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Introduction

Profex is a graphical user interface for Rietveld refinement of powder X-ray diffraction data with
the program BGMN [1]. It provides a large number of convenient features and facilitates the use
of the BGMN Rietveld backend in many ways. Some of the program’s key features include:

• Support for a variety of raw data formats, including all major instrument manufacturers
(Bruker / Siemens, PANalytical / Philips, Rigaku, Seifert / GE, and generic text formats)

• Export of diffraction patterns to various text formats (ASCII, Gnuplot scripts, Fityk scripts),
pixel graphics (PNG), and vector graphics (SVG)

• Batch conversion of raw data scans

• Automatic control file creation and output file name management

• Conversion of CIF and ICDD PDF-4+ XML structure files to BGMN structure files

• Internal database for crystal structure files, instrument configuration files, and predefined
refinement presets.

• Computation of chemical composition from refined crystal structures

• Batch refinement

• Export of refinement results to spread sheet files (CSV format)

• Context help for BGMN variables

• Syntax highlighting

• Enhanced text editors for structure and control file management and editing

• Generic support for FullProf.2k [2] as an alternative Rietveld backend to BGMN.

• And many more. . .

Profex runs on Windows, Linux, and Mac OS X operating systems and is available as free software
licensed under the GNU General Public License (GPL) version 2 or any later version. The latest
version of the program can be downloaded from [3]. This website provides the Profex source
code, bundles of Profex and BGMN for easy installation on Windows and Mac OS X (requiring
zero configuration), and a default set of crystal structure and instrument configuration files.
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1 Search-Match

Before XRD datasets can be processed with Rietveld refinement, the crystalline phases (at least
the main phases) must be identified. This is usually done by extracting the 2θ positions of the
measured peaks and comparing them to peak positions of all known phases stored in a database.
Phases with peak positions matching the observed ones are added to the refinement project. This
is called a search-match process.

Profex implements a different approach to phase identification. Thanks to fast personal computers
and optimized refinement algorithms, it is now feasible to use Rietveld refinement to identify
phases. The algorithm implemented in Profex is similar to the full-profile search-match method
described by Lutterotti et al. [4]. Each phase from a predefined set of phases is individually refined
to the measured dataset with a strongly restricted refinement strategy. A figure of merit (FoM) is
then computed and used to score the phases. After the first cycle, the user can pin matching phases
and repeat the phase matching until no more matching phases are found. A refinement project can
be created from the pinned phases by clicking the Add-Remove-Phase dialog. All pinned phases
will be pre-selected (Fig. 1).

Unlike other search-match software, Profex only searches phases in the internal structure
database. It is not possible to search 3rd party databases such as the COD or ICDD PDF databases.
If no matching phases are found in the internal database, a different program able to access larger
databases can be used.

1.1 Figure of Merit (FoM)

The FoM used to score the phases is in principle similar to the equation proposed in [4]. It differs
in the following points:

Density Instead of comparing the initial density with the refined one, Profex compares initial unit
cell parameters with refined ones.

Weight fraction Instead of the refined weight fraction, Profex uses the raw value of GEWICHT.

Crystallite size and micro-strain Instead of crystallite sizes and micro-strain, Profex uses the raw
parameters B1 and k2.

The following equation is used to compute FoM:

FoM =

(
1

Rwp + a · ∆U
+ b · GEWICHT

)
·
(

1 +
c

B1
+ d · k2

)−1

∆U = 100 ·
(
|Ar − A0|

A0
+
|Br − B0|

B0
+
|Cr − C0|

C0

)
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Figure 1: The pages ,,Database”, ,,Controls”, and ,,Results” of the Search-Match dock widget.

A0, B0, and C0 are the intial unit cell parameters, and Ar, Br, and Cr are the refined ones. If B0

and Br or C0 and Cr are not given in the structure files, for example in high-symmetry structures,
they are set to their equivalents of A. Parameters a, b, c, d are weighing coefficients to control the
influence of the penalty functions for aberrations in cell parameters, small crystallites, and high
micro-strain.

a, b, c, d, as well as thresholds for c and d can be set in ,,Edit→ Preferences→ BGMN→ Search-
Match”. Thresholds for c and d are defined as follows:

c = 0 i f B1r < B1th

d = 0 i f k2r < k2th

B1r and k2r are refined values, and B1th and k2th are threshold values also set in the preferences.

1.2 Elimination of duplicates

Once one or more phases have been pinned, the search-match algorithm tries to identify dupli-
cates of the pinned phases and skip them in the next search-match run. This strongly improves
matching of weak phases, because duplicates of strong pinned phases would always be found
at the top of the score list. By skipping duplicates the chances for unidentified weak phases to
appear at the top of the score list improve drastically.

Phase B is considere a duplicate of phase A if all of the following criteria are fulfilled:

1. The international tables space group number of B is identical to A.
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2. The Hermann-Mauguin symbol of B is identical to A.

3. None of the unit cell parameters of B differs from A more than a specified value (in nm).

4. None of the unit cell angles of B differs from A more than a specified value (in ◦).

The thresholds for unit cell parameters and angles can be customized in the preferences (see part
3 of the user manual). Parameters given by the symmetry are not used for duplicate identification.
For example in a cubic structure only the cell parameter a is used, because b, c, α, β, and γ are given
by the symmetry. In a triclinic structure all six parameters are compared to identify duplicates.

1.3 Performance optimizations

Matching large numbers of phases by refining each of them to the measured dataset is very com-
putation intensive. The first and most important measure to speed up the search-match process is
to define a list of favorite phases and only search in the favorites subset of the database. Setting
favorites is described in section 18.

The process can further be accelerated by limiting the maximum number of iterations and an-
gular range. These and more parameters can be set in the ,,Controls” tab of the ,,Search-Match”
widget:

ITMAX Sets the maximum number of refinement iterations for each cycle. A value of 20 is recom-
mended. Lower values may abort the refinement before it converges, which may impair the
phase scoring. Higher values lead to excessively long processing time.

Set WMIN Clips measured data below a 2θ angle of WMIN. Set the value just below the first
visible peak to speed up the refinement.

Set WMAX Clips measured data beyond a 2θ angle of WMAX. Setting it to a value below the
upper end of the measured range speeds up the refinement. However, do not exclude im-
portant peaks.

Allow anisotropic parameters Normally the BGMN parameter ONLYISO is set to Y to only allow
isotropic refinement. This not only speeds up the search-match process, but it also improves
the score. Anisotropic refinement may lead to a lot of false positive matches. However, for
the final cycles, when only trace phases are left to identify, allowing anisotropic refinement
may improve the score of matching phases.

Refine sample height displacement This parameter has no influence on the performance. How-
ever, it affects the score of matching phases. If no sample height displacement is present,
now refining EPS2 improves the score of matching phases and reduces false positives, be-
cause the penalty function of aberrations in unit cell parameters has a stronger influence.
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1.4 Step-by-step: Identifying phases in a new dataset

First cycle:

1. Load the raw data file.

2. Go to the ,,Search-Match” dialog (if closed: Window→ Search-Match).

3. In the tab ,,Database” select in which database to search.

4. In the tab ,,Instrument” select the instrument configuration and radiation used to measure
the sample.

5. In the tab ,,Refinement” set ITMAX to 20, WMIN to below the first visible peak, uncheck
,,Set WMAX”.

6. Leave ,,Allow anisotropic parameters” and ,,refine sample height displacement” unchecked.

7. Leave the settings in the ,,Scoring” tab unchanged.

8. Start the search-match process by clicking ,,Run→ Search-Match”.

After the first cycle, check the score list for matching phases:

1. Click on the best matching phase (highest FoM) to display the hkl lines.

2. If the hkl lines fit, check the phase by clicking the checkbox in front of the file name.

3. Click the button to pin the checked phase.

4. Repeat the search-match process as described above.

Repeat the second part until all peaks are assigned to a phase. Then open the ,,Add-Remove
Phase” dialog (section 3.2) to create a refinement project. The pinned phases will be pre-selected.
Proceed with the Rietveld refinement.

1.5 Step-by-step: Identifying phases in an existing project

If a refinement project has already been created but additional peaks are observed, proceed as
follows:

1. Go to the ,,Search-Match” dialog (if closed: Window→ Search-Match).

2. In the tab ,,Database” select in which database to search.

3. Check the settings in all other tabs as described in the previous section.

4. Start the search-match process by clicking ,,Run→ Search-Match”.

The phases already found in the refinement project are immediately added as pinned phases to
only search the residual signal. The fit during search-matching may look worse than during the
Rietveld refinement before. This is due to the control file being bypassed during the phase match-
ing. Once the normal Rietveld refinement continues, the control file will be effective again.
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2 Refinement Projects

The BGMN refinement backend requires several text or binary input files to start a refinement,
and it generates more text output files after completing the refinement. In Profex’ terminology,
all files belonging to a refinement constitute a ,,refinement project”, or just ,,project”. Projects
typically include a raw data scan file, a refinement control file (*.sav), instrument configuration
files, and crystal structure files (*.str). After the refinement, BGMN will have generated several
results files, of which the refined profile (*.dia) and list file (*.lst) are the most important ones.
It is strongly recommended to use the same base name for the raw scan file, refinement control
file, refined profile file, and list file. When following the workflow in section 3, correct file names
will be generated automatically. More information about project file structure, specifically about
projects sharing the same structure and device files, is given in section 4.1.

Important: BGMN requires an instrument configuration file (device file) precisely describing the
instrument setup used to acquire the raw dataset. If the device file of a different instrument is
used for the refinement, or if it does not precisely describe the configuration used, the following
problems will occur during the refinement:

• BGMN will not be able to fit the peak shapes correctly. The fit will converge with a high χ2

value and major differences between the observed and calculated scans will remain.

• Some refined parameters will be wrong. Typically the refined crystallite size (parameter B1),
micro-strain (parameter k2), and atomic parameters (x, y, z, TDS) will be biased. Unit cell
parameters and phase quantities will be affected to a lesser degree, but will also be biased if
major discrepancies between the used instrument configuration and the device file exist.

Section 7 describes how to create device files. Note that any change to the instrument setup will
require a new device file (e. g. changing the divergence slit setting or swapping soller slits).
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3 Standard Refinement

When Profex and BGMN have been installed and configured correctly as described in part 1 of
the user manual, and at least one device configuration and structure file has been stored in the
databases, the program is ready for a first refinement. Remember that a device file precisely de-
scribing the instrument configuration used to measure the dataset is required. If no such device
file is available, it is recommended to start with one of the tutorials available on the Profex website
[3] to become familiar with Profex and BGMN, as they include the correct device files.

The following listing shows a step-by-step workflow for a standard refinement. The individual
steps will be discussed in more detail in the next sections.

1. Click ,,File→ Open Graph. . . ”, or alternatively press Ctrl+G or the corresponding button in
the main tool bar.

2. In the opening file dialog set the file format at the bottom to the format of your raw scan file,
and open the file. See Tab. 1 for supported file formats.

3. The scan will be loaded as a new project.1

4. Double click on the strongest peak or select a reference structure from the reference structure
dropdown menu to identify your main phase.

5. Click ,,Edit → Add / Remove Phase. . . ”, or press F8 or the corresponding button in the
project tool bar create a control file. The dialog shown in Fig. 2 will be shown.

6. Select your instrument configuration from the dropdown menu, your phase from the struc-
tures list (it may be pre-selected), and verify that the option ,,Generate default control file”
is active. Then click ,,OK”.

7. Click ,,Run→ Run Refinement. . . ”, press F9, or click the corresponding button in the refine-
ment tool bar to start the refinement.

8. Wait for the refinement to complete.

9. If more phases are present, repeat steps 4–7, but make sure the option ,,Generate default
control file” is not active anymore.

10. If the refinement is complete, click ,,File→ Export Global Parameters and GOALs”, or press
Ctrl+E or the corresponding button in the project tool bar to export the results to a CSV file.

11. Optionally, also click ,,File→ Export Local Parameters and GOALs”, or press Shift+Ctrl+E
or the corresponding button in the project tool bar to export the local results to a CSV file.
This file can be opened in a spreadsheet program such as Microsoft Excel, LibreOffice Calc,
or Softmaker PlanMaker for further evaluation of the results.

1At the first start of the program, all reference structures in the structure database directory will be indexed. Depend-
ing on the number of files and the speed of the computer, this may take up to several minutes. A progress dialog is
shown while indexing is in progress. Wait for the process to complete.
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The steps of opening a scan file, creating a refinement project by adding structure files, and ex-
porting results are described in more detail in the following sections.

3.1 Opening and Closing Scan Files

A refinement usually starts by opening a raw data file. In Profex’ terminology these files are
either called ,,Graph files” or ,,Scan files”, whereas one file contains one or several ,,Scans”. Profex
supports a large number of file formats (Tab. 1), however, the level of support depends on the
availability of documentation for the file format specification. If a format is not supported, or
support is broken, other software such as PowDLL [10] is required to convert the scan to a format
supported by Profex.

Scan files can be opened in various ways:

,,File→ Open Raw Scan File. . . ” menu or toolbar (Ctrl+G): This will open a file dialog to select
one or more graph files. The correct file format must be selected. Important: Several instru-
ment suppliers use the same file extension (*.raw) for different proprietary file formats. It is
important to select the correct format, else Profex will show an error message. For example,
a raw file measured on a Bruker instrument cannot be opened with the file format set to
Rigaku or Stoe raw file.

If more than one file is selected, each file will be opened as a separate refinement project.

,,File→ Insert Scans. . . ” menu or toolbar (Ctrl+I): Similar to the ,,Open Raw Scan File. . . ” func-
tion above, but instead of creating a new refinement project for each file, all scans will be
inserted into one project. If a project is already open, new scans will be inserted into the
existing project.

Drag and Drop: Dragging one or several graph files from a file browser and dropping them on
the Profex main window will open them in new refinement projects.

Ctrl + Drag and Drop: Holding the Ctrl key while dropping one or more scan files will insert them
into the open project. If no project is open, a new one will be created from the first dropped
scan file, and all consecutive scans will be inserted in the new project.

Once the graph file is loaded, Profex will detect whether or not the file is part of a refinement
project. If yes, the control and list files will be loaded automatically. If not, a refinement control
file has to be created for the project in order to run the refinement (section 3.2).

Text files can be opened in text editors using ,,File → Open Text File. . . ”. Profex will check if a
project with the same base name is already open. If yes, the text file will be opened in a new
tab of the project. This is convenient to open various output files (*.lst, *.par), as they are part of
the project. If no matching project was found, the text file will be opened in a new project. One
exception to this rule are structure files (*.str). They belong to a refinement project with a different
base name. Therefore, structure files are always opened as new tabs in the current project. Only if
no project is loaded, opening a structure file will create a new empty project.
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Table 1: Data file formats supported for import by Profex. Level of support (LoS): A = full sup-
port based on the file format specification, including multi-range files; B = good support, reverse-
engineered; C = basic support, reverse engineered.

Manufacturer Extension File format Version LoS

Bruker *.raw Binary V1, V2, V3, V4 A
Bruker *.brml XML Compressed archive A
Bruker *.brml XML Single XML file with XML data

container
A

Bruker *.brml XML Single XML file with binary
data container

A

PANalytical *.xrdml XML 1.0 - 1.5 A
Philips *.rd Binary - C
Philips *.udf ASCII - C
Seifert/FPM *.val ASCII - B
Rigaku *.bin Binary - C
Rigaku *.dat, *.rig, *.dif ASCII - C
Rigaku *.raw Binary - C
MDI Jade *.xml XML - C
MDI Jade *.dif ASCII - C
STOE *.pro ASCII - C
STOE *.raw Binary - C
Thermo Fisher *.raw Binary - C
Generic *.xy ASCII Field separators: ; : , space tab

Comment signs: ! % & #
A

BGMN *.dia ASCII - A
Fullprof.2k *.prf ASCII Only PRF=3 A
Fullprof.2k *.dat ASCII Only INS=10 A
GSAS *.fxy, *.fxye ASCII GSAS Standard Powder File A
pdCIF *.cif ASCII Supported tags:

pd meas 2theta scan
pd proc 2theta corrected
pd meas counts *
pd proc counts *
pd calc intensity *
pd meas intensity *
pd proc intensity *

A
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Individual files can be closed by clicking on the ,,Close Tab” symbol on the tab bar. Structure files
can also be closed by clicking ,,Project→ Close all Project STR files”.

The current project can be closed by ,,File→ Close Project” (Ctrl+W). If more than one project is
selected in the Projects dock window, all selected projects will be closed. To close all open projects
at once, click ,,File→ Close all projects”.

3.2 Adding and Removing Structure Files

One of Profex’ central components is the ,,Add / Remove Phase” dialog (Fig. 2). It is accessed
by clicking ,,Project→ Add / Remove Phase. . . ”, or pressing F8 or the corresponding button on
the project tool bar. This dialog is used to easily create or modify the refinement control file.
It will automatically add a STRUC[n] reference and related GOALs for phase quantification to
the control file, and copy the selected STR files from the structure file database to the working
directory (Fig. 4). The individual elements of this dialog are described in detail below.

Generate default control file: If this option is checked, Profex will generate a default control file
for the selected instrument configuration. If a template file is found, it will be used to cre-
ate the control file. Else Profex will present a dialog asking for basic information about the
instrument configuration (Fig. 3). If the option is active, an existing control file will be over-
written. The default state of this option depends on the presence of a previous control file:

• If a control file was found, this function will be unchecked. Manually activating the
option will overwrite the existing control file with a newly created default file.

• If no control file was found, this function will be active.

Instrument configurations: This dropdown menu lists all instrument configurations found in the
device database directory.

Add phases: This list shows all structure files found in the structure file database directories. Files
stored in a sub-directory will be shown in a tree structure that can be collapsed or expanded.
Clicking on the header of the table (,,File Name”, ,,Phase”, or ,,Comment”) will sort the
table in ascending or descending order of the clicked column. Structures selected in the first
column will be added to the control file. If a reference structure is shown on the main graph,
it will be pre-selected in this dialog.

The structure file list can be filtered by entering a search string in the filter line. The filter is
applied instantly. Clear the line to display all structure files. The filter options menu allows
to configure whether or not filtering will be case-sensitive, whether or not the search string
will be interpreted as a regular expression pattern, and in which columns the filter string
will be searched for.

If using regular expressions is not selected, only the wildcard characters ,,*” and ,,?” are
evaluated. Activating regular expressions allows to make use of powerful regular expression
patterns for filtering. Tutorials and documentation on regular expressions can be found on
the internet.
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Expand/Collapse: If structure files are organized in sub-directories in the structure database di-
rectory, they will be organized in a tree structure in this dialog. Clicking ,,Expand/Collapse”
will expand or collapse all items in the tree structure for easy navigation.

Overwrite existing files: If a selected structure file is already present in the project directory, it
will normally not be overwritten. This preserves customized files. Checking this option will
force overwriting of existing files. Use this option with care, as other projects accessing the
same structure files will be affected, too.

Favorites: If checked, only the phases flagged as favorites in the 4th column are displayed.

Remove Phases: The phases listed here are currently referenced in the control file. Check the
ones that shall be removed from the refinement.

Delete Files: If this option is checked, the removed file will also be deleted from the hard disk
in the project directory. This may cause problems with other projects residing in the same
directory and referencing the same structure file. It is recommended to use this option with
care.

If the control file contains multiple references to the same structure file, only the first occur-
rence will be removed. In that case, the option ,,Delete STR Files” will be ignored until the
last reference to this file was removed from the control file.

Note that only copies of structure files in the local project directory will be deleted. The
structure file database directory will remain unchanged.

The ,,Add / Remove Phase” dialog will not allow to add the same phase more than once to a
control file. If a selected file is already referenced in the control file, it will be skipped by the dialog.
If multiple entries of the same structure file are requested, the control file has to be modified by
hand.

After clicking ,,OK” to apply the configuration, Profex will copy the structure and device files to
the project directory, and create or modify the refinement control file as shwon in Fig. 4.
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Figure 2: The ,,Add / Remove Phase” dialog is used to create a new project. If a project already
exists, it is used to append more phases, or remove phases from the project.

Figure 3: If no instrument template
file is found, a dialog will ask for ba-
sic information on the radiation and
monochromatization.
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Structures database

Albite.str
Barite.str
Calcite.str
Dolomite.str
Ettringite.str
Fluorite.str
Gypsum.str
Hematite.str
Illite.str
Jade.str
Kaolinite.str
Lime.str
Magnesite.str
Nahpoite.str

Devices database

Instrument1.tpl
Instrument1.sav
Instrument1.ger
Instrument1.geq
Instrument2.tpl
Instrument2.sav
Instrument2.ger
Instrument2.geq
Instrument3.tpl

Project directory

myscan.xrdml

myscan.sav

Instrument1.sav
Instrument1.ger
Instrument1.geq

Calcite.str
Dolomite.str
Magnesite.str

Copies files from
database directories
to project directory

Modifies *.str files
if requested

Converts instrument
template (*.tpl) file to

control file (*.sav)

"Add Phase" Dialog

Figure 4: The ,,Add / Remove Phase” dialog will copy structure files and device files from the
database directories to the project directory. Files already existing in the project directory will not
be overwritten, unless the option is checked manually in the ,,Add / Remove Phase” dialog.
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3.3 Exporting data

3.3.1 Refinement results

CSV tables At the end of a refinement, Profex shows a summary of global parameters and
GOALs, refined local parameters, and the refined chemical composition in the summary dockable
windows. These values are read from the LST output file. Local parameters can be customized in
the preferences as described in part 3 of the user manual. Profex allows to easily export the global
and local refined parameters of all open projects to spreadsheet files:

,,Results→ Export Global Paramters and GOALs” will write the global parameters and goals of
all open projects to a CSV file.

,,Results→ Export Local Paramters” will write the local parameters of all open projects to a CSV
file.

,,Results→ Export refined chemical composition” will export the chemical composition (see
section 12) to a CSV file.

The exported files are text files containing semicolon-separated fields. Open the file in a spread-
sheet program and specify the semicolon character as a field separator. Since the exported files
also contain the source file name, using the spreadsheet program’s sorting function allows easy
sorting and statistical evaluation of the results. The following listing shows what the exported
CSV file with global parameters and goals looks like when opened in a text editor. Table 2 shows
how the same data looks after importing and sorting in a spreadsheet program.

File;Sample;Parameter / Goal;Value;ESD
<path>/scan1.lst;scan1;alphaTCP/sum;0.0311;0.0023
<path>/scan1.lst;scan1;hap/sum;0.9689;0.0023
<path>/scan2.lst;scan2;alphaTCP/sum;0.0161;0.0022
<path>/scan2.lst;scan2;hap/sum;0.9839;0.0022
<path>/scan3.lst;scan3;alphaTCP/sum;0.0147;0.0024
<path>/scan3.lst;scan3;hap/sum;0.9853;0.0024

3.3.2 Graphs

Scans shown in the plot area can be exported to various formats. Depending on the export format,
some information may get lost if it is not supported by the output format. Scans can be exported
as follows:

1. Make sure the graph to be exported is shown by selecting the project and showing the
,,Graph” tab.

2. Select ,,File→ Save File As. . . ”.
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Table 2: Global parameters and GOALS exported from Profex and sorted by the ,,Paramter / Goal”
column. Sorted like this, mean values and standard deviations can easily be calculated.

File Sample Parameter / Goal Value ESD

<path>/scan1.lst scan1 alphaTCP/sum 0.0311 0.0023
<path>/scan2.lst scan2 alphaTCP/sum 0.0161 0.0022
<path>/scan3.lst scan3 alphaTCP/sum 0.0147 0.0024
<path>/scan1.lst scan1 hap/sum 0.9689 0.0023
<path>/scan2.lst scan2 hap/sum 0.9839 0.0022
<path>/scan3.lst scan3 hap/sum 0.9853 0.0024

3. Select the format for the export in the file format dropdown menu.

4. Specify the file name and save the file.

Profex exports some generic file formats, and some formats specific for other applications. The
generic formats are useful for most users interested in further data processing or creation of fig-
ures. They will be discussed in further detail in the following paragraphs.

Pixel image (PNG) Pixel image export will write the file to a Portable Network Graphics (PNG)
image. A dialog will open to ask for the output size in pixels. PNG uses lossless compression,
therefore relatively small files free of compression artifacts will be created.

If the line width or font size is too small, it will have to be changed prior to the export in the graph
preferences (see part 3 of the user manual). Use ,,display line width” to change the export line
width.

All elements visible on screen will be exported, including hkl lines and the legend. Visibility of
the scans will be considered, invisible scans will also be invisible on the exported file. The export
will create a high-resolution image of the on-screen graph.

Pixel images can be edited in any photo editing software, such as Adobe Photoshop, GIMP,
Paintshop Pro, Corel PhotoPaint, and others.

Gnuplot (GPL) Gnuplot [11] is a powerful cross-platform graphing utility able to create quality
graphs in various formats. Scans exported as Gnuplot files are saved as Gnuplot scripts with
inline data. The graphs are a fairly accurate but not perfectly identical representation of the plot
as displayed in Profex. It includes hkl indices, a legend, all selected scans, and it preserves scan
colors and symbol styles. The output file may be edited to optimize the appearance of the Gnuplot
graph or to change the output terminal. Gnuplot code created by Profex version 4.0.x was tested
with Gnuplot versions 4.6 and 5.0.

On a system with a working Gnuplot installation, the following command entered in a terminal
emulator will output the graph ,,scan.gpl” to the default terminal:
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gnuplot −p scan . gpl

Grace plots (AGR) The displayed graph is exported to a file for the Grace plotting program [12].
All colors and hkl tick marks are preserved. Grace is described on wikipedia as follows:

Grace is a free WYSIWYG 2D graph plotting tool, for Unix-like operating systems.
The package name stands for ,,GRaphing, Advanced Computation and Exploration
of data.” Grace uses the X Window System and Motif for its GUI. It has been ported
to VMS, OS/2, and Windows 9*/NT/2000/XP (on Cygwin). In 1996, Linux Journal
described Xmgr (an early name for Grace) as one of the two most prominent graphing
packages for Linux.

A modern incarnation of grace is available for all major platforms [13].

Scalable vector graphics (SVG) Scalable vector graphics (SVG) is a resolution-independent vec-
tor graphics format ideal for post-processing of graphs. All elements (scans, axes, hkl lines, text)
are exported as editable paths or text elements, allowing to change fonts, sizes, places, colors, line
widths, or add annotations easily in the exported file. It is the most powerful and flexible of all
export formats to create high-quality figures. However, it may be necessary to use vector drawing
software and convert the format before importing into a word processor, as some programs do
not import SVG files directly.

All modern webbrowsers are capable of viewing SVG files natively. SVG files can therefore be
viewed and printed easily on all operating systems without requiring any additional software.
In order to edit the files, a vector drawing program such as Adobe Illustrator, Inkscape, Corel
DRAW, or others is necessary. Note that not all vector drawing programs interpret SVG files
correctly. Wrong SVG drawing may need manual optimization.

The recommended workflow to add a scan to a manuscript in high quality is the following:

1. Exort the scan to SVG as described above.

2. Open or import the SVG file in a vector drawing program of your choice.

3. Make sure the SVG file looks as expected. Modify if necessary.

4. Select the entire plot and copy to the clipboard.

5. Special-paste it into the word processor or presentation program, for example as an extended
metafile.
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Printing to PDF A PDF printer is available on most operating systems. It allows direct export of
the graph to a PDF file. Prepare the graph as described at the beginning of this section, but use
,,File→ Print. . . ” instead of the ,,Save As. . . ” function. Use the printer dialog to write the output
to a PDF file. The layout and functions are platform specific.

If line widths in the printed document are too fine or too wide, change the printing line width in
the preferences as described in part 3 of the user manual. PDF files can be used directly in LATEX.
Other word processors may need the same conversion as described for SVG files in section 3.3.2.

All open graphs can be printed to a printer or to a single PDF file using the function ,,File→ Print
all graphs. . . ”. Similarly all graphs can be exported to SVG format using ,,File→ Export all graphs
to SVG”. In this case, however, a separate SVG file will be created for each graph.

3.3.3 Scan Data Files

ASCII free format (XY) A generic text format writing the data in columns, starting with the an-
gle, followed by columns with intensities for each scan. These files can be imported in spread-
sheet or plotting software for further processing. Spreadsheet software includes Microsoft Excel,
LibreOffice Calc, SoftMaker PlanMaker, and others. Plotting software includes OriginLab Origin,
GNUplot, and others.

hkl lines will not be exported. Scan colors, line styles, and the legend will also get lost during the
export. Visibilities of scans will be ignored, all scans will be exported. A white space character is
used for field separation.

The following example shows an exported ASCII free format file with all scans written into one
file. The first column contains the x-values (2θ angle), the following columns contain y-values Iobs,
Icalc, Idi f f , Ibackground, and two phase patterns. Note that the phase patterns include the background
intensity:

4.007500 22.000000 21.070000 0.930000 21.050000 21.050000 21.070000
4.022500 19.000000 20.910000 -1.910000 20.890000 20.890000 20.910000
4.037500 20.000000 20.760000 -0.760000 20.740000 20.740000 20.760000
4.052500 22.000000 20.610000 1.390000 20.590000 20.590000 20.610000
4.067500 24.000000 20.470000 3.530000 20.450000 20.450000 20.470000
4.082500 13.000000 20.330000 -7.330000 20.310000 20.310000 20.330000
...

ASCII HKL List (HKL) If the graph contains hkl tick lines, the data will be written to a text file.
The output file starts with a header line, followed by hkl tick mark information of all phases. Note
that the lines are sorted by phase number, not by 2θ angle. An example of an ASCII HKL list file
is shown below:
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"Phase Name" "Angle" "Phase No." "HKL" "Texture"
"Adularia" 22.501230 0 "0 2 1" 1.263500
"Adularia" 24.476712 0 "2 0 -1" 0.915900
"Adularia" 26.213459 0 "1 1 1" 1.328900
...
"Calcite" 26.835628 1 "1 -1 2" 0.968500
"Calcite" 34.275930 1 "1 -1 -4" 1.053900
"Calcite" 36.669943 1 "0 0 6" 1.049000
...
"Plagioclase_Albite" 22.106786 2 "0 2 -1" 1.174800
"Plagioclase_Albite" 23.578835 2 "0 2 1" 1.363700
"Plagioclase_Albite" 25.646178 2 "2 0 -1" 0.723100
...
"Quartz" 24.264737 3 "1 -1 0" 1.029900
"Quartz" 31.030320 3 "1 -1 1" 1.037600
"Quartz" 31.030320 3 "1 -1 -1" 0.970300
...
"Zincite" 37.055257 4 "1 -1 0" 1.000000
"Zincite" 40.184602 4 "0 0 2" 1.000000
"Zincite" 40.184602 4 "0 0 -2" 1.000000
...

Powder CIF file (CIF) The crystallographic information file format (CIF) is not only used to share
crystal structure information, but also raw or refined powder diffraction patterns. Saving a refined
graph file (*.dia) in powder CIF format will create a file that is compliant with the guidelines for
Rietveld papers by the International Union for Crystallography (IUCr) [14]. The project base name
will be used for the data and pd block id tags, which is consistent with structure CIF files
exported from the ,,Results” menu (section 3.3.3).

A truncated example of an exported powder CIF file is shown below.

######################################################################
# Rietveld refinement results for sample 160629-03
# Created with Profex 3.12.0
# Export date: July 28, 2016 - 11:27
######################################################################

data_160629-03
_pd_block_id 160629-03

loop_
_pd_proc_point_id
_pd_proc_2theta_corrected
_pd_proc_intensity_total
_pd_calc_intensity_total
_pd_proc_intensity_bkg_calc
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Figure 5: Export options for CIF
structure files.

1 4.000000 240.2700 238.7400 238.7400
2 4.012300 243.6700 238.9300 238.9300

...
4572 59.999100 147.6700 164.0000 43.3000
4573 60.011400 144.7300 147.1600 43.3300

# The following lines are used to test the character set of files sent by
# network email or other means. They are not part of the CIF data set.
# abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789
# !@#$%ˆ&*()_+{}:"˜<>?|\-=[];’‘,./

CIF files Crystallography information file (CIF file, *.cif) is a standardized file format for the ex-
change of crystal structure information. It essentially contains the same information as BGMN list
files (*.lst) do, however in a very different format. Profex can extract crystal structure information
from *.lst files and write to *.cif files once a refinement has completed and a *.lst file has been
created. In order to export CIF files of several refined projects, proceed as follows:

1. Open all projects you wish to convert to CIF

2. Make sure all projects were refined successfully

3. Select ,,Results→ Export CIF files from LST files”

4. In the project selection dialog, select all project and click ,,OK”

5. A CIF export dialog will be shown (Fig. 19). Set up the output options to your preferences
and click ,,OK”. The individual options will be explained below.
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A truncated example of a single-phase CIF file is shown in Fig. 6. Note that some lines contain
trailing comments of type ,,# <phaseName>”, such as the following lines:

_chemical_formula_structural ? # MgO
_chemical_formula_sum ? # MgO
_chemical_formula_weight ? # MgO

The question mark ,,?” is a placeholder for missing information. It should be filled with informa-
tion by the user. The comment with the phase name (MgO) allows the user to use search-replace
features in text editors to add the missing information efficiently. Some text editors can search
and replace text in multiple files at once. Adding the molecular weight for MgO can thus easily
be achieved, without interfering with other phases, by replacing

_chemical_formula_weight ? # MgO

with

_chemical_formula_weight 40.3044

Fig. 6 also shows placeholder question marks for isotropic B values for both atoms. The reason is
that, unlike fractional coordinates, isotropic displacement parameters are not listed in the BGMN
list file (*.lst) unless they are refined. A simple modification to the BGMN structure file (*.str, in
this case ,,periclase.str”) solves the problem. In order to print fixed TDS values to the *.lst file, add
the instruction GOAL=TDS to the end of the atomic position lines. An example is shown below, in
which the GOAL statement was added to the end of the last two lines:

PHASE=MgO // 04-010-4039
MineralName=Periclase //
Formula=Mg_O //
SpacegroupNo=225 HermannMauguin=F4/m-32/m //
PARAM=A=0.4214_0.400ˆ0.425 //
RP=4 k1=0 k2=0 PARAM=B1=0_0ˆ0.01 GEWICHT=SPHAR4 //
MAC=10000*my/density
GOAL=MAC
GOAL=GrainSize(1,1,1) //
GOAL:MgO=GEWICHT*ifthenelse(ifdef(d),exp(my*d*3/4),1)
E=MG+2 Wyckoff=a x=0.0000 y=0.0000 z=0.0000 TDS=0.0031583 GOAL=TDS
E=O-2 Wyckoff=b x=0.5000 y=0.5000 z=0.5000 TDS=0.0033951 GOAL=TDS

After repeating the refinement and re-exporting the CIF files, the atomic positions section now
includes correct values for atom site B iso or equiv:
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loop_
_atom_site_label
_atom_site_type_symbol
_atom_site_occupancy
_atom_site_fract_x
_atom_site_fract_y
_atom_site_fract_z
_atom_site_B_iso_or_equiv
MG1 MG 1.00000 0.00000 0.00000 0.00000 0.31583
O2 O 1.00000 0.50000 0.50000 0.50000 0.33951

Export options

One single-phase CIF file per phase If several projects are to be processed and each project con-
tains several phases, one CIF file will be created for each phase. The file name will automat-
ically be set to <projectName>-<phaseName>.cif. Existing files will be overwritten
without warning. The created file names will be shown in the refinement output console.

One multi-phase CIF file per project One CIF file per project will be generated. The CIF file
contains all phases found in the project. The output name will be set automatically to
<projectName>.cif. Existing files will be overwritten without warning. The created
file names will be shown in the refinement output console.

One global multi-phase CIF file All phases found in all projects will be exported to one single CIF
file. The user will be prompted to enter the file name.

Temperature Select the temperature at which the diffraction data was collected in Kelvin (K). To
reset the value to room temperature, click the ,,RT” button. The value will be used for the
CIF tag diffrn ambient temperature.

Instrument Select the name of the instrument used for the diffraction experiment. If the
instrument is not available from the dropdown menu, create a new one by clicking
the ,,+” button. The name can be chosen freely. It will be used for the CIF tag
diffrn measurement device type.

Radiation Source Select the type of radiation used for the diffraction experiment. The value will
be used for the CIF tag diffrn radiation probe

GSAS Standard Powder Data File GSAS standard powder data files are exported in constant
stepwidth (BINTYP=CONS) with one record per line consisting of the position in centidegrees and
the intensity (TYPE=FXY). Graphs containing multiple scans are exported to a single file contain-
ing multiple banks.
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CELL Files This function reads RES files of all open projects and writes crystal structure infor-
mation to CELL files for the software Castep [8]. One CELL file will be created for each crystal
structure found. The file will be stored in the project directory. Information on saved files is
shown in the refinement protocol console. If no RES file is available for a specific phase, a tag
RESOUT[n]=filename.res must be added to the control file (*.sav) and the refinement must be
repeated. The CELL files contain cartesian atomic coordinates.
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4 Opening Refinement Projects

Once a refinement has been completed, the Rietveld refinement backend BGMN will write vari-
ous output files. One of them, the diagram file (*.dia), contains the refined profile, typically the
measured and calculated intensities, the background curve, phase contributions, and hkl indices.
Refinement projects can be opened in Profex by selecting ,,File→Open Refinement Project. . . ” (or
pressing ,,Ctrl+R”) and selecting the refined profile file (*.dia).

4.1 Project structure

When working with several datasets (= projects) at a time, it is important to understand how Pro-
fex’ ,,Add / Remove Phase” function handles structure and instrument files in the background.

By default the ,,Add / Remove Phase” dialog will copy selected structure and instrument files to
the location of the currently loaded scan file as shown in Fig. 2. It will check whether a file with
the same name is already present. If yes, the present file will not be overwritten, unless the option
,,overwrite existing files” was activated for structure files, and ,,generate default control file” was
activated manually for instrument files.

Since several raw scan files can be located in the same directory, a structure file will only be present
once, even if it was added multiple times for each project. Modifying, removing, or overwriting
this structure file will affect all projects within this directory (Fig. 7).

If common structure files are not desired, there are several options to avoid shared access by
multiple projects:

• Distribute the raw scans on several sub-directories, as shown in Fig. 7. The ,,Add / Remove
Phase” dialog will have to be called for each project separately, but each project will receive
it’s own copy of the instrument and structure files.

• Manually manage the structure files. E. g. create a copy of structure 1.str and name
it structure 1a.str. Then change the STRUC[1]=structure 1.str line in the corre-
sponding control file to STRUC[1]=structure 1a.str.

• Manually manage structure files by creating sub-directories for structure files only.
E. g. create a copy of structure 1.str in strFiles 1/structure 1.str. Then
change the STRUC[1]=structure 1.str line in the corresponding control file to
STRUC[1]=strFiles 1/structure 1.str. The project directory remains unchanged,
but it will access the structure files in a specific sub-directory, which can be managed
manually for each project.
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Projects sharing structure files

working directory
scan 1.sav
scan 2.sav
structure 1.str
structure 2.str

scan 1.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

scan 2.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

Projects in sub-directories

working directory
project 1

scan 1.sav
structure 1.str
structure 2.str

project 2
scan 2.sav
structure 1.str
structure 2.str

scan 1.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

scan 2.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

Manually renamed structure files

working directory
scan 1.sav
scan 2.sav
structure 1a.str
structure 2a.str
structure 1b.str
structure 2b.str

scan 1.sav:
STRUC[1]=structure 1a.str
STRUC[2]=structure 2a.str

scan 2.sav:
STRUC[1]=structure 1b.str
STRUC[2]=structure 2b.str

Structure files in sub-directories

working directory
scan 1.sav
scan 2.sav
strFiles 1

structure 1.str
structure 2.str

strFiles 2
structure 1.str
structure 2.str

(a) File structure

scan 1.sav:
STRUC[1]=strFiles 1/structure 1.str
STRUC[2]=strFiles 1/structure 2.str

scan 2.sav:
STRUC[1]=strFiles 2/structure 1.str
STRUC[2]=strFiles 2/structure 2.str

(b) Control file content

Figure 7: Projects and structure files can be organized in different ways, depending on whether
structure and instrument files shall be shared or not.
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5 Refinement Report

Results of a refinement can be exported to a report in HTML format. After the refinement has
completed, select ,,Results→ Generate report. . . ”. A HTML file will automatically be created in
the project directory and opened in a web browser. The location of the report file is shown in the
refinement output console. An example of a report in the default layout is shown in Fig. 8. The
report can be printed to paper or PDF format from the web browser.

5.1 Customizing the report

The information added to the report can be customized to a certain degree in the preferences
(,,Edit→ Preferences→ BGMN→ Refinement Report”).

5.1.1 Structure

The information exported in the report, and the structure of the document, can be customized to
a certain degree in the tree view of the ,,Structure” page (Fig. 9a). The sections added by default
cannot be removed. However, they can be deactivated by unchecking the section item, and the
text used for the section heading can be changed by double-clicking on the ,,Text/Value” column.
Using the arrow buttons, the sections can be moved up or down in the tree to rearrange the doc-
ument structure. Changing the heading text allows to change for example the heading ,,Global
GOALs” to ,,Phase quantities” if the global GOALs table only contains phase quantities. The re-
port thus becomes more easily understandable for readers who are not familiar with the BGMN
nomenclature.

The content of the selectable sections is described below.

Sample information contains the sample ID, file names, date of refinement, instrument configu-
ration, wavelength file, and working directory of the project.

Operator name contains the operator name to be added to the sample information table. The
operator name can be omitted by unchecking this line. By default, the user name of the user
generating the report is used.

Refinement statistics adds a line with Rwp, Rexp, χ2, and goodness of fit to the sample information
table.

Gloabl GOALs creates a table with global GOALs, as customized on the ,,Summary tables” page
of the preferences dialog.

Diffraction pattern adds the currently displayed pattern (can be a raw dataset or a refined *.dia
file) as a figure to the report.
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(a) Document structure

(b) Custom banner (c) Style sheet

Figure 9: The HTML report can be customized in the preferences dialog.
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Aspect Ratio change the aspect ratio of the diffraction pattern. The width is always 100 % of the
page width, and the height will be set to the width divided by ,,Aspect ratio”. This is helpful
if the diffraction pattern is too high to fit on a page and causes a page break between the
heading and the figure.

Local GOALs adds a table with phase-specific local goals, as customized on the ,,Summary ta-
bles” page of the preferences dialog.

Chemical composition add a table with the refined chemical composition. It is important to as-
sign all quantification goals correctly in the ,,Chemical composition” table, else the table in
the report will be incomplete.

Peak list adds a list of hkl peaks generated for the refinement and read from the *.par file.

In addition to the predefined sections, one can add page breaks at specific positions to avoid page
breaks between headings and the following tables or figures.

Custom sections allow to insert plain HTML code in the report. Select the section item preceding
the custom section, then click ,,Add custom section”. In the following dialog, enter a name for the
section (it will not be used as a heading) and enter plain HTML code in the editor. For example,
the code shown in Fig. 10 adds a horizontal ruler (horizontal line) at the position of the custom
section.

Figure 10: A custom section adding a hori-
zontal line to the document.

5.1.2 Header

By default, the report uses a ,,Profex” banner at the top of the first page. This banner can be
replaced with a custom one to match the corporate design. Banners must be saved as scalable
vector graphics (*.svg) and can be created with Inkscape, Adobe Illustrator, or any software able
to write SVG files.
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Select a custom banner by clicking the button on the ,,Header” page. A preview of the selected
banner is shown below the file name (Fig. 9). When the ,,Logo” line is empty, Profex defaults to
the internally stored Profex logo.

5.1.3 Style

The colors, font, and layout of the tables and headings can be customized as well. Profex uses
CSS styls sheets for the HTML layout. A custom style sheet can be specified on the ,,Style” page.
Alternatively, disable the CSS style sheet and specify a font and colors for tables directly. The
width of the diffraction pattern can also be specified in % of the page width to avoid unfavorable
page breaks when printing the report. Fig. 11 shows an example of a report adapted to a corporate
design.
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Figure 11: A report using a custom header logo and color scheme, shown in the print-preview of
a web browser.
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6 Sharing Refinement Projects with other Users

Opening a refinement project created on one platform (either Windows or OS X / Linux) on an-
other platform (OS X / Linux or Windows) will cause an error message as soon as the refinement is
started. This is due to the fact that both types of platforms use different characters for line endings
in text files, and BGMN only accepts the format native to the platform it is used on.

To avoid these error messages, use the backup feature to share projects as described below. It
automatically converts the files to the target platform.

On the source computer:

1. In Profex click ,,Project→ Save project backup” to create a *.zip file with all required scan,
control, structure, and instrument files.

2. The name of the created file will be shown in the ,,Refinement Protocol” console.

3. Share the *.zip file with the recipient.

On the recipient’s computer:

1. Save the received *.zip file at the location where you want to process it.

2. In Profex click ,,File→ Open Project Archive. . . ” to open the *.zip file.

3. Run the refinement.

The *.zip file will be extracted and the file formats will be converted to the target platform’s text
file format.
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7 Creating Instrument Configuration Files

The Rietveld refinement software must be able to precisely describe the measured peak shape
with a mathematical model to obtain accurate fits of measured diffraction peaks. BGMN uses the
fundamental parameters approach (FPA), and thus raytraces the peak shape from the diffractome-
ter’s hardware configuration rather than fitting it to a measured reference pattern. Very detailed
hardware information must be specified by the user in order to obtain a correct peak shape model.
But in return, FPA peak shapes often describe strongly asymmetric peaks at very low diffraction
angles more realistically and accurately than generic peak profile functions. FPA peak shapes can
also be computed at any 2θ angle, whereas measured peaks of a reference material can only be
fitted from the 2θ position of the first peak upwards. Extrapolation to lower angles introduces
increasingly severe errors.

Profex includes a set of hardware configuration files. But very often these configurations differ
to a certain degree from configurations used by other users. Applying even a slightly wrong
configuration file will result in poor quality of fits and most likely in wrong results. Using an
instrument configuration file not specifically created for the instrument in use is thus strongly
discouraged. This tutorial describes how to customize an instrument configuration file for one’s
own use.

It is much easier to adapt one of the existing configuration files than to create a new file from
scratch. Profex includes default files for instruments manufactured by Bruker, PANalytical,
Rigaku, and Siemens, with various old and modern detectors and beam path configurations. Nor-
mally the type of instrument and some basic hardware information is given in the file name. For
example ,,D8-. . . ” and ,,D2-. . . ” refers to Bruker D8 or D2 instruments, and ,,xpert-. . . ” and
,,cubix-. . . ” to PANalytical X’Pert or CubiX instruments. Often the file name also contains infor-
mation about the divergence slit mode (fds = fixed divergence slit, ads = automatic divergence slit)
and detector (xcel = PANalytical X’Celerator, pixcel = PANalytical PIXcel, LynxEyeXE = Bruker
LynxEye XE etc.).

Step 1: Select and open an existing instrument configuration file

Start Profex and select ,,Instrument→ Edit Configuration. . . ” from the menu. The file dialog will
open in the Device file database. Try to find a configuration file that matches your own configu-
ration as closely as possible. Open a file that seems to reasonably describe your own hardware. If
none seems reasonable, open any arbitrary file. A dialog showing the content of the instrument
configuration file will open (Fig. 12).

Step 2: Edit the existing instrument configuration

Most instrument configuration files start with a comment header with some information on the
creator and instrument. Adapt this header to your own instrument. Lines starting with ,,%” are
comments ignored by the software.

Next you will have to go through the entire file line by line and make sure all parameters are set
correctly for your own instrument. Change the parameters if necessary. If you don’t know some
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Figure 12: ,,Instrument → Edit Configuration. . . ” opens a dialog to edit an existing instrument
configuration.

of the parameters, you will have to figure them out. Study the settings in your diffractometer
control software, read the diffractometer manual, or take a ruler and measure the parameter at
your instrument.

Instrument configuration files shipped with Profex contain detailed comments describing the pa-
rameters, and also often giving additional useful information. A full specification of the device
file format is given on the BGMN websites [1]. When going through the file line by line, all optical
elements in the beam paths must be described accurately as described in Fig. 13. If one optical
element is not installed, either delete or deactivate the lines by adding ,,%” to the beginning of the
line.

The opening of divergence and anti-scatter slits must be given in millimeters. However, for fixed
slit configurations the opening is often specified in degrees as the angle of beam divergence. In
that case, the slit width in mm can be calculated from the beam divergence angle and the position
of the slit directly in the instrument configuration file. The relevant code section is shown below.
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Figure 13: Schematic representation of the instrument parameters to be entered in the instrument
configuration file (reproduced from [1]).
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This code can be used for all instruments using a fixed divergence or anti-scatter slit opening, if
the slit opening is specified as beam divergence in degrees:

%--------------------------------------------------------------------
% Divergence slit
%--------------------------------------------------------------------

% beam divergence (degrees)
div=0.25

% distance from sample (mm)
HSlitR=100

% fixed divergence slit width (mm)
HSlitW=2*tan(div*pi/360)*(R-HSlitR)

For variable slit configurations, the opening of the divergence slit in mm changes as a function of
the 2θ position. The slit width can also be calculated with the formula shown below. The same
formula can be used for all instruments using variable slit width. Note: The line break in the line
starting with HSlitW= is only used here due to limited line width, but it is not allowed in the
configuration file:

%--------------------------------------------------------------------
% Divergence slit
%--------------------------------------------------------------------

% irradiated length (mm)
irr=10

% distance from sample (mm)
HSlitR=100

% automatic divergence slit width (mm)
HSlitW=(2*(R-HSlitR)*irr*sin(pi*zweiTheta/360))

/(2*R+irr*cos(pi*zweiTheta/360))

At the bottom of the file, find the following section:

%--------------------------------------------------------------------
% Parameters for the simulation of the profile function
%--------------------------------------------------------------------

% angular positions for the MonteCarlo simulation (deg 2theta)
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zweiTheta[1]=4
zweiTheta[2]=8
zweiTheta[3]=13
zweiTheta[4]=20
zweiTheta[5]=30
zweiTheta[6]=42
zweiTheta[7]=56
zweiTheta[8]=76
zweiTheta[9]=90
zweiTheta[10]=105
zweiTheta[11]=120
zweiTheta[12]=135
zweiTheta[13]=150

% angular range (deg 2theta)
WMIN=4
WMAX=150

Make sure that the list of zweiTheta[ ] values and WMIN / WMAX cover the identical range.
The range must cover the entire angular range you intend to measure with this configuration2. If
unsure, select a very wide range, e. g. from 4 to 150◦ 2θ. If you modify the list of zweiTheta[ ],
make sure the parameters are numbered consecutively (starting at 1, no gaps).

Once the file has been completely revised and all parameters have been matched to the user’s
hardware configuration, save the file under a new name (ideally in the device file directory) using
the ,,Save As. . . ” button. Give it a meaningful name, as with the default configuration files.

Step 3: Prepare the template file and run the calculation

Before running the calculation, check the settings in the ,,Control File Template” tab below the
text editor. Profex uses a template control file with each instrument configuration (Fig. 14). An
example will be shown later.

Go through the following steps:

• Choose whether you want to create a control file template for an instrument using a conven-
tional cathode ray tube, a synchrotron beamline, or no template at all.

• For cathode ray tube:

– select the type of radiation your instrument uses (,,cu” for characteristic copper radia-
tion, ,,co” for cobalt, ,,mo” for molybdenum, ,,cr” for chromium). Don’t use any of the
other emission profiles unless you know what you are doing.

2The angular range specified here is a common source of errors. If a dataset exceeding the range (e. g. starting below
WMIN or ending beyond WMAX is to be refined, BGMN will abort with an error message ,,insufficient angular range”.
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Figure 14: Options for control file templates.

– Check whether your instrument uses a Kβ filter or monochromator crystal. In the lat-
ter case, specify the monochromator angle (the default of 26.60 degrees is correct for
Graphite monochromators set up for CuKα radiation.)

• For synchrotron:

– enter the wavelength in nm.

Step 4: Run the calculations

Now click ,,Run” to start the calculation of the peak profiles and the interpolation. You may see
a warning message that the output file names do not match the configuration file name (Fig. 15).
Profex suggests to fix it, so just click ,,Yes”. The message is shown because the variables ,,VERZ-
ERR” and ,,GEQ” at the beginning of the instrument configuration file were not changed to the
new file name given in the ,,Save As. . . ” dialog.

Once the calculation started you will see some output information printed to the ,,Output” console
(Fig. 16). The calculation takes several minutes, just wait for completion.

After completion, three new files have been created: <config-name>.ger, <config-name>.geq,
and <config-name>.tpl. The *.tpl file is the template for the refinement control file Profex will use
for each refinement project. It can be opened in a text editor. If any customizations for the specific
instrument configuration shall be applied, it can be done in this template file. For example, WMIN
and WMAX could be customized, or refinement of EPS1, EPS2 and EPS3. Or the intensity of Kα3

and Kβ could be specified. (See file cubix-ads-10mm.tpl for an example of Kα3 and Kβ.) An
example of a template file is shown below:

% Theoretical instrumental function
VERZERR=
% Wavelength
LAMBDA=CU
% Phases
% Measured data
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Figure 15: Warning in case of
non-matching file names.

VAL[1]=
% Minimum Angle (2theta)
% WMIN=10
% Maximum Angle (2theta)
% WMAX=60
% Result list output
LIST=
% Peak list output
OUTPUT=
% Diagram output
DIAGRAMM=
% Global parameters for zero point and sample displacement
EPS1=0
PARAM[1]=EPS2=0_-0.001ˆ0.001
betaratio=0
NTHREADS=2
PROTOKOLL=Y
SAVE=N

If the template file contains a reference to a scan file containing a measured background curve
(UNT=<my-background>.xy), the background file should be stored in the device database di-
rectory, too. Profex will copy it to the project directory when creating a new refinement control file.
The background scan file will not be converted. It must be stored in a format natively supported
by BGMN. The recommended format is ASCII XY.

The template file is optional. If no template file is found for an instrument, a dialog will be shown
asking for basic information about the X-ray tube target material and the type of monochromati-
zation (Kβ filter, monochromator, energy dispersive detector) used.

Step 5: Testing the configuration

The next time a new refinement project is created, the new instrument configuration will show up
in the ,,Add/Remove Phase” dialog’s dropdown box (Fig. 17).

If the new configuration does not appear in the dropdown menu, make sure all four files <config-
name>.sav, <config-name>.ger, <config-name>.geq, and <config-name>.tpl are stored in the
device file directory, then restart Profex.
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Figure 16: Calculation in progress.

Figure 17: When creating a new refinement project by using the ,,Add/Remove Phase” dialog,
select the new instrument dconfiguration from the dropdown menu (here ,,RMS-D8-ADS-15-
LynxEyeXE”).
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Device file directories are usually found in the following locations:

Windows ...\Profex\Devices

Mac OS X .../Profex-BGMN/Devices

Linux unspecific

For Linux (optionally also for Windows and OS X), check ,,Edit→ Preferences→ BGMN→Device
Files Directory”.

Using ,,Instrument→New Configuration. . . ” will allow to read some hardware information from
Bruker RAW V4, Bruker BRML V5, and PANalytical XRDML files to create a BGMN instrument
configuration file from scratch. Other raw data formats are not supported. Usually several vari-
able required by BGMN will still not be available from the raw data files and will thus have to be
entered manually.
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8 Creating Structure Files (*.str)

Crystal structure files retrieved from online or commercial databases are usually supplied in the
CIF format [9] or in an XML file format if exported from the ICDD PDF-4+ database. Before they
can be used with BGMN, the structure information needs to be converted the the BGMN STR
file format. Profex provides support to facilitate the conversion process for both CIF and XML
formats. PDF-4+ XML files are usually complete and require very little user input. CIF files, on
the other hand, often lack important information and require manual revision. The import and
conversion process in Profex is the same for both CIF and XML formats.

8.1 CIF and ICDD XML import

The following workflow is recommended for CIF or XML import:

1. Retrieve a CIF or XML file from an external resource (online or local database).

2. Start Profex and choose ,,File→ Import Structure file. . . ” to open the import dialog.

3. Click the + button in the dialog to load the source file.

4. If asked for the space group number, select the number according to the International Tables
for Crystallography. If unknown, the number has to be determined from an external source.

5. If asked for a space group setting, select it from the list of proposed settings. If unknown,
the correct setting has to be determined from an external source.

6. The STR file is created and shown in an editor (Fig. 18). At the same time, the file is verified
by running BGMN in the background. If successful, a hkl stick pattern is shown. Else an
error message appears in the ,,Messages” console. The file name in the ,,Files” list is preceded
by an asterisk (*) if verification failed.

7. If verification failed, add the missing information manually. Then run verification again by
pressing the ,,.” button.

8. Once verification is successful, save the file to the structures repository.

Thermal displacement parameters read from CIF files are converted automatically to isotropic Biso
in nm2 as described in part 3 of the user manual.

The button to save all STR files will ignore files that failed verification (marked by *). It will save
all successfully verified files to the structure file repository, using the file base name of the source
CIF files.
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8.2 Verification

STR files created from CIF files should be verified before saving to the structure file repository,
because CIF import often results in incomplete STR files. Verification is run automatically imme-
diately after opening the CIF file. If it fails, errors will be reported in the ,,messages” console and
the faulty lines will be marked (Fig. 18). After fixing the errors, verification should be run again
by clicking the ,,.” button. If verification was successful, a hkl stick pattern is shown. Select the
correct wavelength at the bottom of the dialog to display the hkl indices at the correct 2θ position
for a specific instrument. The hkl graph can be exported to a semi-colon separated text file (*.csv),
a PDF file, or a pixel image.

If verification failed, error messages are again shown in the ,,messages” console, the hkl graph is
cleared, and the file name is preceded by an asterisk (*). Study the error messages, try to fix the
issue in the STR file, and run verification again. STR files that haven’t passed verification will later
issue the same error message when used in a refinement.

8.3 Common errors

8.3.1 ,,No Wyckoff symbol found”

Many CIF files do not contain Wyckoff symbols for atomic positions. In that case the symbols must
be added manually. If the symbols are unknown, open the tool ,,Tools → Browse BGMN Space
Groups. . . ”, select the correct spacegroup number and Hermann Mauguin symbol, and browse
all Wyckoff positions (Fig. 19). Try to find a position that describes special coordinates (,,round
numbers”) for each atom in the structure.

Example

A CIF file for anhydrite did not contain any Wyckoff symbols:

PHASE=Anhydrite //
SpacegroupNo=63 HermannMauguin=A2_1/m2/m2/a Setting=3 //
...
E=S Wyckoff= x=0.250000 y=0.000000 z=0.155560 TDS=0.005503
E=CA Wyckoff= x=0.750000 y=0.000000 z=0.347600 TDS=0.006538
E=O Wyckoff= x=0.250000 y=0.169900 z=0.016200 TDS=0.009849
E=O Wyckoff= x=0.081900 y=0.000000 z=0.297500 TDS=0.009388

The first atom S is located on a special position with ,,round numbers” for x and y. The position
can be described as ,,1/4 0 z”. To find the Wyckoff letter belonging to this special position,
open ,,Tools→ Browse BGMN Space Groups. . . ”, select space group number 63, Hermann Mau-
guin symbol A2_1/m2/m2/a (setting 3) and browse all Wyckoff symbols (Fig. 19). The symbol
describing the special position of the S atom is ,,c”. Repeat the process for all other atoms until all
Wyckoff letters are known. The solution is shown in Table 3.
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Figure 18: After conversion from CIF to STR format, BGMN will be called in the background to
run the STR file. If successful, a hkl stick pattern will be shown, else an error message appears in
the ,,Messages” page (bottom).

8.3.2 ,,Coordinates do not match first Wyckoff symmetry”

When browsing the BGMN space group definitions in ,,Tools→ Browse BGMN Space Groups. . . ”,
it is important to note that the special position descriptions appear in a specific order. BGMN
expects atomic coordinates to be given in the first symmetry description. Coordinates given in a
symmetry other than the first one in the list must be converted manually.

Example

In the previous example using the Anhydrite CIF file, the Wyckoff symbols were determined as
follows:
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Figure 19: Symmetry de-
scriptions for Wyckoff po-
sition c of space group no.
63 setting 3.

Table 3: Atomic positions in the Anhydrite CIF file and matching Wyckoff symbols describing
special positions. The symmetry actually matching the coordinates is shown in bold typeface.

Atom Coordinates Wyckoff Symmetries

S x=0.250000 y=0.000000 z=0.155560 c 1/4 0 z
3/4 0 -z

CA x=0.750000 y=0.000000 z=0.347600 c 1/4 0 z
3/4 0 -z

O x=0.250000 y=0.169900 z=0.016200 g 1/4 y z
3/4 -y -z
1/4 -y z
3/4 y -z

O x=0.081900 y=0.000000 z=0.297500 f x 0 z
x+1/2 0 -z
-x+1/2 0 z
-x 0 -z
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E=S Wyckoff=c x=0.250000 y=0.000000 z=0.155560
E=CA Wyckoff=c x=0.750000 y=0.000000 z=0.347600
E=O Wyckoff=g x=0.250000 y=0.169900 z=0.016200
E=O Wyckoff=h x=0.081900 y=0.000000 z=0.297500

However, when running the verification, an error message will be shown for the CA atom:

Line 8 (CA): Coordinates 0.750000 0.000000 0.347600 do not match
first Wyckoff symmetry for c (1/4 0 z).

Indeed the coordinates for the CA atom correspond to the second symmetry description for Wyck-
off position c (3/4 0 -z). The coordinates must thus be converted manually to the first symme-
try 1/4 0 z, which is done as follows:

• Change the value of x from 3/4 to 1/4

• Leave the value of y at 0.0

• Invert the sign of the z value

Correct coordinates for CA are thus:

E=CA Wyckoff=c x=0.250000 y=0.000000 z=-0.347600

or with z shifted back into the unit cell (the two z coordinates are equivalent):

E=CA Wyckoff=c x=0.250000 y=0.000000 z=0.652400
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9 Peak Detection

Since the search-match feature only searches Profex’ internal database, which, although constantly
growing, is far from complete, it is often necessary to use a third party software to search a more
complete structure database, for example the Crystallography Open Database (COD) [5]. One of
the most critical steps for accurate phase identification is the extraction of peak positions. Third
party search-match programs use their proprietary peak detection algorithms, sometimes with
a large number of parameters to tweak, but with complex or nano-crystallite samples it is often
necessary to improve the peak list manually by deleting duplicate peaks and adding peaks not
detected by the algorithm.

Profex has a very powerful peak detection module that exceeds the detection accuracy of most
other algorithms. The module is based on two compoments of the BGMN software suite called
TEIL and EFLECH. The first program TEIL splits the scan file in several parts, and the second
program EFLECH fits peaks and a background curve to these parts. EFLECH uses instrument
parameters read from an instrument configuration file and the wavelength spectrum read from
a *.lam file (both have to be specified by the user). It also fits peak broadening due to crystallite
size and micro-strain and thus recognizes broad peaks as single peaks instead of fitting them with
multiple narrow peaks. The peak recognition is outstanding, but the process can be extremely
time consuming.

9.1 Example

Open a scan file and start ,,Run → Run peak Search”. A dialog asking for the instrument con-
figuration and wavelength file opens (Fig. 20). Adjust both to your scan file and click OK. Peak
detection will start and take a few seconds up to several minutes.

Figure 20: Information required for peak search.

When the detection is complete, all peaks are shown as hkl lines in the graph and in tabular form
in the peak list widget (to open click ,,Windows → Peak List”). A new hkl scan is added to the
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Figure 21: Peak search completed.

plot options (Fig.21). To save the peak list to disk, click the ,,Save as CSV file” button ( ) above
the peak list. In the file dialog three different file formats can be selected:

CSV file This format stores all information (d value, 2θ position, and intensity) in a text file which
can then be opened with a spreadsheet program.

d values This format only stores d values and intensities. The file can directly be imported in
other programs for phase matching.

2theta values This format only stores 2θ positions and intensities. The file can directly be im-
ported other programs for phase matching.

By chosing one of the file formats only exporting d values or 2θ position, the peak list can be used
with third party search-match programs such as QualX [6] or Match! [7], which allows to use Pro-
fex’ superior peak detection with search-match programs accessing large structure databases.

At this point Profex cannot use the peak list for phase matching. The peak list can only be used
with other software, for graphical representation, or for publication purpose.

9.2 Peak search in refinement projects

If a refinement project has already been created, running peak detection works a little bit differ-
ently:
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• It is not necessary to specify the instrument configuration and wavelength files. Both pa-
rameters are read from the control file.

• The peak search will run on the active scan, i.e. a scan clicked in the ,,Plot options” list and
drawn in a bold line. If no scan is active, it will run on the first scan in the ,,Plot options” list
(usually I observed).

This offers some powerful possibilities in terms of isolating unassigned peaks of weak phases.
Using the ScanMath dialog (section 20) a residual scan can be computed than only contains the
unassigned files. If I difference is scan #3 and Background is scan #4, use the following
ScanMath equation to create a residual scan: I = #3 + #4. After generating the new scan and
closing ScanMath, click on the new scan in the ,,Plot Options” list to activate it, then run ,,Run→
Run peak detection”.
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10 Batch Refinement

10.1 Individually Configured Projects

If several projects are loaded, and all projects are configured correctly using the ,,Add/Remove
Phase” dialog, they can be refined sequentially using the batch refinement feature. Simply click
,,Run→ Run batch refinement. . . ” and select the projects to be refined. If more than one project
was pre-selected in the projects dock window, the same projects will be pre-selected in the project
selection dialog for the batch refinement. All selected projects will be scheduled for the batch
refinement.

Once a batch refinement is running, the functions in the ,,Run” menu work as follows:

Run Refinement will immediately start the refinement of the selected project, regardless of
whether its status is IDLE, COMPLETE, or SCHEDULED. The refinement will run paral-
lel to the running batch.

Run Batch Refinement will schedule the selected project for the running batch.

Abort Current Refinement depends on the status of the current project. RUNNING: The refine-
ment will be aborted, the batch refinement jumps to the next scheduled project and starts the
refinement. SCHEDULED: The project will be un-scheduled, i. e. set to IDLE and skipped
by the batch refinement.

Abort All Refinements will stop all running refinements and un-schedule all projects from the
batch. Note that also individually started refinements running parallel to the batch will be
aborted.

10.2 Batch Configuration

It is a common use case to refine a large number of files with nearly identical composition. For
example time-resolved series of a single specimen, or multiple measurements of the same sample
for statistical analysis. In that case, having to create a refinement project for each measurement as
described in section 3.2 would be tedious. Profex offers a much more efficient way to configure
and run a list of equivalent refinements:

1. Open all raw data files as individual projects (section 3.1). Note: Make sure to use the ,,Open
Graph Files. . . ”, not ,,Insert Scans. . . ” function.

2. Configure and refine the first project as described in section 3.

3. Once satisfied with the refinement quality, click ,,Edit → Copy Control File” to apply the
configuration of the first project to other projects.

4. Run a batch refinement (,,Run→ Run batch refinement. . . ”). You can skip the first project,
as it has been refined already.
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Figure 22: A batch refinement in progress.

Fig. 22 shows an example of a batch refinement in progress. Note that sequential batch refine-
ment, i. e. using the refinement results of one project as input for the next project, is currently not
supported.
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11 Amorphous phases

11.1 Background peak

X-ray amorphous phases, i. e. materials lacking a long-range structural order, do not produce a
distinct diffraction signal and are therefore considered to be invisibel in XRD data sets. However,
short-range ordering may still cause a broad bump in the background signal, typically (but not
exclusively) around d = 3.0 Å. If this bump is prominent, the background polynome may have
difficulties following it and may instead diverge from the measured background underneath the
bump. A polynome of higher degree, on the other hand, may have undesired side effects such
as an increased processing time due to additional refined parameters, or unstable background
refinement at the start and/or end of the scan.

Refinement of dataset with a strong amorphous bump can be drastically improved if the bump is
fit with a single broad diffraction peak. To add such a peak, select ,,Project → Add amorphous
peak” and specify the approximate center position in the following dialog. A new structure file
,,amorphous.str” is added, which contains just a signle peak. The structure cannot be used for
quantification of the amorphous content. But it may improve the quantification of all crystalline
phases because of a drastically better fit of the background.

To remove the amorphous phase, use the ,,Add/Remove phase” dialog and remove the file ,,amor-
phous.str” from the project.

The broadening parameters B1 and k2 of the amorphous peak must be carefully monitored. If
the amorphous peak gets wider than the measured amorphous signal and starts to extend beyond
the bump, the width parameters must be limited. If the amorphous bump is weak and the refined
peak starts to interfere with the background polynome, it may be better to remove the amorphous
phase and increase the order of the background polynome instead.

11.2 Internal standard

Adding an internal standard is a common method for quantification of amorphous fractions from
XRD data. The idea is to add one crystalline phase in a precisely known quantity. This internal
standard phase is measured and quantified along with the sample, and its mixed and refined
quantities can be used to scale all refined phase quantities to absolute values.

11.2.1 Example

Suppose a sample contains an amorphous phase (e. g. glass) and quartz in unknown quantities.
Since the amorphous phase is invisible in XRD data set, a quantification would result in 100 rel. wt-
% quartz.

In order to determine the absolute quantity of quartz and glass, we add 0.5 g of corundum (α-
Al2O3) to 1.0 g of the sample mixture. Now we know that the absolute quantity of corundum
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is 33.33 wt-% (0.5 g out of 1.5 g material). However, after refining the quantities of quartz and
corundum, we obtain the following relative phase fractions:

Quartz 58.33 %
Corundum 41.66 %

The relative fraction of corundum is 41.66 wt-%, but we know that the absolute fraction is 33.33 %.
With this information we can rescale all relative fractions to absolute fractions by multiplication
with factor 33.33/41.66. The absolute refined quantities are thus:

Quartz 58.33 · 33.33/41.66 = 46.66 %
Corundum 41.66 · 33.33/41.66 = 33.33 %

By adding 0.5 g of corundum, we increased the total amount of material from 1.0 to 1.5 g. Quartz
makes up 46.66 % of 1.5 g, but we are interested in the fraction in the original sample prior to
adding the corundum standard. Therefore we must rescale the quartz quantity by factor 1.5/1.0.
The amount of amorphous material is then 100− quartz:

Quartz 46.66 · 1.5/1.0 = 70.00 %
Amorphous 100.00− 70.00 = 30.00 %

11.2.2 Internal standard in Profex

The calculations demonstrated above to rescale refined phase quantities with an internal standard
to absolute quantities without the internal standard can be performed in a spreadsheet program
after the Rietveld refinement. However, Profex also provides a function to change the computa-
tion of quantity GOALs accordingly, so the refined quantities represent absolute phase quantities
including the amorphous content.

When refining a sample with internal standard, create a refinement project including all identified
crystalline phases, including the internal standard phase. Then select ,,Project→ Set internal stan-
dard”. In the following dialog, specify the internal standard phase you added to the sample, and
specifiy its known absolute amount in wt-%. After closing the dialog, the GOALs section in the
control file is modified. For example, the following section computing relative phase fractions:

sum=Calcite+Aragonite+Corundum

QCalcite=Calcite/sum
QAragonite=Aragonite/sum
QCorundum=Corundum/sum

GOAL[1]=QCalcite
GOAL[2]=QAragonite
GOAL[3]=QCorundum

. . . is changed to the following code when setting corundum as the internal standard in a quantity
of 30.00 abs. wt-%:
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ISTD=Corundum
ISTDQ=0.3000

sum=ISTD*(1-ISTDQ)/ISTDQ

QCalcite=Calcite/sum
QAragonite=Aragonite/sum
QAmorph=1-(Calcite+Aragonite)/sum

GOAL[1]=QCalcite
GOAL[2]=QAragonite
GOAL[3]=QAmorph

Important: The quantity entered for the internal standard must be the true standard quantity of
the final mixture. For example, when adding 0.3 g standard to 1.0 g sample, the true standard
quantity is 0.3/1.3 = 0.2308. The correct value to enter for the internal standard quantity in this
example would thus be 23.08 %. It is also possible to change the calculation of ISTDQ after closing
the dialog as follows:

ISTDQ=0.3/1.3

The modified GOAL code takes care of all rescalings described in the previous example and re-
ports absolute phase fractions, including amorphous fractions. The internal standard quantity is
eliminated so the reported quantities represent the phase fractions in the sample prior to adding
the standard.

To revert to relative phase quantities, simply select ,,Project→ Unset internal standard”.
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12 Chemical Composition

After the refinement, Profex will calculate the bulk chemical composition of the sample from the
structural information and refined site occupancies reported in the list file (*.lst). The elemental
composition, expressed in wt-% of the oxide, is shown in the ,,Chemical composition” dockable
widget (Fig. 23). In a first step, Profex will calculate the chemical composition of each phase,
and normalize it to 100 % (Fig. 23a). In order to calculate the bulk composition of the entire sam-
ple, Profex needs to know the relative quantity of each phase, which is normally calculated as a
global goal. Profex will attempt to identify the correct ,,Quantity Goal” by comparing global goal
names with the phase name. If a goal name of format phase name/some string is found, with
phase namematching the phases PHASE variable (case insensitive), the goal will be automatically
selected. Else no ,,Quantity Goal” will be selected and the user will have to select it manually.

As an example, the following ,,Quantity Goal” will be recognized and assigned automatically,
because the phase name and goal name match (matching is case insensitive):

STR file: PHASE=Corundum
GOAL:corundum=GEWICHT

SAV file: GOAL[1]=corundum/sum

But the following ,,Quantity Goal” will not be recognized automatically, because the phase name
and goal name do not match. The user will have to select it manually:

STR file: PHASE=Corundum
GOAL:Al2O3=GEWICHT

SAV file: GOAL[1]=Al2O3/sum

Once a valid ,,Quantity Goal” has been selected for a phase, the element composition will be
normalized to the phase’s quantity. The total chemical composition will be calculated only when
all phases were assigned a valid ,,Quantity Goal” (Fig. 23b).

The oxides and their molecular weights used to calculate the composition can be accessed and cus-
tomized in the preferences by calling ,,Edit→ Preferences. . .→ Chemical composition” (Fig. 24a).
Elements without molecular weight value, or with a value of 0.0, will be ignored for the calcula-
tion. It is recommended to leave the molecular weight of oxygen (element No. 8) empty or at 0.0
to avoid listing oxygen as a separate element in the chemical composition output table. See part 3
of the user manual for more information on customizing the oxide parameters.

Select ,,Results→ Export refined chemical composition. . . ” to export the data to a csv file.

Clicking with the right mouse button on the table allows to copy the table to the clipboard. The
content can be pasted to a spread sheet program. The semicolon character ,,;” is used as field
separator. The entire table will be copied, cell selections will be ignored.
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(a) (b)

Figure 23: Chemical composition of the sample. Quantity goals must be selected by the user. If no
quantity goals were selected (a), each phase will be normalized to 100 %. If the goals describing the
phases’ quantities were assigned (b), the total bulk composition of the sample will be calculated,
too.

(a)

(b)

Figure 24: Oxides and molecular weights can be customized in the preferences dialog (a). Double
click on a ,,Element” cell in the oxide table to open a dialog for calculation of oxide molecular
weights (b).
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13 Limits of Quantification and Detection

The counting noise inherently superimposing the diffraction peaks in a powder XRD pattern lim-
its the accuracy of phase quantifications. Even if a single specimen is measured multiple times
and variations introduced by sample preparation or sample inhomogeneities are guaranteed to be
absent, the random noise pattern will lead to a certain variation of the refined phase quantities.
The results are Gauss-distributed around the true value. The standard deviation is largely inde-
pendent of the phase quantity, it rather depends on the counting noise amplitude, which itself
strongly depends on the background intensity. As a result, phase quantities close to 0.0 still show
a standard deviation similar to greater quantities. An example is given in Table 4, which shows
mean quantities and ESDs of reference mixtures measured 10 times. Once the contamination
phases fall below 5 wt-%, their ESDs are surprisingly constant, even if the phases are entirely ab-
sent. As the phase quantities approach 0.0, but the ESDs remain constant, the variation coefficient
(VC) gets larger. The variation coefficient is defined as

VC =
ESD

Quantity
[%]

Assume we prepare reference mixtures with 5, 2, 1, 0.5, 0.2, and 0.0 wt-% of a contamination phase,
and the ESD of the refined quantities is constant at 0.2 wt-%. As a result, we observe the following
VCs:

Quantity [wt-%] ESD [wt-%] VC [%]

5.0 0.2 4.0
2.0 0.2 10.0
1.0 0.2 20.0
0.5 0.2 40.0
0.2 0.2 100.0
0.0 0.2 ∞

For small quantities the scattering of the values becomes excessively large compared to the mean
value, which is expressed by huge VCs. In other words, the refined quantity becomes unreliable.
Many textbooks, guidelines and standards define the limits of quantification and detection (LOQ
and LOD) as a specific variation coeficient. For example, they specify that for quantification the
mean value must be at least 4 times greater than its standard deviation, or the standard deviation
must be less than one quarter of the value (VC ≤ 25%). And for detection, the mean value must
be at least 2 times greater than its standard deviation, or the standard deviation must be less than
half the value (VC ≤ 50%). The actual limits might depend on the source of the information.

The example in Table 4 also shows that, with the exception of phase C, none of the contamination
phases reach 0.0 wt-% in the sample absolutely free of contaminations (bottom line). Once the
peak intensities drown in the counting noise, the refinement algorithm will be able to fit positive
intensities into the noise pattern. This has some undesired side effects: These residual intensities,
even when reported as ,,not detected”, reduce the quantity of the main phase, as long as they are
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taken into the normalization of phase quantities to 100 %. In Table 4 the quantity of phase A is
reduced to 99.10 wt-% due to accumulated residual intensities, even though no contaminations
were present. In order to avoid this problem, which can become even more pronounced if more
non-existent phases are added to the refinement, it is recommended to remove phases below the
detection limit from the project and repeat the refinement. This process should be repeated until
none of the refined phases is below the detection limit. Profex facilitates this strategy by high-
lighting phases below the detection and quantification limits and by showing a warning in the
summary table. The feature has to be enabled in the preferences dialog (Edit→ Preferences. . .→
BGMN → Summary Tables → ,,Show warnings for values below detection and quantification
limit”). In the same dialog the variation coefficients (VCs) used as limits of quantification and
detection can be defined. In the example shown in Figure 25 the limit of quantification is reached
when the refined quantity falls below 8 times its ESD (VC ≥ 12.5 %), and the limit of detection is
reached when it falls below 4 times its ESD (VC ≥ 25 %).

Some phases actually converge towards 0.0 wt-% despite a considerable noise pattern. In that
case the ESD may reach 0.0 wt-%, too. However, this is an artifact of the refinement algorithm
and its error propagation, as there cannot be an absolute certainty of absence of a particular phase
as long as there is noise superimposing the diffraction signal. After all, there always might be a
signal hidden in the noise. If the ESD reaches 0.0, the refined quantity might never fall below the
quantification and detection limit, as the ESD shrinks along with the value rather than remaining
constant, and the VC may or may not exceed the LOQ or LOD at a certain point. In order to avoid
this undesired result, Profex allows to define a minimum ESD. Any refined ESD below this value
will be considered to be an artifact, i. e. an unrealistically low ESD, and instead the minimum ESD
specified in the preferences dialog will be used. That way, a hard-coded minimum LOQ and LOD
is introduced. For example, the limit of detection in Figure 25 is defined as

LOD =
ESD
value

= 0.250

If we refine a phase quantity to 0.06 wt-% with an ESD of 0.01, its VC is:

VC =
0.01
0.06

= 0.167

The VC does not exceed the LOD, therefore the phase quantity of 0.06 wt-% should be considered
detectable, Profex will not show the warning ,,< LOD”. However, it is quite obvious that a quan-
tity of 0.06 wt-% cannot be detected in most real datasets collected on conventional instruments
with standard settings. Also an ESD of 0.01 wt-% is impossible to achieve if there is counting
noise in the pattern. The low ESD must therefore be an artifact. Applying Profex’ minimum ESD
at 0.05 wt-% (which is a realistic choice), the equation changes as follows

VC =
minESD

0.06
=

0.05
0.06

= 0.833

The VC exceeds the LOD of 0.250 by far, and the quantity of 0.06 wt-% is flagged as ,,< LOD”. In
fact, any quantity below

minESD
LOD

=
0.05
0.250

= 0.20

will be flagged as ,,< LOD”, regardless of its refined ESD.
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Figure 25: Warnings for quantities below LOQ and LOD can be activated in the preferences dialog.
Variation coefficients (VC = ESD/value) used as LOQ and LOD are also specified on the same
page.

If the minimum ESD is set to 0.0, the feature is deactivated and all refined ESDs will be used as
read from the results file. This is not recommended. The minimum ESD should be set to a positive
value. The non-existent phases B and D in Table 4 that converged to a positive residual intensity
(bottom line) had residual ESDs of 0.06 and 0.14 wt-%. It is a reasonable guess to use a value just
below the residual ESDs of non-existent phases as a minimum ESD. In this example, 0.05 wt-%
seems to be a good choice.
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Table 4: Reference mixtures of 3 contamination phases (B, C, D) in a matrix (A). All values are given in wt-%.

Composition (A + B + C + D) Quantity A ESD A Quantity B ESD B Quantity C ESD C Quantity D ESD D

0.0 + 33.3 + 33.3 + 33.3 0.02 0.01 33.79 0.29 32.54 0.19 33.65 0.37
1.0 + 33.0 + 33.0 + 33.0 0.66 0.11 33.57 0.29 32.33 0.20 33.44 0.38
10.0 + 30.0 + 30.0 + 30.0 9.58 0.24 30.63 0.29 29.44 0.20 30.36 0.40
25.0 + 25.0 + 25.0 + 25.0 24.98 0.29 25.48 0.28 24.20 0.19 25.34 0.40
40.0 + 20.0 + 20.0 + 20.0 40.37 0.30 20.35 0.26 19.02 0.18 20.27 0.41
55.0 + 15.0 + 15.0 + 15.0 55.94 0.25 14.95 0.19 14.00 0.15 15.11 0.26
70.0 + 10.0 + 10.0 + 10.0 70.71 0.25 9.82 0.17 9.14 0.13 10.32 0.25
77.5 + 7.5 + 7.5 + 7.5 78.07 0.22 7.44 0.14 6.72 0.12 7.77 0.17
85.0 + 5.0 + 5.0 + 5.0 85.55 0.21 4.91 0.13 4.27 0.12 5.27 0.17
94.0 + 2.0 + 2.0 + 2.0 93.79 0.19 2.02 0.10 1.65 0.08 2.53 0.15
97.0 + 1.0 + 1.0 + 1.0 96.64 0.17 1.05 0.09 0.74 0.05 1.57 0.14
98.5 + 0.5 + 0.5 + 0.5 98.09 0.16 0.54 0.08 0.30 0.04 1.08 0.13
99.4 + 0.2 + 0.2 + 0.2 98.79 0.14 0.28 0.07 0.09 0.03 0.84 0.12
100.0 + 0.0 + 0.0 + 0.0 99.10 0.15 0.14 0.06 0.00 0.00 0.75 0.14
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14 Text Blocks

Text blocks are pre-defined sections of text that needs to be inserted in control or structure files
regularly. Instead of entering the text manually each time, a text block can be selected from the
menu and inserted conveniently at the text cursor position in the currently shown text editor. Part
3 of the user manual describes how to manage text blocks.

A common scenario for text blocks is the structure file code to activate sub-phase refinement. The
same code is needed occasionally in structure files. It can thus be pre-defined in the preferences
and applied from the menu ,,Edit→ Insert Text Blocks”. The block will be inserted at the position
of the text cursor. An example block is shown below.

RefMult=2

PARAM=pG=0.5_0ˆ1
GEWICHT[1]=pG*GEWICHT
GEWICHT[2]=(1-pG)*GEWICHT

PARAM=pB1=1_0.1ˆ10
B1[1]=B1
B1[2]=pB1*B1
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15 Refinement Preset

For routine analyses or refinements of series of measurements it is often recommended to use
exactly the same structure files and refinement strategy in order to obtain reproducible and user-
independent results. Instead of using the ,,Add/Remove Phase” dialog each time to select the
device configuration and structure files, this information can also be loaded from a refinement
preset file. A preset thus automates the choice of device configuration and structure files, and
reduces user input to a single mouse click. The specification of preset files is given in part 3 of the
user manual.

15.1 Creating and Using Presets

Presets can be created from an existing refinement as follows:

1. Load your raw data using ,,File→ Open Graph File. . . ”.

2. Create your refinement control file using the ,,Add/Remove Phase” dialog.

3. Run and optimize the refinement until you are satisfied with the quality of fit.

4. Select ,,Project → Save as Refinement Preset. . . ” and save the file in the Preset directory
specified in the Preferences dialog (part 3 of the user manual).

The preset is now ready for use3. It can be applied to a new raw data scan as follows:

1. Load your raw data using ,,File→ Open Graph File. . . ”.

2. Select ,,Project → Refinement Presets → <preset name>” or use the button in the project
toolbar to create the control file.

3. Click ,,Run→ Run Refinement”.

15.2 Presets for Quality Control

An MD5 checksum is saved for each file referenced in the preset (MD5hash=...). When applying
the preset, Profex will verify the integrity of the files and issue a warning if files were modified.
The preset can still be applied, but the user was informed about (accidental or intentional) modi-
fications of the files.

Presets allow using Profex for routine quality control in an accredited environment. In such a
scenario it is recommended to store the presets directory on a network shared drive, and giving
write access only to the lab manager. This, in combination with MD5 checksums, provides a high
level of data integrity and reduces user input to applying the correct preset.

3Projects loaded before saving the preset need to be closed and re-opened in order to scan for new presets.
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16 Show Peak Profiles

The shape of measured diffraction peaks originates from a convolution of the wavelength emis-
sion spectrum, geometrical features of the instrument, and peak broadening by certain sample
properties. Profex allows to display the individual contributions to the peak shape using ,,Instru-
ment → Show Peak Profile . . . ”. The dialog features four tabs. The first three tabs are used to
display wavelength, instrumental, and sample profile shape contributions. The fourth tab shows
the convoluted profile, and only is enabled once the first three tabs show data. Fig. 27 shows
examples for all four pages.

All graphs can be zoomed horizontally using the mouse scroll wheel, unzoomed using the right
mouse button, and dragged using the left mouse button. Also the graphs can be exported to CSV
table files, PDF graphs, and pixel images. Clicking the second button from the left will reload the
current file from disk. This allows to quickly update the graph when editing the source file in a
text editor.

The filled curve always represents the total contribution function, which are usually composed of
several sub-curves. The sub-curves can be toggled on and off using the third button from the left
in the bottom-left corner of the dialog.

It is generally recommended to start with the left-most tab and load some data. Then proceed to
the next tab. Once the third tab contains data, the fourth tab is enabled and the convoluted profile
can be calculated.

16.1 Wavelength Distribution D

The first tab allows to display the characteristic spectrum of an X-ray tube, as it is described in a
*.lam file bundled with BGMN and Profex. Use the first button on the left to load a file. The file
dialog automatically opens in the BGMN directory and offers all *.lam files to be opened. Once
opened, the dialog will show the wavelength spectrum on an Ångstrom scale.

The sub-curves on this graph represent the lorentzian curves described in the *.lam file in order to
approximate the characteristic spectrum.

16.2 Instrumental Function G

The instrumental function originating from the goniometer layout is read from a *.geq file, which
is obtained as a result of the raytracing and interpolation of the peak shape as described in section
7. When loading a file, the file dialog will automatically open in the device repository.

Instrument contributions are displayed on a ∆2θ axis. The position 0.0 represents the peak center,
values to the left and right represent deviations from the center. The actual 2θ value is shown in
the legend. Since the instrument contribution depends on the 2θ position, a slider at the bottom
of the dialog can be used to scroll through the 2θ range the profile was calulated in (defined in the
instrument *.sav file).
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Sub-curves represent lorentzian curves computed by BGMN to approximate the raytraced pro-
file.

16.3 Sample Function P

Peak broadening by small crystallite size and micro-strain can be computed on the third tab. There
is no file to load. Instead, enter values for the BGMN variables B1, k1, and k2 in the spin boxes,
then press the ,,Reload” button (second button from the left) to compute the profile contribution.
The peak broadening is shown on a 1/d axis. It also depends on the 2θ position of the peak, which
can be scrolled through using the slider.

Sub-curves represent individual contributions of crystallite size and micro-strain.

16.4 Convolution D*G*P

In order to convolute the peak profile contributions shown in the first three tabs, raise the fourth
tab and click the ,,Reload” button (second button from the left). Computation will be complete
after a few seconds. The graph will show the observed peak shape on a ∆2θ scale with the value
0.0 representing the peak center. The peak’s position in the diffraction pattern is shown in the
legend. Use the slider to scroll through the entire 2θ range.

Sub-curves represent contributions from wavelength distribution, instrument geometry, and sam-
ple properties. Note that here all contributions are converted to a 2θ scale.
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(a) Wavelength distribution (b) Instrument geometry

(c) Sample contribution (d) Convoluted peak profile

Figure 27: The dialog ,,Instrument → Show peak profile. . . ” allows to display the individual
contributions leading to the convoluted observed peak shape.
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17 Scan batch conversion

Several scan files can be converted to other data formats at a time using the ,,File → Scan batch
conversion. . . ” feature. However, due to limitations given by the formats, SVG and pixel images
(PNG) are not available for batch conversion.

When opening the batch conversion dialog by clicking ,,File→ Scan batch conversion. . . ”, the file
queue will contain all currently opened scan files by default. More files can be added by clicking
the ,,Add File” button and selecting one or more files, and selected files can be removed from the
queue by clicking the ,,Remove File” button.

Some output format support multiple scans stored in a single file. The option ,,Write scans to one
file” will instruct Profex to store all scans found in a source file into one single file. In that case, all
scans Iobs, Icalc, Idi f f , Ibackground, and all sub phase patterns found in a DIA file will be stored in a
single output file. Use ,,Write scans to individual files” to write these patterns into single output
files instead. Note that storing multiple scans in one file must be supported by the output format
as well as by Profex’ output filter, which is currently only the case for ASCII and Gnuplot files.

Click ,,Convert” to start the conversion process, or ,,Close” to close the dialog without conver-
sion. Output files will be stored at the location of their source files using the same base file name.
Existing output files will be overwritten without warning.
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18 Favorites

Reference structure files can be flagged as favorites in the preferences dialog (Fig. 28). Favorite
phases can then be filtered in the ,,Add / Remove Phase” dialog and in the reference phase drop-
down menu by clicking the ,,Show favorites” button (Fig. 29). Filtering favorites greatly sim-
plifies handling reference structures in large repositories by limiting the number of displayed
structure to a hand full of relevant ones.

Important: When double-clicking a peak in the diffraction pattern to identify the nearest reference
structure while filtering of favorites is active for the reference structure list (Fig. 29 top-left), only
the favorites will be searched. In order to search all reference structures, temporarily deactivate
favorites filtering (Fig. 29 top-right) prior to double-clicking.

Figure 28: Favorite reference structure files are configured in the preferences dialog by checking
the box in the 4th column ,,Favorites”.
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Figure 29: Filtering favorite reference structures (left) allows to quickly change between relevant
(left) and all (right) structure files in the repository.
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19 Baselines

Note: Subtracting baselines from raw data later used for Rietveld refinement is not recommended. All
Rietveld refinement programs rely on unmodified intensities for error estimation.

Profex allows to compute a baseline (background curve) for scans in a project. Use ,,Project →
Add Baseline. . . ” to open the dialog shown in Fig. 30. Two different algorithms [15, 16] are imple-
mented with various parameters to adjust. The dialog provides the following options:

Scan Select the scan to add a baseline for.

Algorithm Select the algorithm for baseline calculation.

Append Appends the baseline to the project without closing the dialog. Another one can be cre-
ated, either for a different scan, or for the same one but using different parameters.

OK Appends the baseline to the project and closes the dialog.

Cancel Discards the baseline and closes the dialog.

Depending on the selected algorithm, various different parameters can be adjusted in order to
optimize the baseline. There is no recommended setup. One set of parameters might work well
for a certain diffraction dataset whereas it might be a poor choice for another dataset. It is rec-
ommended to adjust the parameters until a satisfying baseline is created. The parameters are
described in the sections below.

Baselines appended to the project are not yet saved to disk. If the project or the program is closed,
they are discarded. To preserve the baselines, open the ,,Plot Options” window, right-click on the
baseline scan, and select ,,Export Scan. . . ”. Select ,,Ascii Free format (*.xy *.XY)” file type, or any
other format of your preference.

Baselines can be subtracted from measured data using the ,,Scan Math” feature (section 20). How-
ever, as mentioned above, raw data used for Rietveld refinement must not be modified by baseline
subtraction. However, in situations when the refined background curve is not able to accurately
describe amorphous signals or low-angle steps in the background, it may still be desired to use a
fitted baseline on top of the refined background. This is done as follows:

1. Create a baseline for the raw data scan, and export it to disk in ,,Ascii Free format (*.xy *.XY)”
as described above, for example as ,,myBaseline.xy”.

2. Create a refinement project and open the control file (*.sav).

3. Add the following line to the control file

UNT=myBaseline.xy

4. Now run the refinement

The resulting background curve is a combination of the manually created baseline and a refined
background polynom. This approach has no negative effect on error estimation.
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Figure 30: The baseline dialog allows to add a smoothed baseline (green) to the project.

19.1 SNIP algorithm

The SNIP algorithm [15] allows two adjust two parameters:

Clipping Window Select either an increasing or a decreasing clipping window. The decreasing
window usually results in a smoother baseline and is generally the preferred choice.

Iterations The number of iterations determines the curvature of the baseline. Low values result
in the line bending into the feet of wide peaks. High values result in a smoother, more
continuous line. Adjust the value until the baseline follows the background, but does not
bend into peaks.

19.2 Golotvin and Williams algorithm

The algorithm published by Golotvin and Williams [16] is based on interpolated anchor points.
The first 6 parameters control the selection of anchor points, whereas the last option defines the
interpolation function. Anchor points are shown in the table on the right, and can be fine adjusted
manually.

Data smoothing M: Raw data can be smoothed prior to selecting anchor points. The smoothing
algorithm is described in [16]. Select 0 for no smoothing. Greater values result in stronger
smoothing. Usually a low number (0–5) works best.

Window size N: The number of data points used for the anchor point selection window. Data
point i is compared with its neighbors in the window from data points i− N/2 to i + N/2
in order to determine whether or not it qualifies as an anchor point. Lower values result in
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more flexible baselines, greater values in smoother ones. Values between 5–20 usually work
well.

Noise multiplier n: Multiplier factor for the noise σnoise. See equation 1 in the original paper [16]
for more information. Greater values result in more data points being used as anchor points.
Lower values are more restrictive, resulting in lower number of anchor points. A value of
1.0 is recommended.

Sampling steps: Only every ith data point will be used to determine anchor points. For a value of
1, every data point will be evaluated. For a value of 5, every 5th data point will be evaluated.
Values between 1 and 20 are recommended.

Sensitivity: For values greater than 1, a certain number of consecutive data points must qualify
as anchor points in order for the middle point to be accepted as anchor points. For example,
if sensitivity is set to 5, and the following data points all fulfill the requirements for anchor
points:

30.02, 30.04, 30.06, 30.08, 30.10

then only the middle point at 30.06 will be used as an anchor point. Greater values for
sensitivity result in smoother baselines. Values between 1 and 5 usually work best.

Last point: An anchor point will always be added at the position of the last data point in order to
avoid extrapolation of the baseline. However, sometimes the scan stops in the middle of a
peak rather than on the baseline. In that case, using the last data point as an anchor would
bend the baseline upwards. To avoid this, a different intensity value can be used for the last
anchor point. Options are either the second last anchor point, resulting in a horizontal end
of the baseline, or the lowest anchor point determined anywhere in the diffraction pattern.
There is no recommended setting. Avoid abrupt changes of the baseline at the end of the
diffraction pattern.

Interpolation: Select one from several interpolation functions to connect the anchor points. In
most cases, the Akima or monotone spline curves are the best choices.
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20 Scan Math

The tool ,,Scan Math” allows to perform mathematical operations on all scans loaded in a project.
Expressions must be entered in Java Script syntax [?, ?]. After clicking ,,Generate Scan” the calcu-
lation is performed and a new scan is appended to the project. The new scan can be saved to disk
by right-clicking on the scan in the ,,Plot options” window and selecting ,,Export scan. . . ”.

Scans are addressed by their position in the project preceded by ,,#”. The first scan in a project is
addressed as ,,#1”, the second one as ,,#2”. Double-clicking on a scan in the ,,Scan Math” dialog
will append its reference to the ,,Expression” line.

If a reference exceeds the number of available scans, the calculation will not be performed.

20.1 Anchor Scan

Scans in a project can have different angular ranges and different step sizes. When performing
mathematical operations on scans of different ranges or sampling intervals, the user must declare
one of the scans as anchor scan. The selected anchor scan determines in which angular range and
at what sampling intervals the mathematical operation is performed. Scans of different angular
ranges or with different sampling intervals are handled as follows:

• If the anchor scan range exceeds the angular range of one or more scans used in the mathe-
matical operations, the exceeded scans are padded with intensity 0.0.

• If one or more scans use different sampling intervals than the anchor scan, their intensities
are quantized to the anchor scan’s sampling interval using linear interpolation.

An example for the role of the anchor scan is illustrated in Fig. 31. Two scans with different angular
ranges and step sizes are summed using the expression ,,#1 + #2” (Fig. 31a).

• If the longer scan #1 is selected as anchor scan, the resulting scan has the same angular
range and step size (Fig. 31b), the shorter scan #2 is padded with intensity 0.0 on both ends.
Intensities of scan #2 are quantized to the smaller step size of the anchor scan using linear
interpolation.

• If scan #2 is selected as anchor scan, the longer scan #1 is clipped to the length of the shorter
anchor scan (Fig. 31c), and the intensities of scan #1 are quantized to the larger step size of
anchor scan #2 using linear interpolation.

20.2 Examples

Some example expressions are shown below. A comprehensive reference of functions and opera-
tors supported by Java Script is available at [?, ?].
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(a) Two scans #1 (black) and #2 (red).

(b) #1 + #2 (orange), anchor scan #1.

(c) #1 + #2 (orange), anchor scan #2.

Figure 31: An example illustrating the role of the anchor scan.
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20.2.1 Rescaling and offset

Select ,,File→ Open raw scan file. . . ” and open a scan file. Then select ,,Tools→ Scan Math. . . ”.

To rescale the intensity by factor 2.0, enter the expression:

2 ∗ #1

To add a vertical offset of 100 counts, enter the expression:

#1 + 100

To get the square root of the instensity, enter the expression:

Math.sqrt(#1)

To raise the intensities to the power of 2, enter the expression:

Math.pow(#1, 2)

20.2.2 Sum and difference of two scans

Select ,,File→ Open raw scan file. . . ” and open a scan file. Insert another scan to the same project
by selecting ,,File→ Insert Scan. . . ”. Then select ,,Tools→ Scan Math. . . ”.

To calculate the sum of the two scans, enter the expression:

#1 + #2

To calculate the difference of the two scans, enter the expression:

#1− #2

Alternatively the same examples can be performed on a refined project (*.dia) file, for example to
subtract the background curve (#4) from ,,I observed” (#1):

#1− #4
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21 Peak Integrals

The integrated intensity of individual peaks can be determined with the tool ,,Peak integration”
found in ,,Window→ Peak integrals”. This opens a new window with an empty table. The table
will list integrated intensities once at least one range is defined in the graph.

To define an integration range, place the mouse cursor on the graph at the beginning of the range,
then press and hold the shift key and left mouse button, and drag the cursor to the end of the
range. The range will be highlighted in gray, and once the mouse button is released, the integrals
will be computed and shown in the peak integral table (Fig. 32). The range’s start and end position
can be adjusted in the respective boxes in the table.

The results of the peak integration can be exported to a CSV file by selecting ,,Results→ Export
peak integrals. . . ”.

On the right-hand side of the table some buttons for more actions are located:

Remove selected range: By clicking this button the currently selected range is removed from the
table.

Remove all ranges: This action clears the entire table.

Apply ranges to all open projects: This action will copy all ranges of the table to all other open
projects. This allows to define ranges in one project, but to obtain the same integrals from
a large number of projects. A dialog allowing to select projects to apply the ranges to will
be shown prior to applying the ranges. Note that existing ranges will be cleared from the
receiving projects.

Subtract linear background: This action toggles subtraction of a linear background on or off. See
the next section for more information.

21.1 Calculations

Integrals A in the angular range from data points start to end are determined as follows:

A =
end−1

∑
n=start

Sn · In · F

with S being the step size between data points n and n + 1, In being the intensity of data point n,
and F being the scale factor applied by the user in the plot options. Vertical offsets are ignored.
No interpolation or curve fit is performed.

If the option ,,subtract linear background” is checked, a linear background will be interpolated
between start and end, and intensities will be determined relative to this background curve
(Fig. 33):
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A =
end−1

∑
n=start

Sn · (In − Bn) · F

The background intensity Bn is calculated as:

Bn = Istart +
n− start

end− start
· (Iend − Istart)

Note that data points below the background will also be considered for integration, hence poor
choice of the integration range can result in negative integrals.

When processing refined projects, it is recommended to de-activate the background subtraction,
and instead subtract the integral of the refined background from the integral of the raw data.

Figure 32: Peak integrals of a raw data file (top) and a refined project (bottom).
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Figure 33: When the option ,,subtract linear background” is checked, a linear background will be
interpolated between the first and the last point of the range (top). Integrals will be determined
relative to this baseline (yellow area). If the option is unchecked, integrals will be determined
from the zero line (bottom).
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22 Edit All Structure Files

Changing the refinement state of a large number of parameters (e. g. all atomic coordinates) can
be tedious. Profex offers a dialog allowing to change the refinement state of many parameters at
a time, not only in one structure file, but in all (or a selection of) structure files of a refinement
project. Selecting ,,Project→ Edit all Project STR files. . . ” opens the dialog shown in Fig. 34.

The dialog lists all project STR files on the left side, allowing to select all or a subset of files. Specific
files can be selected using the buttons marked as group 1 in Fig. 34. From left to right, the buttons
select the following files:

All Selects all files in the list

Open files Selects only the STR files that are currently opened in the current project. If no STR
files are opened, this button is disabled.

Current file Selects only the currently shown STR file. If no STR file is opened, or a different type
of file is currently shown, this button is disabled.

None Unselects all files. Note that the ,,Apply” button has no effect if no file is selected. It is,
however, sometimes useful to unselect all files before selecting certain files manually. This
is what this button is used for.

The right part of the dialog list structural parameters, grouped as ,,Unit Cell”, ,,Profile”, and ,,
Atomic Sites”. Each parameter can be checked or unchecked. Only checked parameters will be
modified. Selections can be quickly made using the buttons in group 2 in Fig. 34, which from left
to right have the following function:

Check Group If a parameter or a group is selected with the mouse, this button will check all
parameters of this group. If no parameter or group is selected, all parameters of all groups
will be checked.

Uncheck Groups If a parameter or a group is selected with the mouse, this button will uncheck all
parameters of this group. If no parameter or group is selected, all parameters of all groups
will be unchecked.

Increase refinement state by one step This button will increase the refinement state of the cur-
rently selected group of parameters.

The refinement state of checked parameters can be set individually, or using the button ,,Increase
refinement state by one step” to modify the group of the currently selected parameter. This but-
ton increases the state of all parameters that are not yet at their maximum refinement state. For
isotropic parameters the sequence is:

f ix → re f ined

For anisotropic parameters the sequence is:

f ix → isotropic→ ANISO(4)
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Figure 34: The dialog allows to modify the refinement state of all project structure files at a time.

And for GEWICHT the sequence is:

SPHAR0→ SPHAR2→ SPHAR4→ SPHAR6→ SPHAR8→ SPHAR10

Once all parameters of the current group have reached their maximum refinement state, clicking
the button again resets them to fix.

Clicking ,,Apply” will apply the modifications to all selected STR files. The changes are saved to
disk immediately. Closing the dialog without clicking ,,Apply” will have no effect.
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23 Electron Density Maps

The measured intensity of a diffraction peak hkl is proportional to the square of the structure factor
F2

hkl , which represent diffracted waves and are calculated as the sum of waves scattered at each
atom in the unit cell:

Fhkl =
n

∑
j=1

fi · e2πi[hx+ky+lz]

where fi is the scattering factor of atom i, h, k, l are the Miller indices of the reflection, and x, y, z
are the fractional coordinates of atom i. Theoretically, F is the Fourier transform of the scattering
density, ρ(x, y, z) taken over the entire unit cell:

Fhkl =
∫ c

0

∫ b

0

∫ a

0
ρ(x, y, z) · e2πi(hx+ky+lz) dx dy dz

If we determined F by Rietveld refinement and want to restore ρ(x, y, z), we can use the reverse
Fourier:

ρ(x, y, z) =
1
V ∑

hkl
Fhkl · e−2πi(hx+ky+lz)

where ρ is the electron density at discrete fractional coordinates x, y, z. V is the unit cell volume.
The summation is over all hkl peaks within the measured range.

23.1 Preparations

Profex can compute maps showing the electron density ρ in the unit cell from refined structure
factors F. In order to do so, two specific output files must be generated for each phase the map
should be generated for:

*.res : This is a file format used by ShelX. It contains all refined fraction atomic coordinates, as
well as all symmetry operators.

*.fcf : Another file format used by ShelX, which contains calculated and observed structure fac-
tors.

Both output files must be generated before the electron density map can be cacluated. Add the
following lines to the refinement control file:

RESOUT[n]=structure.res
FCFOUT[n]=structure.fcf
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Figure 35: Use the contxt menu (right mouse button) to add *.fcf and *.res files for electron density
map calculation.

This can simply be done by placing the cursor on a structure file entry and clicking the right mouse
button. In the context menu, both files can be added. For example, in a project containing the two
phases ,,hydroxylapatite” and ,,whitlockite”, the following section shows the structure files used
in this project:

% Phases
STRUC[1]=Hydroxylapatite-monoclinic.str
STRUC[2]=Whitlockite.str

If an electron density map for hydroxylaptite should be calculated, add the FCFOUT and
RESOUT lines using the right mouse button:

% Phases
STRUC[1]=Hydroxylapatite-monoclinic.str
FCFOUT[1]=Hydroxylapatite-monoclinic-ex1-file01.fcf
RESOUT[1]=Hydroxylapatite-monoclinic-ex1-file01.res
STRUC[2]=Whitlockite.str

The file names are created automatically. See Fig. 35 for an example. Then repeat the refinement.
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23.2 Map calculation

Open the dialog ,,Tools → Electron density map”. An empty dialog as shown in Fig. 36 will
appear. We need to load the *.fcf file created in the previous section. The electron density map will
automatically be computed and images will be rendered. Once the Fourier synthesis and image
rendering are complete, the electron density distribution is shown along the projection selected in
the ,,Projection” box (Fig. 37). By default the image is projected along the c axis, showing a cross
section of the a-b plane. The vertical slider on the right side of the image can be used to select the
cross section level along the c axis. The cursor position in fractional coordinates is displayed on
the bottom left.

Figure 36: The Electron Density Map dialog.

The projection, color appearance, and the amount of interpolation (,,smoothing”) can be adjusted.
To apply the changes, press the ,,Compute map” button again. Fig. 38 shows the same map ren-
dered with a false color map and contour lines, and with labels and circles representing the size
of the atoms. All user interface elements are described below.

Load *.fcf file Loads an *.fcf file and immediately computes the electron density map and renders
images. The *.res file is read in the background at the same time.

Re-calculate electron density map When the synthesis, resolution, projection, or the content of
the *.fcf file changed, the electron density map can be re-calcluated by pressing this button.

Render images When the color map, interpolation, or intensity range changed, the images can be
updated by pressing this button.
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Figure 37: Rendered electron density map.

Figure 38: Electron map rendered with a different color map and with labels.
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Save current layer Saves the current layer to a pixel image.

Save all layers Saves all layers to pixel images. The images will be numbered automatically.

Pre-render images When checked, all images from level 0 to 1 will be rendered automatically. If
unchecked, only the displayed level will be rendered. All other levels will be rendered on
the fly when displayed. For most users, pre-rendering is the preferred settings. If it takes
too long, disable pre-rendering.

Projection Select the projection plane of the unit cell to be displayed.

Color map Chose the preferred color map.

Interpolation Select the amount of pixel interpolation. Color maps with contour lines require high
interpolation. Lower levels of interpolation look pixelated.

• ,,None” shows the voxels filled with the sampled value.

• ,,Medium” uses bi-linear interpolation to interpolate screen pixels between samples
values.

• ,,High” uses bi-cubic interpolation to interpolate screen pixels between sampled values.

Range Sets the electron density range for the color map. Normally the range is set automatically
to fit the maximum and minimum calculated density in the range.

Image size Set the size of the map images in pixels (longest dimension).

Draw axes Check to draw the vertical and horizontal unit cell axis.

Draw atoms Check to draw circles for ionic radii. The radii are taken from [?].

Draw atom labels Check to label each atom.

Coordinates Displays the cursor position in fractional coordinates.

Mouse actions The mouse can be used to interact with the map image display as follows:

• The scroll wheel is used to zoom in and out.

• The right mouse button resets the zoom level and fits the map to the window.

• When zoomed in, hold the left mouse button to drag and pan the map.

• When atom labels are shown, hover the mouse over the label to show the atom’s frac-
tional coordinates.

Level The slider on the right side of the map image can be used to select the level of the cross-
section.

Close Closes the dialog.
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(a) Fobs map (b) Fcalc map (c) Fobs-Fcalc map

Figure 39: The Fobs-Fcalc map shows the difference between electron densities calculated from
observed (Fobs) and calculated (Fcalc) structure factors. Note that Fobs-Fcalc uses a different
range value to enhance the visibility of the differences.

23.3 Difference Fourier maps

Two types of structure factors are available from the Rietveld refinement: The ones extracted from
the measured data (Fobs), and the ones obtained from the pattern calculated from the crystal struc-
ture models (Fcalc). The electron density map can be calculated from either of them by selecting
the corresponding ,,Synthesis”. However, the most useful application of electron density maps is
the ,,Difference Fourier map” showing the differences between Fobs and Fcalc in terms of elec-
tron density mismatches. This allows to locate misfits in the structure models, for example due
to substitutions or vacancies. It is also a useful tool for structure solution. To display a difference
Fourier map, simply select ,,Fobs-Fcalc” from the synthesis box and re-calculate the map. Fig. 39
shows a comparison of observed and calculated electron densities, as well as the difference be-
tween the two with an apparent residual density due to a mismatched substitution of Ca for Mg
in the apatite structure.
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24 Absorption coefficient

The dialog ,,Tools → Calcualte absorption coefficient. . . ” allows to calculate the absorption of
X-radiation from refinement results. When opening the dialog from a refinement project, it will
automatically read the *.lst file and enter the information to the dialog. An example is shown in
Fig. 40.

For each phase, the chemical composition, its density, and its quantitiy in wt-% in the sample
is required. This information must be enterd in the ,,Phase parameters” section of the dialog, if
it is not automatically entered. In the block ,,Sample parameters”, the following information is
required:

Wavelength: The absorption changes with wavelength. Select the characteristic wavelength to
calculate the absorption for.

Attenuation: The ,,Path length” and ,,Layer thickness” results describe, after which distance in
the sample the initial intensity is attenuated by the fraction given here. For example, an
attenuation of 99 % means that after the calculated ,,Path length” the intensity is reduced to
1 %.

Packing density: The absorption of the sample also depends on the packing density, because the
air in the space between the grains absorbs less than the solid material. Estimate the packing
density to obtain a more realistic penetration depth.

Incident angle: The result for ,,Path length” describes how far the radiation penetrates into the
sample along the direction of the beam. ,,Layer thickness” gives only the penetration depth
vertical from the sample surface and thus depends on the incident angle of the beam.
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Figure 40: The absorption coefficient dialog computing the absorption for a mixture of the two
phases β-TCP and hydroxyapatite.
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25 Trouble shooting

25.1 Installation

25.1.1 How can I reset all preferences?

Program settings are stored outside of the Profex directories. Deleting and re-installing Profex will
not reset the preferences. Here is what you need to do in order to clear all preferences:

Windows

1. Close Profex

2. Open the windows menu and enter the command ,,regedit.exe”

3. Navigate to HKEY_CURRENT_USER/Software/doebelin.org

4. Delete the entire folder ,,Profex2”

OS X

1. Close Profex

2. Delete the file /Library/Preferences/org.doebelin.Profex2.plist

3. Restart your computer

Note: If you don’t restart your computer, it will continue using a buffered version of the plist file
and the settings will not be reset to default. Instead of restarting your computer, you can enter the
following command in a terminal in order to force updating the buffered file:

defaults read org.doebelin.Profex2.plist

Linux

1. Close Profex

2. Delete the file ˜/.config/doebelin.org/Profex2.conf

25.2 User Interface

25.2.1 I closed all dock windows. How can I open them again?

All dock windows (tool windows arranged around the plot area) can be opened from the ,,Win-
dows” menu.
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25.2.2 How can I share refinement projects with other users?

The easiest way to share projects with other users is to share project backups:

On the source computer

1. In Profex click ,,Project→ Save project backup” to create a *.zip file with all required scan,
control, structure, and instrument files.

2. The name of the created file will be shown in the ,,Refinement Protocol” console.

3. Share the *.zip file with the recipient.

On the recipient’s computer

1. Save the received *.zip file at the location where you want to process it.

2. In Profex click ,,File→ Open Project Archive. . . ” to open the *.zip file.

3. Run the refinement.

The *.zip file will be extracted and the file formats will be converted to the target platform’s text
file format.

25.2.3 How can I share refinement projects between Windows and OS X / Linux platforms?

Opening a refinement project created on one platform (either Windows or OS X / Linux) on an-
other platform (OS X / Linux or Windows) will cause an error message as soon as the refinement is
started. This is due to the fact that both types of platforms use different characters for line endings
in text files, and BGMN only accepts the format native to the platform it is used on.

To avoid these error messages, use the backup feature to share projects as described in sec-
tion 25.2.2. It automatically converts the files to the target platform.

25.2.4 The ,,Reference Structures” list is empty

Here is a list of things to try if the reference structures menu is empty:

Favorites

• Make sure the ,,Favorites” button is unchecked ( button next to the reference structures
list).

Re-index the reference structures

• Select ,,Tools→ Index Reference Structures” to update the structures database (or click the
button).
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Clear the hkl buffer file and re-index the structure files

1. Select ,,Edit→ Preferences→ BGMN→ Reference Structures” and clicking ,,Clear Buffer”.

2. Close the preferences dialog.

3. Select ,,Tools→ Index Reference Structures” to update the structures database (or click the
button).

Verify the location of the structure file repository

• Select ,,Edit → Preferences → BGMN → Repositories” and verify that the structure file
repository points to a valid location containing *.str files.

25.2.5 The ,,Add/Remove Phases” dialog is empty

Here is a list of things to try if the ,,Add/Remove Phases dialog” is empty:

Favorites

• Make sure the ,,Favorites” button is unchecked ( button in the bottom-right corner).

Re-index the reference structures

• Select ,,Tools→ Index Reference Structures” to update the structures database (or click the
button).

Clear the hkl buffer file and re-index the structure files

1. Select ,,Edit→ Preferences→ BGMN→ Reference Structures” and clicking ,,Clear Buffer”.

2. Close the preferences dialog.

3. Select ,,Tools→ Index Reference Structures” to update the structures database (or click the
button).

Verify the location of the structure file repository

• Select ,,Edit → Preferences → BGMN → Repositories” and verify that the structure file
repository points to a valid location containing *.str files.

25.2.6 The ,,Add/Remove Phases” dialog only shows checkboxes, but no text

All columns showing the file and phase names are minimized to the left side of the dialog. Resize
the columns to show the names and selection checkboxes.
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25.2.7 What does the error message ,,No import filter found for file . . . .raw” mean?

Several different file formats use the same extension *.raw (Rigaku, Bruker, Stoe). Attempting to
open a raw file with an import filter for a different type of raw file will issue this error message.

When opening raw data files, make sure that the file format in the file dialog is set to the correct
type of raw file (,,Bruker raw scan”, ,,Rigaku raw scan”, or ,,Stoe raw scan”).

25.3 Refinements

25.3.1 What does the error message ,,insufficient angular range” mean?

Short answer

The measured scan exceeds the angular range, in which the peak profile was calculated from
the instrument configuration file. Clip your measured data using the keywords WMIN (minimum
angle) and WMAX (maximum angle) in the refinement control file (*.sav) to limit the angular range
of your scan to the range specified in your instrument configuration.

Example Suppose the peak profile was calculated from 4 to 150◦2θ, but your scan was measured
from 3 to 80◦2θ. This will trigger the error message, because the peak profile was not computed
for the range from 3 to 4◦2θ. Add the following line to your refinement control file (*.sav):

WMIN=4

Then repeat the refinement. Now the measured range from 3 o 4◦2θ will be ignored and the error
message should no longer occur.

Long answer

Open your instrument configuration file (*.sav) as follows:

Profex prior to version 3.14: Select ,,Edit → Edit FPA Configuration. . . ”, then navigate to your
refinement project and open the file <instrument>.sav. ,,<instrument>” is the name of the in-
strument you selected when creating the refinement project.

Profex version 3.14 and newer: Select ,,Edit→ Edit current FPA configuration”.

The instrument configuration file will be opened in a special editor. Scroll down to the last section,
until you find a block that looks like this:
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%--------------------------------------------------------------------
% Parameters for the simulation of the profile function
%--------------------------------------------------------------------

% angular positions for the MonteCarlo simulation (deg 2theta)
zweiTheta[1]=4
zweiTheta[2]=8
zweiTheta[3]=13
zweiTheta[4]=20
zweiTheta[5]=30
zweiTheta[6]=42
zweiTheta[7]=56
zweiTheta[8]=76
zweiTheta[9]=90
zweiTheta[10]=105
zweiTheta[11]=120
zweiTheta[12]=135
zweiTheta[13]=150

% angular range (deg 2theta)
WMIN=4
WMAX=150

This shows the 2θ positions at which the profile is simulated (zweiTheta[n]), and the range in
which the profile is interpolated (WMIN and WMAX). In this example, the peak profile was modeled
in the range from 4 to 150◦2θ. Outside of this range, the profile is unknown. Hence, if a mea-
sured scan starting below 4◦2θ, or ending beyond 150◦2θ, is attempted to be refined, the error
message ,,insufficient angular range” will be shown. There are two different ways to avoid the
error message:

• Clip your measured data in order to ignore the measured ranges not covered by the instru-
ment configuration file using the keywords WMIN and WMAX in the refinement control file
(example 2).

• Extend your instrument configuration file to cover at least the range you measured (example
3).

For a demonstration of the two solutions, we assume that the instrument was configured in the
range from 4 to 150◦2θ, and we are attempting to refine a dataset measured from 3 to 80◦2θ.

Clipping the measured scan We need to clip the measured data below 4◦2θ, because it is outside
of the valid range. In your refinement control file (*.sav), add the following lines:

WMIN=4
WMAX=150
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Then repeat the refinement.

Extending the instrument configuration We need to extend the range in the instrument configu-
ration file from 4 to 3◦2θ. Open your instrument configuration file using the function ,,Edit→ Edit
current FPA configuration. . . ” (or ,,Edit→ Edit FPA Configuration. . . ” in Profex versions prior to
3.14) and extend the angular range as follows:

%--------------------------------------------------------------------
% Parameters for the simulation of the profile function
%--------------------------------------------------------------------

% angular positions for the MonteCarlo simulation (deg 2theta)
zweiTheta[1]=3
zweiTheta[2]=4
zweiTheta[3]=8
...
zweiTheta[13]=135
zweiTheta[14]=150

% angular range (deg 2theta)
WMIN=3
WMAX=150

Then click ,,Run calculations” to start the profile computation. Once it is complete, repeat the
refinement. If it runs without error messages, and you want to keep the extended instrument con-
figuration, copy all files <instrument>.* from your project directory to the devices repository.

Note: In Profex prior to version 3.14, the ,,Edit FPA Configuration. . . ” dialog will open in the
devices repository. It is important to navigate to the current refinement project first, and open the
instrument configuration file found there. Once this version of the instrument configuration file
works as expected, copy all <instrument>.* files from there to the devices repository to make it
available to all future refinement projects.

25.4 My fit looks good, but χ2 is still high. What should I do?

Absolute χ2 values are not always a good indicator for the quality of a fit. They are strongly
influenced by the signal-to-noise ratio. In high intensity datasets it is generally more difficult to
reach a χ2 value close to 1.0, whereas it is easily reached in noisy datasets.

The evolution of χ2 during a refinement is a good indicator when comparing different refinement
strategies, for example to determine which refinement strategy fits better with a given dataset. But
absolute values can be misleading. Sometimes it is better to trust your eyes and assess the quality
of fit based on the difference curve.
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