## Contents

1. Introduction .................................................. 6

**I. Installation and Setup** .................................. 7

2. Installation .................................................. 7
   2.1. Windows .................................................. 7
   2.2. Linux .................................................... 7
      2.2.1. Getting the source .................................. 8
      2.2.2. Compiling from source code .......................... 8
   2.3. Mac OS X ................................................ 9

3. Setup ....................................................... 10
   3.1. Automatic setup ........................................ 10
      3.1.1. Windows .............................................. 10
      3.1.2. Linux ................................................. 10
      3.1.3. Mac OS X ............................................. 11
   3.2. Manual setup ............................................ 11
   3.3. Using WINE on Linux .................................... 12

4. Structure, Device, and Preset Database .................. 12
   4.1. Structure Template Files ............................... 13
      4.1.1. Structure File Handling ............................ 13
   4.2. Device Configuration Files ............................. 14
   4.3. Refinement Preset Files ................................ 16

**II. Using Profex** ........................................ 17

5. Refinement Projects ......................................... 17

6. Standard Refinement ........................................ 17

7. Opening and Closing Scan Files .......................... 18

8. Adding and Removing Structure Files .................... 20

9. Project structure ........................................... 22

10. Exporting data .............................................. 24
    10.1. Refinement results .................................... 24
    10.1.1. CSV tables ......................................... 24
    10.2. Graphs ................................................. 26
    10.2.1. ASCII free format (XY) ............................. 27
    10.2.2. ASCII HKL List (HKL) ............................... 27
28. Preferences 96

28.1. General 96
28.2. Text Editors 96
28.3. Graphs 97
  28.3.1. Appearance 97
  28.3.2. Fonts 98
  28.3.3. Scan Styles 98
  28.3.4. Print and Export 99
28.4. BGMN 99
  28.4.1. Backend Configuration 99
  28.4.2. Repositories 101
  28.4.3. Limits 102
  28.4.4. GOAL Management 102
  28.4.5. Summary Table 105
  28.4.6. Reference Structures 107
  28.4.7. Favorites 107
  28.4.8. Structure File Handling 108
28.5. Fullprof 108
28.6. Chemical Composition 109
28.7. Text Blocks 109

29. Profex-specific Control File Variables 109

IV. Appendix 111

A. Bundle File Structure 111
  A.1. Windows 111
  A.2. Mac OS X 112
  A.3. Linux 113

Index 115
1. Introduction

Profex is a graphical user interface for Rietveld refinement of powder X-ray diffraction data with the program BGMN [1]. It provides a large number of convenient features and facilitates the use of the BGMN Rietveld backend in many ways. Some of the program’s key features include:

- Support for a variety of raw data formats, including all major instrument manufacturers (Bruker / Siemens, PANalytical / Philips, Rigaku, Seifert / GE, and generic text formats)
- Export of diffraction patterns to various text formats (ASCII, Gnuplot scripts, Fityk scripts), pixel graphics (PNG), and vector graphics (SVG)
- Batch conversion of raw data scans
- Automatic control file creation and output file name management
- Conversion of CIF and ICDD PDF-4+ XML structure files to BGMN structure files
- Internal database for crystal structure files, instrument configuration files, and predefined refinement presets.
- Computation of chemical composition from refined crystal structures
- Batch refinement
- Export of refinement results to spread sheet files (CSV format)
- Context help for BGMN variables
- Syntax highlighting
- Enhanced text editors for structure and control file management and editing
- Generic support for FullProf.2k [2] as an alternative Rietveld backend to BGMN.
- And many more…

Profex runs on Windows, Linux, and Mac OS X operating systems and is available as free software licensed under the GNU General Public License (GPL) version 2 or any later version. The latest version of the program can be downloaded from [3]. This website provides the Profex source code, bundles of Profex and BGMN for easy installation on Windows and Mac OS X (requiring zero configuration), and a default set of crystal structure and instrument configuration files.
Part I.
Installation and Setup

2. Installation

2.1. Windows

Since Profex requires a Rietveld refinement backend, a bundle containing both Profex and BGMN is offered for download on the Profex website. Using the bundle is the preferred way of installation if no previous installation is present on the computer. The directory and file structure of the bundle is shown in appendix ???. The software does not need installation. The downloaded archive can be extracted to any location on the computer. Automatic configuration of Profex will be able to locate the BGMN installation if the relative paths of the BGMNwin and Profex-3.13 folders are maintained. Therefore, it is recommended to copy the entire bundle to the same location on the hard disk, as shown in Fig. [1]. Follow these instructions to install BGMN and Profex:

1. Download Profex-BGMN-Bundle-3.13.x.zip from [3]
2. Extract the bundle to your harddisk (e.g. C:\Program Files)
3. Run Profex by executing the file profex.exe (e.g. C:\Program Files\Profex-BGMN-Bundle\Profex\profex.exe)

The file and directory structure of the bundle is explained in appendix[A]. Profex is also available for download without BGMN. This is the preferred way of installation if BGMN is already installed on the computer, or if previous versions of Profex are to be upgraded. The Profex binary archive does not need installation. Extracting the archive to the local hard drive is sufficient.

If a previous version is installed on the same computer, using a new version will not interfere with the existing installation. Old and new versions can be used at the same time, they will share the configuration options.

2.2. Linux

A binary archive of BGMN for Linux (32 and 64 bit) is available for download on the Profex website [3]. An RPM bundle containing BGMN and Profex is also provided for OpenSuse Leap (64bit). The RPM package installs Profex, BGMN, and a default set of structure and device templates to the /opt directory.

Users of linux distributions other than OpenSuse can download and extract the BGMN binary archive and template files, but must compile Profex from the source code.
2.2.1. Getting the source

Download the source code archive profex-3.13.x.tar.gz from the Profex website [3], extract it to your harddisk and navigate into the source code directory:

```
tar xzvf profex-3.12.0.tar.gz
cd profex-3.12.0
```

2.2.2. Compiling from source code

Compiling Profex requires a C++ compiler environment and the Qt toolkit version 5 to be installed [4], including header files. Qt version 5.3 or later is required. The following Qt 5 modules and header files must be installed:

```
widgets, xml, printsupport, sql, svg, qml
```

The package names for these modules depend on the distribution. Some examples for installation commands are given below. On most distributions these commands must be entered with root privileges.

**Ubuntu 16.04:**

```
apt-get install qtbase5-dev libqt5svg5-dev qtdeclarative5-dev
```

**PCLinuxOS:**

```
apt-get install lib64qt5base5-devel lib64qt5svg-devel
lib64qt5qml-devel lib64qt5imageformats-devel
```

**OpenSuse Leap 42.1:**

```
zypper install libqt5-qtbase-devel libqt5-qtsvg-devel
libqt5-qtdeclarative-devel libqt5-qtimageformats-devel
```

Support for Bruker BRML raw data files requires the 3rd party libraries zlib [5] and QuaZip [6]. Both libraries are included in the Profex source code archive and linked statically into the binary in order to avoid version conflicts with system-wide installed libraries linked against Qt version 4.

To compile the program run the following commands from the source code directory:

```
qmake -r
make -j 4
src/profex
```

Make sure `qmake` of Qt version 5 is used. If unsure, run `qmake` with the full path. If error messages occur and the program does not start after typing `src/profex`, read the error messages carefully and try to solve all dependency and version problems with your distribution’s software repository. `qmake` locations for Qt5 vary among distributions. Some examples are listed below:
Figure 1: When extracting the Profex-BGMN-Bundle for Windows to the hard disk, automatic setup will only be successful if the BGMNwin and Profex-3.13.x directories are copied to the same location, for example to a directory named C:\Program Files\Profex-BGMN.

2.3. Mac OS X

A disk image containing Profex and BGMN for Mac OS X 10.7 or newer is provided for download on the Profex website [3]. The binary requires a 64bit CPU. Visit [7] to find out whether a specific Apple computer uses a 64bit or a 32bit CPU.

Mount the disk image and drag the folder Profex-BGMN to the Applications folder. The file and directory structure of the bundle is explained in appendix A. Then run the application „Profex-BGMN/profex“.

The automatic setup routine (section 3) will find the BGMN installation and the structure and device directories.
3. Setup

3.1. Automatic setup

When starting Profex for the first time, the program will try to locate the BGMN installation directory and structure and device repositories automatically. Automatic configuration will also be executed later if the configured paths are invalid. It is therefore possible to force automatic setup later by deleting the paths to BGMN and the database directories in the preferences dialog, followed by closing and starting Profex. Automatic setup is platform specific. The locations scanned automatically are listed below.

3.1.1. Windows

Three directories named „Structures“, „Devices“, and „Presets“ are expected to be located in the directory of „profex.exe“. „BGMN.EXE“ is expected to be found in a directory called BGMNwin stored next to the parent directory of „profex.exe“. In other words, automatic setup on Windows will work if BGMN and Profex directories are organized as shown in Figure 1.

3.1.2. Linux

On Linux, a list of directories is scanned for the executable file „bgmn“. Scanning will stop at the first match. The directories are scanned in the following order:

1. /opt/Profex-BGMN/BGMNwin
2. /home/<user>/BGMN/
3. /home/<user>/BGMNwin/
4. /opt/bgmnwin/
5. /opt/bgmn/
6. /opt/bgmn-4.2.22/
7. /opt/BGMNwin/
8. /usr/bin/
9. /usr/local/bin/

Directories named „Structures“, „Devices“, and „Presets“ will be searched in the following order at:

1. /opt/Profex-BGMN/BGMN-Templates/Structures
   /opt/Profex-BGMN/BGMN-Templates/Devices
   /opt/Profex-BGMN/BGMN-Templates/Presets
2. /opt/BGMN-Templates/Structures
   /opt/BGMN-Templates/Devices
   /opt/BGMN-Templates/Presets

3. /home/<user>/Documents/BGMN-Templates/Structures
   /home/<user>/Documents/BGMN-Templates/Devices
   /home/<user>/Documents/BGMN-Templates/Presets

4. /home/<user>/BGMN-Templates/Structures
   /home/<user>/BGMN-Templates/Devices
   /home/<user>/BGMN-Templates/Presets

3.1.3. Mac OS X

On Mac OS X the BGMN installation and Structures and Devices directories will be scanned relative to the path of the Profex application bundle. Profex expects to find the following files, starting at the position of the Profex application bundle:

- `<location of profex.app>/../BGMNwin/bgmn`
- `<location of profex.app>/../BGMN-Templates/Structures`
- `<location of profex.app>/../BGMN-Templates/Devices`
- `<location of profex.app>/../BGMN-Templates/Presets`

3.2. Manual setup

The following sections describe how to configure Profex to find the BGMN backend, as well as the structure, device, and preset database directories manually. There are some scenarios when automatic setup will fail and the backend and database directories are not found, or when the automatic configuration is not desired:

- if only Profex was downloaded instead of a Profex-BGMN bundle
- if the Profex and BGMN folders from the bundle were not copied to the same location on the harddisk
- if other structure and device repositories will be used than the ones provided with the bundle. E.g. centrally stored on a network shared drive, or from a previous installation.
- on Linux no bundles are available

In these cases, manual configuration is necessary. Follow these instructions to set up Profex manually:

1. Run Profex and go to „Edit → Preferences ...“.
2. On the page „General“ set the „Default Project Type“ to „BGMN“ (Fig. 2).
3. Go to page „BGMN” and check the configuration of „BGMN Backend”. If auto-detection was successful, the lines for executable files and files directories are not empty (Fig. 2).

4. If the lines are empty, click the button on the right of each line and navigate to the corresponding executable file. The file names depend on the operating system. On Windows, the files are called BGMN.EXE, MAKEGEQ.EXE, GEOMET.EXE, and OUTPUT.EXE. On Linux and Mac OS X these files are called bgmn, makegeq, geomet, and output.

5. Verify the location of the Structure, Device, and Preset directories. If they are empty or point to the wrong location, click on the button on the right and select the correct directories.

3.3. Using WINE on Linux

Profex supports running the Windows version of BGMN on Linux using WINE. In that case, a „BGMNwin” directory from a Windows installation can be copied to any location on a Linux system. The executable files of the BGMN backend will then be called BGMN.EXE, MAKEGEQ.EXE, GEOMET.EXE, OUTPUT.EXE, and GERTEST.EXE. Checking the box „Run in WINE” and entering the WINE executable in the configuration dialog (Fig. 2), which is usually /usr/bin/wine, will let Profex call the BGMN backend in WINE. However, for performance reasons it is recommended to use the native Linux version of BGMN if available.

4. Structure, Device, and Preset Database

Profex supports databases for crystal structures, device configurations, and refinement presets for the BGMN backend. These databases are directories containing template files. Official Profex-BGMN bundles usually contain default template files for structures and devices. The location of
these directories can be chosen freely. For example, installations on several computers can access structures, device files, and presets stored on a network share and maintained centrally. In that case, new structure files, device configurations, or presets will immediately become available to all users using the same database directories. Write access is not required for normal use, only for maintenance. Configuration (automatic or manual) is explained in section 2. Several structure file directories can be specified, but only one directory for device and preset files, respectively.

4.1. Structure Template Files

Template files for crystal structures are normal BGMN structure files (*.str) stored at a central place in the „Structures“ database directory. When appending a structure file from the database to a refinement using Profex’ „Add / Remove Phase“ dialog, the file will be copied to the location of the XRD scan. The original file will never be modified.

The following information is relevant when creating new structure files:

- Use the file extension *.str, other files will be ignored by Profex.
- Profex will display the name given after the keyword „PHASE=“ in the „Add / Remove Phase“ dialog.
- It is recommended to add further information, e.g. an original database code (PDF, AMCS, COD) after a comment sign (//) trailing the „PHASE=“ keyword (see following example). This text will be shown as a comment in the „Add / Remove Phase“ dialog.

The following lines show an example of the file „lime.str“.

```
PHASE=CaO // 04-007-9734
SpacegroupNo=225 HermannMauguin=F4/m-32/m //
PARAM=A=0.4819_0.4771ˆ0.4867 //
RP=4 k1=0 k2=0 B1=ANISO°0.01 GEWICHT=SPHAR2 //
GOAL=GrainSize(1,1,1) //
GOAL:CaO=GEWICHT*ifthenelse(ifdef(d),exp(my*d*3/4),1)
E=CA+2 Wyckoff=a x=0.0000 y=0.0000 z=0.0000 TDS=0.00350000
E=O-2 Wyckoff=b x=0.5000 y=0.5000 z=0.5000 TDS=0.00440000
```

4.1.1. Structure File Handling

Depending on where structure files are obtained from (created manually, exported from databases, converted, downloaded, shared with others) they may contain different profile parameters RP, B1, k1, k2, GEWICHT etc. Altering these files in the structure file database will also affect other users accessing the same database, and may thus not be desired. Profex offers a feature to modify the structure files while copying them from the database to the working directory. Choose „Edit → Preferences → BGMN → Structure File Handling“ to access the settings (Fig. 3). The individual options on this page are explained in more detail in section 28.4.8.
Figure 3: Profex allows to modify structure files automatically to apply custom profile functions and goals.

4.2. Device Configuration Files

For each device configuration Profex expects to find four different files in the device database directory. These file names are supposed to have the same file name, but different file extensions (Fig. 7):

* .sav Containing the description of the device configuration. To be processed with GEOMET.

* .ger Containing the raytraced profile shape. To be processed with MAKEGEQ.

* .geq Containing the interpolated profile.

* .tpl A sample *.sav control file for the refinement, not containing any file names or phases (optional).

The *.tpl file is specific to Profex, all other files will be required by BGMN. The *.tpl file can be any existing refinement control file, but all output file names (LIST=, OUTPUT=, DIAGRAMM=), all scan file names VAL[n]=, and all structure file names STRUC[n]= should be empty. *.tpl files allow to add goals, calculations, numbers of threads and similar customizations, which will be applied by default when creating a new file set from the database. An example is shown in listing 4. All device file names, structure files, scan files, and the various output files will be filled in automatically by Profex.
% Theoretical instrumental function
VERZERR=
% Wavelength
LAMBDA=CU
% Phases
% Measured data
VAL[1] =
% Minimum Angle (2theta)
% WMIN=10
% Maximum Angle (2theta)
% WMAX=60
% Result list output
LIST=
% Peak list output
OUTPUT=
% Diagram output
DIAGRAMM=
% Global parameters for zero point and sample displacement
EPS1=0
PARAM[1]=EPS2=0_-0.001^0.001
betaratio=0
NTHREADS=2
PROTOKOLL=Y

Figure 4: Example of a template refinement control file.
If the template file contains a reference to a scan file containing a measured background curve (UNT=<my-background>.xy), the background file should be stored in the device database directory, too. Profex will copy it to the project directory when creating a new refinement control file. The background scan file will not be converted. It must be stored in a format natively supported by BGMN. The recommended format is ASCII XY.

The template file is optional. If no template file is found for an instrument, a dialog will be shown asking for basic information about the X-ray tube target material and the type of monochromatization (Kβ filter, monochromator, energy dispersive detector) used.

4.3. Refinement Preset Files

A refinement preset file allows to quickly create a control file with a certain device configuration file and a set of structures. It is useful for standard refinement always using the same device configuration and structure files, as it allows to set up the control file with a single mouse click. The format and application of preset files is described in detail in section 16.
Part II.
Using Profex

5. Refinement Projects

The BGMN refinement backend requires several text or binary input files to start a refinement, and it generates more text output files after completing the refinement. In Profex’ terminology, all files belonging to a refinement constitute a „refinement project”, or just „project”. Projects typically include a raw data scan file, a refinement control file (*.sav), instrument configuration files, and crystal structure files (*.str). After the refinement, BGMN will have generated several results file, of which the refined profile (*.dia) and list file (*.lst) are the most important ones. It is strongly recommended to use the same base name for the raw scan file, refinement control file, refined profile file, and list file. When following the workflow in section 6, correct file names will be generated automatically. More information about project file structure, specifically about projects sharing the same structure and device files, is given in section 9.

6. Standard Refinement

When Profex and BGMN have been installed and configured correctly as described in sections 2 and 3 and at least one device configuration and structure file has been stored in the databases (section 4), the program is ready for a first refinement. The following listing shows a step-by-step workflow for a standard refinement. The individual steps will be discussed in more detail in the next sections.

1. Click „File → Open Graph…”, or alternatively press Ctrl+G or the corresponding button in the main tool bar.
2. In the opening file dialog set the file format at the bottom to the format of your raw scan file, and open the file. See Tab. 1 for supported file formats.
3. The scan will be loaded as a new project.
4. Double click on the strongest peak or select a reference structure from the reference structure dropdown menu to identify your main phase.
5. Click „Edit → Add / Remove Phase…”, or press F8 or the corresponding button in the project tool bar create a control file. The dialog shown in Fig. 5 will be shown.
6. Select your instrument configuration from the dropdown menu, your phase from the structures list (it may be pre-selected), and verify that the option „Generate default control file” is active. Then click „OK”.

---

1 At the first start of the program, all reference structures in the structure database directory will be indexed. Depending on the number of files and the speed of the computer, this may take up to several minutes. A progress dialog is shown while indexing is in progress. Wait for the process to complete.
7. Click „Run → Run Refinement…”, press F9, or click the corresponding button in the refinement tool bar to start the refinement.

8. Wait for the refinement to complete.

9. If more phases are present, repeat steps 4–7, but make sure the option „Generate default control file” is not active anymore.

10. If the refinement is complete, click „File → Export Global Parameters and GOALs”, or press Ctrl+E or the corresponding button in the project tool bar to export the results to a CSV file.

11. Optionally, also click „File → Export Local Parameters and GOALs”, or press Shift+Ctrl+E or the corresponding button in the project tool bar to export the local results to a CSV file.

The exported CSV files can be opened in a spreadsheet program such as Microsoft Excel, LibreOffice Calc, or Softmaker PlanMaker. Specify the semicolon „;” as field separator and use the spreadsheet program’s sort feature to sort the parameters as needed.

7. Opening and Closing Scan Files

A refinement usually starts by opening a raw data file. In Profex’ terminology these files are either called „Graph files” or „Scan files”, whereas one file contains one or several „Scans”. Profex supports a large number of file formats (Tab. 1), however, the level of support depends on the availability of documentation for the file format specification. If a format is not supported, or support is broken, other software such as PowDLL [11] is required to convert the scan to a format supported by Profex.

Scan files can be opened in various ways:

„File → Open Raw Scan File…” menu or toolbar (Ctrl+G): This will open a file dialog to select one or more graph files. The correct file format must be selected. Important: Several instrument suppliers use the same file extension (*.raw) for different proprietary file formats. It is important to select the correct format, else Profex will show an error message. For example, a raw file measured on a Bruker instrument cannot be opened with the file format set to Rigaku or Stoe raw file.

If more than one file is selected, each file will be opened as a separate refinement project.

„File → Insert Scans…” menu or toolbar (Ctrl+I): Similar to the „Open Raw Scan File…” function above, but instead of creating a new refinement project for each file, all scans will be inserted into one project. If a project is already open, new scans will be inserted into the existing project.

Drag and Drop: Dragging one or several graph files from a file browser and dropping them on the Profex main window will open them in new refinement projects.
Table 1: Data file formats supported for import by Profex. Level of support (LoS): A = full support based on the file format specification, including multi-range files; B = good support, reverse-engineered; C = basic support, reverse engineered.

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Extension</th>
<th>File format</th>
<th>Version</th>
<th>LoS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bruker</td>
<td>*.raw</td>
<td>Binary</td>
<td>V1, V2, V3, V4</td>
<td>A</td>
</tr>
<tr>
<td>Bruker</td>
<td>*.brml</td>
<td>XML</td>
<td>Compressed archive</td>
<td>A</td>
</tr>
<tr>
<td>Bruker</td>
<td>*.brml</td>
<td>XML</td>
<td>Single XML file with XML data container</td>
<td>A</td>
</tr>
<tr>
<td>Bruker</td>
<td>*.brml</td>
<td>XML</td>
<td>Single XML file with binary data container</td>
<td>A</td>
</tr>
<tr>
<td>PANalytical</td>
<td>*.xrdml</td>
<td>XML</td>
<td>1.0 - 1.5</td>
<td>A</td>
</tr>
<tr>
<td>Philips</td>
<td>*.rd</td>
<td>Binary</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>Philips</td>
<td>*.udf</td>
<td>ASCII</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>Seifert/FPM</td>
<td>*.val</td>
<td>ASCII</td>
<td>-</td>
<td>B</td>
</tr>
<tr>
<td>Rigaku</td>
<td>*.bin</td>
<td>Binary</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>Rigaku</td>
<td>*.dat, *.rig, *.dif</td>
<td>ASCII</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>Rigaku</td>
<td>*.raw</td>
<td>Binary</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>MDI Jade</td>
<td>*.xml</td>
<td>XML</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>MDI Jade</td>
<td>*.dif</td>
<td>ASCII</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>STOE</td>
<td>*.pro</td>
<td>ASCII</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>STOE</td>
<td>*.raw</td>
<td>Binary</td>
<td>-</td>
<td>C</td>
</tr>
<tr>
<td>Generic</td>
<td>*.xy</td>
<td>ASCII</td>
<td>Field separators: ; : , space tab Comment signs: ! % &amp; #</td>
<td>A</td>
</tr>
<tr>
<td>BGMN</td>
<td>*.dia</td>
<td>ASCII</td>
<td>-</td>
<td>A</td>
</tr>
<tr>
<td>Fullprof.2k</td>
<td>*.prf</td>
<td>ASCII</td>
<td>Only PRF=3</td>
<td>A</td>
</tr>
<tr>
<td>Fullprof.2k</td>
<td>*.dat</td>
<td>ASCII</td>
<td>Only INS=10</td>
<td>A</td>
</tr>
<tr>
<td>pdCIF</td>
<td>*.cif</td>
<td>ASCII</td>
<td>Supported tags:</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>_pd_meas_2theta_scan</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>_pd_proc_2theta_corrected</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><em>pd_meas_counts</em>*</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><em>pd_proc_counts</em>*</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><em>pd_calc_intensity</em>*</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><em>pd_meas_intensity</em>*</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><em>pd_proc_intensity</em>*</td>
<td></td>
</tr>
</tbody>
</table>
Once the graph file is loaded, Profex will detect whether or not the file is part of a refinement project. If yes, the control and list files will be loaded automatically. If not, a refinement control file has to be created for the project in order to run the refinement (section 8).

Text files can be opened in text editors using „File → Open Text File…“. Profex will check if a project with the same base name is already open. If yes, the text file will be opened in a new tab of the project. This is convenient to open various output files (*.lst, *.par), as they are part of the project. If no matching project was found, the text file will be opened in a new project.

Note that structure files (*.str) will generally be opened in new projects, as their base name does not match the project base name. It is therefore recommended to open structure files with either of the two functions:

- „Project → Open all Project STR files“
- Right-clicking on the STRUC[n] line in the refinement control file, and selecting „Open File“.

Both ways will open the structure file(s) in new tabs of the current project.

Individual files can be closed by clicking on the „Close Tab“ symbol on the tab bar. Structure files can also be closed by clicking „Project → Close all Project STR files“.

The current project can be closed by „File → Close Project“ (Ctrl+W). If more than one project is selected in the Projects dock window, all selected projects will be closed. To close all open projects at once, click „File → Close all projects“.

8. Adding and Removing Structure Files

One of Profex’ central components is the „Add / Remove Phase“ dialog (Fig. 5). It is accessed by clicking „Project → Add / Remove Phase…“, or pressing F8 or the corresponding button on the project tool bar. This dialog is used to easily create or modify the refinement control file. It will automatically add a STRUC[n] reference and related GOALs for phase quantification to the control file, and copy the selected STR files from the structure file database to the working directory (Fig. 7). The individual elements of this dialog are described in detail below.

**Generate default control file:** If this option is checked, Profex will generate a default control file for the selected instrument configuration. If a template file is found (section 4), it will be used to create the control file. Else Profex will present a dialog asking for basic information about the instrument configuration (Fig. 6). If the option is active, an existing control file will be overwritten. The default state of this option depends on the presence of a previous control file:

- If a control file was found, this function will be unchecked. Manually activating the option will overwrite the existing control file with a newly created default file.
- If no control file was found, this function will be active.
**Instrument configurations:** This dropdown menu lists all instrument configurations found in the device database directory (section 4).

**Add phases:** This list shows all structure files found in the structure file database directories (section 4). Files stored in a sub-directory will be shown in a tree structure that can be collapsed or expanded. Clicking on the header of the table („File Name”, „Phase”, or „Comment”) will sort the table in ascending or descending order of the clicked column. Structures selected in the first column will be added to the control file. If a reference structure is shown on the main graph, it will be pre-selected in this dialog. The structure file list can be filtered by entering a search string in the filter line. The filter is applied instantly. Clear the line to display all structure files. The filter options menu allows to configure whether or not filtering will be case-sensitive, whether or not the search string will be interpreted as a regular expression pattern, and in which columns the filter string will be searched for.

If using regular expressions is not selected, only the wildcard characters „*” and „?” are evaluated. Activating regular expressions allows to make use of powerful regular expression patterns for filtering. Tutorials and documentation on regular expressions can be found on the internet.

**Expand/Collapse:** If structure files are organized in sub-directories in the structure database directory, they will be organized in a tree structure in this dialog. Clicking „Expand/Collapse” will expand or collapse all items in the tree structure for easy navigation.

**Overwrite existing files:** If a selected structure file is already present in the project directory, it will normally not be overwritten. This preserves customized files. Checking this option will force overwriting of existing files. Use this option with care, as other projects accessing the same structure files will be affected, too.

**Favorites:** If checked, only the phases flagged as favorites in the 4th column are displayed.

**Remove Phases:** The phases listed here are currently referenced in the control file. Check the ones that shall be removed from the refinement.

**Delete Files:** If this option is checked, the removed file will also be deleted from the hard disk in the project directory. This may cause problems with other projects residing in the same directory and referencing the same structure file. It is recommended to use this option with care.

If the control file contains multiple references to the same structure file, only the first occurrence will be removed. In that case, the option „Delete STR Files” will be ignored until the last reference to this file was removed from the control file.

Note that only copies of structure files in the local project directory will be deleted. The structure file database directory will remain unchanged.
Figure 5: The „Add / Remove Phase“ dialog is used to create a new project. If a project already exists, it is used to append more phases, or remove phases from the project.

The „Add / Remove Phase“ dialog will not allow to add the same phase more than once to a control file. If a selected file is already referenced in the control file, it will be skipped by the dialog. If multiple entries of the same structure file are requested, the control file has to be modified by hand.

After clicking „OK“ to apply the configuration, Profex will copy the structure and device files to the project directory, and create or modify the refinement control file as shown in Fig. 7.

9. Project structure

When working with several datasets (= projects) at a time, it is important to understand how Profex’ „Add / Remove Phase“ function handles structure and instrument files in the background.

By default the „Add / Remove Phase“ dialog will copy selected structure and instrument files to the location of the currently loaded scan file as shown in Fig. 5. It will check whether a file with the same name is already present. If yes, the present file will not be overwritten, unless the option
Figure 6: If no instrument template file is found, a dialog will ask for basic information on the radiation and monochromatization.

![Diagram](image.png)

**Devices database**
- Instrument1.tpl
- Instrument1.sav
- Instrument1.ger
- Instrument1.geq
- Instrument2.tpl
- Instrument2.sav
- Instrument2.ger
- Instrument2.geq
- Instrument3.tpl

**Structures database**
- Albite.str
- Barite.str
- Calcite.str
- Dolomite.str
- Ettringite.str
- Fluorite.str
- Gypsum.str
- Hematite.str
- Illite.str
- Jade.str
- Kaolinite.str
- Lime.str
- Magnesite.str
- Nahpoite.str

"Add Phase" Dialog
- Copies files from database directories to project directory
- Modifies *.str files if requested
- Converts instrument template (*.tpl) file to control file (*.sav)

**Project directory**
- myscan.xrdml
- myscan.sav
- Instrument1.sav
- Instrument1.ger
- Instrument1.geq
- Calcite.str
- Dolomite.str
- Magnesite.str

Figure 7: The „Add / Remove Phase“ dialog will copy structure files and device files from the database directories to the project directory. If selected in the preferences, the structure files will be modified according to the preferences in „STR File Handling“. Files already existing in the project directory will not be overwritten, unless the option is checked manually in the „Add / Remove Phase“ dialog.
“overwrite existing files” was activated for structure files, and “generate default control file” was activated manually for instrument files.

Since several raw scan files can be located in the same directory, a structure file will only be present once, even if it was added multiple times for each project. Modifying, removing, or overwriting this structure file will affect all projects within this directory (Fig. 8).

If common structure files are not desired, there are several options to avoid shared access by multiple projects:

- Distribute the raw scans on several sub-directories, as shown in Fig. 8. The “Add / Remove Phase” dialog will have to be called for each project separately, but each project will receive its own copy of the instrument and structure files.

- Manually manage the structure files. E.g. create a copy of structure_1.str and name it structure_1a.str. Then change the STRUC[1]=structure_1.str line in the corresponding control file to STRUC[1]=structure_1a.str.

- Manually manage structure files by creating sub-directories for structure files only. E.g. create a copy of structure_1.str in strFiles_1/structure_1.str. Then change the STRUC[1]=structure_1.str line in the corresponding control file to STRUC[1]=strFiles_1/structure_1.str. The project directory remains unchanged, but it will access the structure files in a specific sub-directory, which can be managed manually for each project.

10. Exporting data

10.1. Refinement results

10.1.1. CSV tables

At the end of a refinement, Profex shows a summary of global parameters and GOALs, refined local parameters, and the refined chemical composition in the summary dockable windows. These values are read from the LST output file. Local parameters can be customized in the preferences as described in section [28.4.5]. Profex allows to easily export the global and local refined parameters of all open projects to spreadsheet files:

“Results → Export Global Paramters and GOALs” will write the global parameters and goals of all open projects to a CSV file.

“Results → Export Local Paramters” will write the local parameters of all open projects to a CSV file.

“Results → Export Chemistry” will export the chemical composition (see section [13]) to a CSV file.
### Projects sharing structure files

<table>
<thead>
<tr>
<th>Working Directory</th>
<th>scan_1.sav:</th>
<th>scan_2.sav:</th>
</tr>
</thead>
</table>

### Projects in sub-directories

<table>
<thead>
<tr>
<th>Working Directory</th>
<th>scan_1.sav:</th>
<th>scan_2.sav:</th>
</tr>
</thead>
</table>

### Manually renamed structure files

<table>
<thead>
<tr>
<th>Working Directory</th>
<th>scan_1.sav:</th>
<th>scan_2.sav:</th>
</tr>
</thead>
</table>

### Structure files in sub-directories

<table>
<thead>
<tr>
<th>Working Directory</th>
<th>scan_1.sav:</th>
<th>scan_2.sav:</th>
</tr>
</thead>
</table>

(a) File structure

(b) Control file content

---

Figure 8: Projects and structure files can be organized in different ways, depending on whether structure and instrument files shall be shared or not.
Table 2: Global parameters and GOALS exported from Profex and sorted by the „Parameter / Goal“ column. Sorted like this, mean values and standard deviations can easily be calculated.

<table>
<thead>
<tr>
<th>File</th>
<th>Sample</th>
<th>Parameter / Goal</th>
<th>Value</th>
<th>ESD</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;path&gt;/scan1.lst</td>
<td>scan1</td>
<td>alphaTCP/sum</td>
<td>0.0311</td>
<td>0.0023</td>
</tr>
<tr>
<td>&lt;path&gt;/scan2.lst</td>
<td>scan2</td>
<td>alphaTCP/sum</td>
<td>0.0161</td>
<td>0.0022</td>
</tr>
<tr>
<td>&lt;path&gt;/scan3.lst</td>
<td>scan3</td>
<td>alphaTCP/sum</td>
<td>0.0147</td>
<td>0.0024</td>
</tr>
<tr>
<td>&lt;path&gt;/scan1.lst</td>
<td>scan1</td>
<td>hap/sum</td>
<td>0.9689</td>
<td>0.0023</td>
</tr>
<tr>
<td>&lt;path&gt;/scan2.lst</td>
<td>scan2</td>
<td>hap/sum</td>
<td>0.9839</td>
<td>0.0022</td>
</tr>
<tr>
<td>&lt;path&gt;/scan3.lst</td>
<td>scan3</td>
<td>hap/sum</td>
<td>0.9853</td>
<td>0.0024</td>
</tr>
</tbody>
</table>

The exported files are text files containing semicolon-separated fields. Open the file in a spreadsheet program and specify the semicolon character as a field separator. Since the exported files also contain the source file name, using the spreadsheet program’s sorting function allows easy sorting and statistical evaluation of the results. The following listing shows what the exported CSV file with global parameters and goals looks like when opened in a text editor. Table 2 shows how the same data looks after importing and sorting in a spreadsheet program.

File;Sample;Parameter / Goal;Value;ESD
<path>/scan1.lst;scan1;alphaTCP/sum;0.0311;0.0023
<path>/scan1.lst;scan1;hap/sum;0.9689;0.0023
<path>/scan2.lst;scan2;alphaTCP/sum;0.0161;0.0022
<path>/scan2.lst;scan2;hap/sum;0.9839;0.0022
<path>/scan3.lst;scan3;alphaTCP/sum;0.0147;0.0024
<path>/scan3.lst;scan3;hap/sum;0.9853;0.0024

10.2. Graphs

Scans shown in the plot area can be exported to various formats. Depending on the export format, some information may get lost if it is not supported by the output format. Scans can be exported as follows:

1. Make sure the graph to be exported is shown by selecting the project and showing the „Graph“ tab.
2. Select „File → Save File As...“.
3. Select the format for the export in the file format dropdown menu.
4. Specify the file name and save the file.

Profex exports some generic file formats, and some formats specific for other applications. The generic formats are useful for most users interested in further data processing or creation of figures. They will be discussed in further detail in the following paragraphs.
10.2.1. ASCII free format (XY)

A generic text format writing the data in columns, starting with the angle, followed by columns with intensities for each scan. These files can be imported in spreadsheet or plotting software for further processing. Spreadsheet software includes Microsoft Excel, LibreOffice Calc, SoftMaker PlanMaker, and others. Plotting software includes OriginLab Origin, GNUplot, and others.

*hkl* lines will not be exported. Scan colors, line styles, and the legend will also get lost during the export. Visibilities of scans will be ignored, all scans will be exported. A white space character is used for field separation.

The following example shows an exported ASCII free format file with all scans written into one file. The first column contains the $x$-values (2$\theta$ angle), the following columns contain $y$-values $I_{\text{obs}}$, $I_{\text{calc}}$, $I_{\text{diff}}$, $I_{\text{background}}$, and two phase patterns. Note that the phase patterns include the background intensity:

```
4.037500 20.000000 20.760000 -0.760000 20.740000 20.740000 20.760000
4.052500 22.000000 20.610000 1.390000 20.590000 20.590000 20.610000
...```

10.2.2. ASCII HKL List (HKL)

If the graph contains *hkl* tick lines, the data will be written to a text file. The output file starts with a header line, followed by *hkl* tick mark information of all phases. Note that the lines are sorted by phase number, not by 2$\theta$ angle. An example of an ASCII HKL list file is shown below:

```
"Phase Name" "Angle" "Phase No." "HKL" "Texture"
"Adularia" 22.501230 0 "0 2 1" 1.263500
"Adularia" 24.476712 0 "2 0 -1" 0.915900
"Adularia" 26.213459 0 "1 1 1" 1.328900
...
"Calcite" 26.835628 1 "1 -1 2" 0.968500
"Calcite" 34.275930 1 "1 -1 -4" 1.053900
"Calcite" 36.669943 1 "0 0 6" 1.049000
...
"Plagioclase_Albite" 22.106786 2 "0 2 -1" 1.174800
"Plagioclase_Albite" 23.578835 2 "0 2 1" 1.363700
"Plagioclase_Albite" 25.646178 2 "2 0 -1" 0.723100
...
"Quartz" 24.264737 3 "1 -1 0" 1.029900
```
10.2.3. Pixel image (PNG)

Pixel image export will write the file to a Portable Network Graphics (PNG) image. A dialog will open to ask for the output size in pixels. PNG uses lossless compression, therefore relatively small files free of compression artifacts will be created.

If the line width or font size is too small, it will have to be changed prior to the export in the graph preferences (see section 28.3). Use "display line width" to change the export line width.

All elements visible on screen will be exported, including hkl lines and the legend. Visibility of the scans will be considered, invisible scans will also be invisible on the exported file. The export will create a high-resolution image of the on-screen graph.

Pixel images can be edited in any photo editing software, such as Adobe Photoshop, GIMP, Paintshop Pro, Corel PhotoPaint, and others.

10.2.4. Gnuplot (GPL)

Gnuplot [12] is a powerful cross-platform graphing utility able to create quality graphs in various formats. Scans exported as Gnuplot files are saved as Gnuplot scripts with inline data. The graphs are a fairly accurate but not perfectly identical representation of the plot as displayed in Profex. It includes hkl indices, a legend, all selected scans, and it preserves scan colors and symbol styles. The output file may be edited to optimize the appearance of the Gnuplot graph or to change the output terminal. Gnuplot code created by Profex version 3.13.x was tested with Gnuplot versions 4.6 and 5.0.

On a system with a working Gnuplot installation, the following command entered in a terminal emulator will output the graph "scan.gpl" to the default terminal:

```
gnuplot -p scan.gpl
```

10.2.5. Grace plots (AGR)

The displayed graph is exported to a file for the Grace plotting program [13]. All colors and hkl tick marks are preserved. Grace is described on wikipedia as follows: 

```
Grace is a free WYSIWYG 2D graph plotting tool, for Unix-like operating systems. The package name stands for „GRaphing, Advanced Computation and Exploration of data.” Grace uses the X Window System and Motif for its GUI. It has been ported to VMS, OS/2, and Windows 9*/NT/2000/XP (on Cygwin). In 1996, Linux Journal described Xmgr (an early name for Grace) as one of the two most prominent graphing packages for Linux.

A modern incarnation of grace is available for all major platforms [14].

10.2.6. Scalable vector graphics (SVG)

Scalable vector graphics (SVG) is a resolution-independent vector graphics format ideal for post-processing of graphs. All elements (scans, axes, hkl lines, text) are exported as editable paths or text elements, allowing to change fonts, sizes, places, colors, line widths, or add annotations easily in the exported file. It is the most powerful and flexible of all export formats to create high-quality figures. However, it may be necessary to use vector drawing software and convert the format before importing into a word processor, as some programs do not import SVG files directly.

All modern web browsers are capable of viewing SVG files natively. SVG files can therefore be viewed and printed easily on all operating systems without requiring any additional software. In order to edit the files, a vector drawing program such as Adobe Illustrator, Inkscape, Corel DRAW, or others is necessary. Note that not all vector drawing programs interpret SVG files correctly. Wrong SVG drawing may need manual optimization.

The recommended workflow to add a scan to a manuscript in high quality is the following:

1. Export the scan to SVG as described above.
2. Open or import the SVG file in a vector drawing program of your choice.
3. Make sure the SVG file looks as expected. Modify if necessary.
4. Select the entire plot and copy to the clipboard.
5. Special-paste it into the word processor or presentation program, for example as an extended metafile.

10.2.7. Powder CIF file (CIF)

The crystallographic information file format (CIF) is not only used to share crystal structure information, but also raw or refined powder diffraction patterns. Saving a refined graph file (*.dia) in powder CIF format will create a file that is compliant with the guidelines for Rietveld papers by the International Union for Crystallography (IUCr) [15]. The project base name will be used for the data_ and pd_block_id tags, which is consistent with structure CIF files exported from the „Results” menu (section 10.4).

A truncated example of an exported powder CIF file is shown in Fig. 9.
# Rietveld refinement results for sample 160629-03
# Created with Profex 3.12.0
# Export date: July 28, 2016 - 11:27

## data_160629-03

_loop_

<table>
<thead>
<tr>
<th>_pd_proc_point_id</th>
<th>_pd_proc_2theta_corrected</th>
<th>_pd_proc_intensity_total</th>
<th>_pd_calc_intensity_total</th>
<th>_pd_proc_intensity_bkg_calc</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4.000000</td>
<td>240.2700</td>
<td>238.7400</td>
<td>238.7400</td>
</tr>
<tr>
<td>2</td>
<td>4.012300</td>
<td>243.6700</td>
<td>238.9300</td>
<td>238.9300</td>
</tr>
<tr>
<td>3</td>
<td>4.024500</td>
<td>240.4700</td>
<td>239.0800</td>
<td>239.0700</td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4571</td>
<td>59.986900</td>
<td>180.7300</td>
<td>196.6500</td>
<td>43.2600</td>
</tr>
<tr>
<td>4572</td>
<td>59.999100</td>
<td>147.6700</td>
<td>164.0000</td>
<td>43.3000</td>
</tr>
<tr>
<td>4573</td>
<td>60.011400</td>
<td>144.7300</td>
<td>147.1600</td>
<td>43.3300</td>
</tr>
</tbody>
</table>

# The following lines are used to test the character set of files sent by network email or other means. They are not part of the CIF data set.

Figure 9: Example of a pdCIF file converted from a BGMN *.dia file.
10.3. Printing to PDF

A PDF printer is available on most operating systems. It allows direct export of the graph to a PDF file. Prepare the graph as described at the beginning of this section, but use „File → Print…” instead of the „Save As…” function. Use the printer dialog to write the output to a PDF file. The layout and functions are platform specific.

If line widths in the printed document are too fine or too wide, change the printing line width in the preferences as described in section 28.3. PDF files can be used directly in \LaTeX. Other word processors may need the same conversion as described for SVG files in section 10.2.6.

All open graphs can be printed to a printer or to a single PDF file using the function „File → Print all graphs…”. Similarly all graphs can be exported to SVG format using „File → Export all graphs to SVG”. In this case, however, a separate SVG file will be created for each graph.

10.4. CIF files

Crystallography information file (CIF file, *.cif) is a standardized file format for the exchange of crystal structure information. It essentially contains the same information as BGMN list files (*.lst) do, however in a very different format. Profex can extract crystal structure information from *.lst files and write to *.cif files once a refinement has completed and a *.lst file has been created. In order to export CIF files of several refined projects, proceed as follows:

1. Open all projects you wish to convert to CIF
2. Make sure all projects were refined successfully
3. Select „Results → Export CIF files from LST files”
4. In the project selection dialog, select all project and click „OK”
5. A CIF export dialog will be shown (Fig. 10). Set up the output options to your preferences and click „OK”. The individual options will be explained below.

A truncated example of a single-phase CIF file is shown in Fig. 11. Note that some lines contain trailing comments of type „# <phaseName>”, such as the following lines:

```plaintext
_chemical_formula_structural ? # MgO
_chemical_formula_sum ? # MgO
_chemical_formula_weight ? # MgO
```

The question mark „?” is a placeholder for missing information. It should be filled with information by the user. The comment with the phase name (MgO) allows the user to use search-replace features in text editors to add the missing information efficiently. Some text editors can search and replace text in multiple files at once. Adding the molecular weight for MgO can thus easily be achieved, without interfering with other phases, by replacing
Fig. 10 also shows placeholder question marks for isotropic $B$ values for both atoms. The reason is that, unlike fractional coordinates, isotropic displacement parameters are not listed in the BGMN list file (*.lst) unless they are refined. A simple modification to the BGMN structure file (*.str, in this case „periclase.str”) solves the problem. In order to print fixed TDS values to the *.lst file, add the instruction GOAL=TDS to the end of the atomic position lines. An example is shown below, in which the GOAL statement was added to the end of the last two lines:

```plaintext
PHASE=MgO // 04-010-4039
MineralName=Periclase //
Formula=Mg_O //
SpacegroupNo=225 HermannMauguin=F4/m-32/m //
PARAM=A=0.4214_0.400ˆ0.425 //
RP=4 k1=0 k2=0 PARAM=B1=0_0ˆ0.01 GEWICHT=SPHAR4 //
MAC=10000*my/density
GOAL=MAC
GOAL=GrainSize(1,1,1) //
GOAL:MgO=GEWICHT*ifthenelse(ifdef(d),exp(my+d*3/4),1)
E=MG+2 Wyckoff=a x=0.0000 y=0.0000 z=0.0000 TDS=0.0031583 GOAL=TDS
E=O-2 Wyckoff=b x=0.5000 y=0.5000 z=0.5000 TDS=0.0033951 GOAL=TDS
```

Figure 10: Export options for CIF structure files.

```plaintext
_chemical_formula_weight ? # MgO

with

_chemical_formula_weight 40.3044
```
Figure 11: Example (truncated) of a single-phase CIF file.
After repeating the refinement and re-exporting the CIF files, the atomic positions section now includes correct values for `_atom_site_B_iso_or_equiv`:

```
loop_
   _atom_site_label
   _atom_site_type_symbol
   _atom_site_occupancy
   _atom_site_fract_x
   _atom_site_fract_y
   _atom_site_fract_z
   _atom_site_B_iso_or_equiv
MG1  MG   1.00000  0.00000  0.00000  0.00000  0.31583
O2   O    1.00000  0.50000  0.50000  0.50000  0.33951
```

## 10.4.1. CIF Export options

**One single-phase CIF file per phase** If several projects are to be processed and each project contains several phases, one CIF file will be created for each phase. The file name will automatically be set to `<projectName>-<phaseName>.cif`. Existing files will be overwritten without warning. The created file names will be shown in the refinement output console.

**One multi-phase CIF file per project** One CIF file per project will be generated. The CIF file contains all phases found in the project. The output name will be set automatically to `<projectName>.cif`. Existing files will be overwritten without warning. The created file names will be shown in the refinement output console.

**One global multi-phase CIF file** All phases found in all projects will be exported to one single CIF file. The user will be prompted to enter the file name.

**Temperature** Select the temperature at which the diffraction data was collected in Kelvin (K). To reset the value to room temperature, click the ,,RT” button. The value will be used for the CIF tag `diffrn_ambient_temperature`.

**Instrument** Select the name of the instrument used for the diffraction experiment. If the instrument is not available from the dropdown menu, create a new one by clicking the ,,+” button. The name can be chosen freely. It will be used for the CIF tag `diffrn_measurement_device_type`.

**Radiation Source** Select the type of radiation used for the diffraction experiment. The value will be used for the CIF tag `diffrn_radiation_probe`.

## 10.5. Castep CELL Files

This function reads RES files of all open projects and writes crystal structure information to CELL files for the software Castep [9]. One CELL file will be created for each crystal structure found. The file will be stored in the project directory. Information on saved files is shown in the refinement.
protocol console. If no RES file is available for a specific phase, a tag \texttt{RESOUT[n]=filename.res}
must be added to the control file (*.sav) and the refinement must be repeated. The CELL files contain cartesian atomic coordinates.

11. Opening Refinement Projects

Once a refinement has been completed, the Rietveld backend will write various output files. One of them contains the refined profile, typically the measured and calculated intensities, as well as the background, phase contributions, and \textit{hkl} indices. Refinement projects can be opened in Profex by selecting „File → Open Refinement Project...“ (or pressing „Ctrl+R“) and selecting the refined profile file (*.dia).

12. Batch Refinement

12.1. Configured Projects

If several projects are loaded, and all projects are configured correctly using the „Add/Remove Phase“ dialog, they can be refined sequentially using the batch refinement feature. Simply click „Run → Run batch refinement...“ and select the projects to be refined. If more than one project was pre-selected in the projects dock window, the same projects will be pre-selected in the project selection dialog for the batch refinement. All selected projects will be scheduled for the batch refinement.

Once a batch refinement is running, the functions in the „Run“ menu work as follows:

- **Run Refinement** will immediately start the refinement of the selected project, regardless of whether its status is IDLE, COMPLETE, or SCHEDULED. The refinement will run parallel to the running batch.

- **Run Batch Refinement** will schedule the selected project for the running batch.

- **Abort Current Refinement** depends on the status of the current project. RUNNING: The refinement will be aborted, the batch refinement continues with the next scheduled project. SCHEDULED: The project will be un-scheduled, i.e. skipped by the batch refinement.

- **Abort All Refinements** will stop all running refinements and un-schedule all projects from the batch. Note that also individually started refinements running parallel to the batch will be aborted.
12.2. Batch Configuration

It is a common use case to refine a large number of files with nearly identical composition. For example time-resolved series of a single specimen, or multiple measurements of the same sample for statistical analysis. In that case, having to create a refinement project for each measurement as described in section 8 would be tedious. Profex offers a much more efficient way to configure and run a list of equivalent refinements:

1. Open all raw data files as individual projects (section 7). Note: Make sure to use the „Open Graph Files . . . “, not „Insert Scans . . . “ function.

2. Configure and refine the first project as described in section 6.

3. Once satisfied with the refinement quality, click „Edit → Copy Control File“ to apply the configuration of the first project to other projects.

4. Run a batch refinement („Run → Run batch refinement . . . “). You can skip the first project, as it has been refined already.

Note that sequential batch refinement, i.e. using the refinement results of one project as input for the next project, is currently not supported.

13. Chemical Composition

After the refinement, Profex will calculate the bulk chemical composition of the sample from the structural information and refined site occupancies reported in the list file (*.lst). The elemental composition, expressed in wt-% of the oxide, is shown in the „Chemistry“ dockable widget (Fig. 12). In a first step, Profex will calculate the chemical composition of each phase, and normalize it to 100 % (Fig. 12a). In order to calculate the bulk composition of the entire sample, Profex needs to know the relative quantity of each phase, which is normally calculated as a global goal. Profex will attempt to identify the correct „Quantity Goal“ by comparing global goal names with the phase name. If a goal name of format phase_name/some_string is found, with phase_name matching the phases PHASE variable (case insensitive), the goal will be automatically selected. Else no „Quantity Goal“ will be selected and the user will have to select it manually.

As an example, the following „Quantity Goal“ will be recognized and assigned automatically, because the phase name and goal name match (matching is case insensitive):

**STR file:** PHASE=Corundum
GOAL:corundum=GEWICHT

**SAV file:** GOAL[1]=corundum/sum

But the following „Quantity Goal“ will not be recognized automatically, because the phase name and goal name do not match. The user will have to select it manually:
Figure 12: Chemical composition of the sample. Quantity goals must be selected by the user. If no quantity goals were selected (a), each phase will be normalized to 100%. If the goals describing the phases’ quantities were assigned (b), the total bulk composition of the sample will be calculated, too.

STR file: PHASE=Corundum
GOAL:Al2O3=GEWICHT


Once a valid „Quantity Goal“ has been selected for a phase, the element composition will be normalized to the phase’s quantity. The total chemical composition will be calculated only when all phases were assigned a valid „Quantity Goal“ (Fig. 12b).

The oxides and their molecular weights used to calculate the composition can be accessed and customized in the preferences by calling „Edit → Preferences → Chemistry“ (Fig. 13a). Elements without molecular weight value, or with a value of 0.0, will be ignored for the calculation. It is recommended to leave the molecular weight of oxygen (element No. 8) empty or at 0.0 to avoid listing oxygen as a separate element in the chemistry output table. See section 28.6 for more information on customizing the oxide parameters.

Select „Project → Export Chemistry…” to export the data to a csv file.

Clicking with the right mouse button on the table allows to copy the table to the clipboard. The content can be pasted to a spreadsheet program. The semicolon character „;“ is used as field separator. The entire table will be copied, cell selections will be ignored.

14. Limits of Quantification and Detection

The counting noise inherently superimposing the diffraction peaks in a powder XRD pattern limits the accuracy of phase quantifications. Even if a single specimen is measured multiple times and variations introduced by sample preparation or sample inhomogeneities are guaranteed to be absent, the random noise pattern will lead to a certain variation of the refined phase quantities. The results are Gauss-distributed around the true value. The standard deviation is largely independent of the phase quantity, it rather depends on the counting noise amplitude, which itself strongly depends on the background intensity. As a result, phase quantities close to 0.0 still show a standard deviation similar to greater quantities. An example is given in Table 3 which shows mean quantities and ESDs of reference mixtures measured 10 times. Once the contamination
phases fall below 5 wt-%, their ESDs are surprisingly constant, even if the phases are entirely absent. As the phase quantities approach 0.0, but the ESDs remain constant, the variation coefficient (VC) gets larger. The variation coefficient is defined as

$$VC = \frac{ESD}{Quantity} \times [\%]$$

Assume we prepare reference mixtures with 5, 2, 1, 0.5, 0.2, and 0.0 wt-% of a contamination phase, and the ESD of the refined quantities is constant at 0.2 wt-%. As a result, we observe the following VCs:

<table>
<thead>
<tr>
<th>Quantity [wt-%]</th>
<th>ESD [wt-%]</th>
<th>VC [%]</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.0</td>
<td>0.2</td>
<td>4.0</td>
</tr>
<tr>
<td>2.0</td>
<td>0.2</td>
<td>10.0</td>
</tr>
<tr>
<td>1.0</td>
<td>0.2</td>
<td>20.0</td>
</tr>
<tr>
<td>0.5</td>
<td>0.2</td>
<td>40.0</td>
</tr>
<tr>
<td>0.2</td>
<td>0.2</td>
<td>100.0</td>
</tr>
<tr>
<td>0.0</td>
<td>0.2</td>
<td>∞</td>
</tr>
</tbody>
</table>

For small quantities the scattering of the values becomes excessively large compared to the mean value, which is expressed by huge VCs. In other words, the refined quantity becomes unreliable. Many textbooks, guidelines and standards define the limits of quantification and detection (LOQ and LOD) as a specific variation coefficient. For example, they specify that for quantification the
mean value must be at least 4 times greater than its standard deviation, or the standard deviation must be less than one quarter of the value (VC ≤ 25%). And for detection, the mean value must be at least 2 times greater than its standard deviation, or the standard deviation must be less than half the value (VC ≤ 50%). The actual limits might depend on the source of the information.

The example in Table 3 also shows that, with the exception of phase C, none of the contamination phases reach 0.0 wt-% in the sample absolutely free of contaminations (bottom line). Once the peak intensities drown in the counting noise, the refinement algorithm will be able to fit positive intensities into the noise pattern. This has some undesired side effects: These residual intensities, even when reported as „not detected”, reduce the quantity of the main phase, as long as they are taken into the normalization of phase quantities to 100 %. In Table 3 the quantity of phase A is reduced to 99.10 wt-% due to accumulated residual intensities, even though no contaminations were present. In order to avoid this problem, which can become even more pronounced if more non-existent phases are added to the refinement, it is recommended to remove phases below the detection limit from the project and repeat the refinement. This process should be repeated until none of the refined phases is below the detection limit. Profex facilitates this strategy by highlighting phases below the detection and quantification limits and by showing a warning in the summary table. The feature has to be enabled in the preferences dialog (Edit → Preferences… → BGMN → Summary Tables → „Show warnings for values below detection and quantification limit”). In the same dialog the variation coefficients (VCs) used as limits of quantification and detection can be defined. In the example shown in Figure 14 the limit of quantification is reached when the refined quantity falls below 8 times its ESD (VC ≥ 12.5 %), and the limit of detection is reached when it falls below 4 times its ESD (VC ≥ 25 %).

Some phases actually converge towards 0.0 wt-% despite a considerable noise pattern. In that case the ESD may reach 0.0 wt-%, too. However, this is an artifact of the refinement algorithm and its error propagation, as there cannot be an absolute certainty of absence of a particular phase as long as there is noise superimposing the diffraction signal. After all, there might be a signal hidden in the noise. If the ESD reaches 0.0, the refined quantity might never fall below the quantification and detection limit, as the ESD shrinks along with the value rather than remaining constant, and the VC may or may not exceed the LOQ or LOD at a certain point. In order to avoid this undesired result, Profex allows to define a minimum ESD. Any refined ESD below this value will be considered to be an artifact, i.e. an unrealistically low ESD, and instead the minimum ESD specified in the preferences dialog will be used. That way, a hard-coded minimum LOQ and LOD is introduced. For example, the limit of detection in Figure 14 is defined as

\[
LOD = \frac{ESD}{value} = 0.250
\]

If we refine a phase quantity to 0.06 wt-% with an ESD of 0.01, its VC is:

\[
VC = \frac{0.01}{0.06} = 0.167
\]

The VC does not exceed the LOD, therefore the phase quantity of 0.06 wt-% should be considered detectable, Profex will not show the warning „< LOD”. However, it is quite obvious that a quantity of 0.06 wt-% cannot be detected in most real datasets collected on conventional instruments with standard settings. Also an ESD of 0.01 wt-% is impossible to achieve if there is counting
Figure 14: Warnings for quantities below LOQ and LOD can be activated in the preferences dialog. Variation coefficients ($VC = \frac{ESD}{value}$) used as LOQ and LOD are also specified on the same page.

noise in the pattern. The low ESD must therefore be an artifact. Applying Profex’ minimum ESD at 0.05 wt-% (which is a realistic choice), the equation changes as follows

$$VC = \frac{\text{minESD}}{0.06} = \frac{0.05}{0.06} = 0.833$$

The VC exceeds the LOD of 0.250 by far, and the quantity of 0.06 wt-% is flagged as „< LOD“. In fact, any quantity below

$$\frac{\text{minESD}}{LOD} = \frac{0.05}{0.250} = 0.20$$

will be flagged as „< LOD“, regardless of its refined ESD.

If the minimum ESD is set to 0.0, the feature is deactivated and all refined ESDs will be used as read from the results file. This is not recommended. The minimum ESD should be set to a positive value. The non-existent phases B and D in Table 3 that converged to a positive residual intensity (bottom line) had residual ESDs of 0.06 and 0.14 wt-%. It is a reasonable guess to use a value just below the residual ESDs of non-existent phases as a minimum ESD. In this example, 0.05 wt-% seems to be a good choice.
Figure 15: Profex showing warnings for phases below the detection limit (< LOD).
Table 3: Reference mixtures of 3 contamination phases (B, C, D) in a matrix (A). All values are given in wt-%.

<table>
<thead>
<tr>
<th>Composition (A + B + C + D)</th>
<th>Quantity A</th>
<th>ESD A</th>
<th>Quantity B</th>
<th>ESD B</th>
<th>Quantity C</th>
<th>ESD C</th>
<th>Quantity D</th>
<th>ESD D</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0 + 33.3 + 33.3 + 33.3</td>
<td>0.02</td>
<td>0.01</td>
<td>33.79</td>
<td>0.29</td>
<td>32.54</td>
<td>0.19</td>
<td>33.65</td>
<td>0.37</td>
</tr>
<tr>
<td>1.0 + 33.0 + 33.0 + 33.0</td>
<td>0.66</td>
<td>0.11</td>
<td>33.57</td>
<td>0.29</td>
<td>32.33</td>
<td>0.20</td>
<td>33.44</td>
<td>0.38</td>
</tr>
<tr>
<td>10.0 + 30.0 + 30.0 + 30.0</td>
<td>9.58</td>
<td>0.24</td>
<td>30.63</td>
<td>0.29</td>
<td>29.44</td>
<td>0.20</td>
<td>30.36</td>
<td>0.40</td>
</tr>
<tr>
<td>25.0 + 25.0 + 25.0 + 25.0</td>
<td>24.98</td>
<td>0.29</td>
<td>25.48</td>
<td>0.28</td>
<td>24.20</td>
<td>0.19</td>
<td>25.34</td>
<td>0.40</td>
</tr>
<tr>
<td>40.0 + 20.0 + 20.0 + 20.0</td>
<td>40.37</td>
<td>0.30</td>
<td>20.35</td>
<td>0.26</td>
<td>19.02</td>
<td>0.18</td>
<td>20.27</td>
<td>0.41</td>
</tr>
<tr>
<td>55.0 + 15.0 + 15.0 + 15.0</td>
<td>55.94</td>
<td>0.25</td>
<td>14.95</td>
<td>0.19</td>
<td>14.00</td>
<td>0.15</td>
<td>15.11</td>
<td>0.26</td>
</tr>
<tr>
<td>70.0 + 10.0 + 10.0 + 10.0</td>
<td>70.71</td>
<td>0.25</td>
<td>9.82</td>
<td>0.17</td>
<td>9.14</td>
<td>0.13</td>
<td>10.32</td>
<td>0.25</td>
</tr>
<tr>
<td>77.5 + 7.5 + 7.5 + 7.5</td>
<td>78.07</td>
<td>0.22</td>
<td>7.44</td>
<td>0.14</td>
<td>6.72</td>
<td>0.12</td>
<td>7.77</td>
<td>0.17</td>
</tr>
<tr>
<td>85.0 + 5.0 + 5.0 + 5.0</td>
<td>85.55</td>
<td>0.21</td>
<td>4.91</td>
<td>0.13</td>
<td>4.27</td>
<td>0.12</td>
<td>5.27</td>
<td>0.17</td>
</tr>
<tr>
<td>94.0 + 2.0 + 2.0 + 2.0</td>
<td>93.79</td>
<td>0.19</td>
<td>2.02</td>
<td>0.10</td>
<td>1.65</td>
<td>0.08</td>
<td>2.53</td>
<td>0.15</td>
</tr>
<tr>
<td>97.0 + 1.0 + 1.0 + 1.0</td>
<td>96.64</td>
<td>0.17</td>
<td>1.05</td>
<td>0.09</td>
<td>0.74</td>
<td>0.05</td>
<td>1.57</td>
<td>0.14</td>
</tr>
<tr>
<td>98.5 + 0.5 + 0.5 + 0.5</td>
<td>98.09</td>
<td>0.16</td>
<td>0.54</td>
<td>0.08</td>
<td>0.30</td>
<td>0.04</td>
<td>1.08</td>
<td>0.13</td>
</tr>
<tr>
<td>99.4 + 0.2 + 0.2 + 0.2</td>
<td>98.79</td>
<td>0.14</td>
<td>0.28</td>
<td>0.07</td>
<td>0.09</td>
<td>0.03</td>
<td>0.84</td>
<td>0.12</td>
</tr>
<tr>
<td>100.0 + 0.0 + 0.0 + 0.0</td>
<td>99.10</td>
<td>0.15</td>
<td>0.14</td>
<td>0.06</td>
<td>0.00</td>
<td>0.00</td>
<td>0.75</td>
<td>0.14</td>
</tr>
</tbody>
</table>
15. Text Blocks

Text blocks are pre-defined sections of text that need to be inserted in control or structure files regularly. Instead of entering the text manually each time, a text block can be selected from the menu and inserted conveniently at the text cursor position in the currently shown text editor. Section 28.7 describes how to manage text blocks.

A common scenario for text blocks is the structure file code to activate sub-phase refinement. The same code is needed occasionally in structure files. It can thus be pre-defined in the preferences and applied from the menu ,,Edit → Insert Text Blocks”. The block will be inserted at the position of the text cursor. An example block is shown below.

RefMult=2

PARAM=pG=0.5_0.1
GEWICHT[1]=pG*GEWICHT
GEWICHT[2]=(1-pG)\times GEWICHT

PARAM=pB1=1_0.1^10
B1[1]=B1
B1[2]=pB1\times B1

16. Refinement Preset

For routine analyses or refinements of series of measurements it is often recommended to use exactly the same structure files and refinement strategy in order to obtain reproducible and user-independent results. Instead of using the ,,Add/Remove Phase” dialog each time to select the device configuration and structure files, this information can also be loaded from a refinement preset file. A preset thus automates the choice of device configuration and structure files, and reduces user input to a single mouse click.

Preset files store data in XML format. Their storage location can be configured in ,,Edit → Preferences... → BGMN → Configuration → Presets directory”, as described in section 4. When opened in a text editor, the file must have the following structure:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<preset name="anyName">
    <device MD5hash="..." RelativePath="...">myInstrument.geq</device>
    <device MD5hash="..." RelativePath="...">myInstrument.ger</device>
    <device MD5hash="..." RelativePath="...">myInstrument.sav</device>
    <template MD5hash="..." RelativePath="...">myTemplate.tpl</template>
    <structures>
        <structure MD5hash="..." RelativePath="...">myPhaseA.str</structure>
        <structure MD5hash="..." RelativePath="...">myPhaseB.str</structure>
        <structure MD5hash="..." RelativePath="...">myPhaseC.str</structure>
```
At least one `<device>` and `<template>` node must be present. If one of them is missing, applying the preset will abort. If more than one template node is present, all but the first will be ignored. An arbitrary number of `<structure>` and `<other><...file>` nodes may be present. All paths can either be absolute or relative to the location of the preset file. Device and template files do not need to have the same file name. It is possible to use different template files with the same device file.

Files specified in

```
<other>
    <textfile>...</textfile>
</other>
```

and

```
<other>
    <binaryfile>...</binaryfile>
</other>
```

tags will be copied to the project directory. These tags can be used for arbitrary files, such as descriptions, background scans, raw data, report files etc. It is important to specify whether the file is stored in text or binary format. For text format files Profex will convert the line endings to the target platform to maintain platform independence. Binary files will be copied without modification. If unsure, use `<binaryfile>`, as the copied file will not be modified.

Note that custom profile functions („Edit → Preferences… → BGMN → STR File Handling“) will not be applied when using presets, as it would undermine the purpose of reproducing precisely defined refinement scenarios.

A typical file structure of a preset named „scenarioA“ is shown below:

```
Presets
|
|_scenarioA
|  |_scenarioA.pfp
|  |_instrA.geq
|  |_instrA.ger
|  |_instrA.sav
|  |_scenarioA.tpl
|  |  |_phaseA.str
|  |  |_phaseB.str
|  |  |_instrA-bkgr.xy
```
The preset file „scenarioA.pfp” references all other files being part of the preset:

```xml
<!DOCTYPE ProfexPreset>
<preset version="20160910" name="scenarioA">
  <device MD5hash="fc74..." RelativePath="">instrA.geq</device>
  <device MD5hash="0523..." RelativePath="">instrA.ger</device>
  <device MD5hash="c2fb..." RelativePath="">instrA.sav</device>
  <template MD5hash="f089..." RelativePath="">scenarioA.tpl</template>
  <structures>
    <structure MD5hash="1fdb..." RelativePath="">phaseA.str</structure>
    <structure MD5hash="787e..." RelativePath="">phaseB.str</structure>
  </structures>
  <other>
    <textfile MD5hash="cc87..." RelativePath="">instrA-bkgr.xy</textfile>
  </other>
</preset>
```

The optional node argument `MD5hash` stores a checksum of the file in hexadecimal format. The checksum will be verified each time the preset is applied. In case of a mismatch, a warning will be presented informing the user that the file has been modified and offering to cancel or proceed. The optional argument `RelativePath` stores the file’s destination path relative to the scan file the preset is applied to.

### 16.1. Source and destination paths

Refinement presets offer some flexibility in terms of referenced file locations (structure, device, other files), both at the source (in the presets directory) and destination (in the project directory) of the preset. The preset file „scenarioA.pfp” will be used as an example. If the file name of, for example, a structure file is specified without a path, the structure file will be searched at the location of the preset file:

```xml
<structure RelativePath="">phaseA.str</structure>
```

If the file name is specified with a relative path (here „structures”), it will be searched in a sub-directory starting from the preset file:

```xml
<structure RelativePath="">structures/phaseA.str</structure>
```
It is also possible to specify absolute file paths to locate the structure file. In that case, the structure file will be searched at the absolute path location, regardless of the location of the preset file:

```xml
<structure RelativePath=""/>
   C:\Profex-BGMN\Profex\Presets\scenarioA\phaseA.str
</structure>
```

The destination of the structure file (or any other file) is specified by the „RelativePath“ argument. It will be used when the preset is applied to a scan file (here „myScan.raw“) to specify the location relative to the scan file after the preset has been applied. If no relative path is given, the structure file will be copied to the location of the scan file:

```xml
<structure RelativePath=""/>
   phaseA.str
</structure>
```

myProject
   myScanA.raw
   phaseA.str

If a relative path is specified, a sub-directory will be created for the structure file:

```xml
<structure RelativePath="structures"/>
   phaseA.str
</structure>
```

myProject
   structures
   phaseA.str

The relative path of the structure file at the source location will be ignored. The structure file will be copied to the relative path specified as „RelativePaths=":

```xml
<structure RelativePath="destination/phases"/>
   source/structures/phaseA.str
</structure>
```

myProject
   destination
      phases
         phaseA.str

There is one exception when the relative path at the source location is not ignored: If no relative path is specified (empty or absent) and the structure file is located in a sub-directory in the preset directory, this sub-directory will be used as a relative path. This is necessary in order to maintain backward compatibility with previous versions of Profex presets:

```xml
<structure RelativePath=""/>
   structures/phaseA.str
</structure>
```

myProject
   structures
      phaseA.str

**Warning:** It is possible to specify destination locations of files outside of the project directory:

```xml
RelativePath="..\structures"
```

This is likely to cause problems by overwriting files used by other projects. It is strongly advised not to specify relative paths outside of the project directory.
16.2. Creating and Using Presets

Presets can be created from an existing refinement as follows:

1. Load your raw data using „File → Open Graph File…”.
2. Create your refinement control file using the „Add/Remove Phase” dialog.
3. Run and optimize the refinement until you are satisfied with the quality of fit.
4. Select „Project → Save as Refinement Preset…” and save the file in the Preset directory specified in the Preferences dialog (section 3).

The preset is now ready for use. It can be applied to a new raw data scan as follows:

1. Load your raw data using „File → Open Graph File…”.
2. Select „Project → Refinement Presets → <preset name>” or use the button in the project toolbar to create the control file.
3. Click „Run → Run Refinement”.

16.3. Presets for Quality Control

An MD5 checksum is saved for each file referenced in the preset (MD5hash=...). When applying the preset, Profex will verify the integrity of the files and issue a warning if files were modified. The preset can still be applied, but the user was informed about (accidental or intentional) modifications of the files.

Presets allow using Profex for routine quality control in an accredited environment. In such a scenario it is recommended to store the presets directory on a network shared drive, and giving write access only to the lab manager. This, in combination with MD5 checksums, provides a high level of data integrity and reduces user input to applying the correct preset.

17. Creating Structure Files (*.str)

Crystal structure files retrieved from online or commercial databases are usually supplied in the CIF format [10] or in an XML file format if exported from the ICDD PDF-4+ database. Before they can be used with BGMN, the structure information needs to be converted the the BGMN STR file format. Profex provides support to facilitate the conversion process for both CIF and XML formats. PDF-4+ XML files are usually complete and require very little user input. CIF files, on the other hand, often lack important information and require manual revision. The import and conversion process in Profex is the same for both CIF and XML formats.

---

2 Project loaded before saving the preset need to be closed and re-opened in order to scan for new presets.
17.1. CIF and ICDD XML import

The following workflow is recommended for CIF or XML import:

1. Retrieve a CIF or XML file from an external resource (online or local database).
2. Start Profex and choose „File → Import Structure file...” to open the import dialog.
3. Click the + button in the dialog to load the source file.
4. If no space group number was found in the source file, Profex will display a dialog to select the number. Select the space group number of your structure. It has to be known or determined from an external source.
5. If more than one space group setting is available, a dialog will be shown asking for the correct setting.
6. The STR file is created and shown in an editor (Fig. [16]). At the same time, the file is verified by running BGMN in the background. If successful, a $hkl$ stick pattern will be shown. Else an error message appears in the „Messages” console. The file name in the „Files” list is preceded by an asterisk (*) if verification failed.
7. If verification failed, add the missing information manually. Then run verification again by pressing the „$\triangledown$” button.
8. Once verification has been successful, save the file to the structures repository.

Sometimes it is helpful to browse the space group numbers and symbols in the form supported by BGMN. Open „Tools → Browse Space Groups” to open a dialog which shows all space group numbers, settings, and Wyckoff sequences in the nomenclature used by BGMN (Fig. [17]).

The assignment CIF file tags to STR parameters is described in Table [4].

The button to save all STR files will ignore files that failed verification (marked by *). It will save all successfully verified files to the structure file repository, using the same file base name as the source CIF files.

17.2. Verification

STR files created from CIF files should be verified before saving to the structure file repository, because CIF import often results in incomplete STR files. Verification is run immediately after opening the CIF file. It can also be run manually at any time by clicking the „$\triangledown$” button in the „Import Structure Files” dialog. If verification was successful, a $hkl$ stick pattern is shown. Select the correct wavelength at the bottom of the dialog to display the $hkl$ indices at the correct $2\theta$ position for a specific instrument. The $hkl$ graph can be exported to a semi-colon separated text file (*.csv), a PDF file, or a pixel image.

If verification failed, an error message issued by BGMN appears in the „messages” console, the $hkl$ graph is cleared, and the file name is preceded by an asterisk (*). Study the error message, try
to fix the issue in the STR file, and run verification again. STR files that haven’t passed verification will later issue the same error message when used in a refinement.

**Important:** Even if verification is successful, the STR file and resulting hkl pattern can still be faulty. This is due to the fact that BGMN expects all atomic coordinates to be given in standard settings (within the asymmetric unit, and in the first Wyckoff symmetry). It is strongly recommended to compare the hkl intensities with a reference pattern, e.g. from a different database, and the calculated density shown in the legend with a reference value. If differences occur, verify all atomic coordinates and make sure that the values comply with the first symmetry for the atom’s Wyckoff position. Use the „Tools → Browse Space Groups” dialog (Fig. [17]) to browse the symmetries.

### 17.3. Automatic conversion of thermal displacement parameters

During the conversion from CIF or XML to STR format Profex automatically transforms the thermal displacement parameters to the format supported by BGMN. Depending on the source format, the following conversions are calculated (anisotropic $\beta_{ij}$ values are not supported by the CIF format):

**Isotropic $B$:** Isotropic $B$ is the format supported by BGMN. However, BGMN uses a different unit than normally provided in the CIF file. Automatic conversion therefore performs the following conversion:

$$B_{iso}[nm^2] = 0.01 \cdot B_{iso}[\AA^2]$$

**Anisotropic $B_{ij}$:** Anisotropic $B_{ij}$ are converted to isotropic $B$ values in the expected unit [21]:

$$B_{iso}[nm^2] = 0.01 \cdot \frac{1}{3} \sum_i \sum_j B_{ij} a_i^* a_j^* A_i A_j$$

with reciprocal lattice parameters $a^*[\AA^{-1}]$ and real lattice parameters $A[\AA]$.

**Anisotropic $U_{ij}$:** Anisotropic $U_{ij}$ are converted to $U_{equiv}$ using the expression [21]:

$$U_{equiv} = \frac{1}{3} \sum_i \sum_j U_{ij} a_i^* a_j^* A_i A_j$$

with reciprocal lattice parameters $a^*[\AA^{-1}]$ and real lattice parameters $A[\AA]$. $U_{equiv}$ is converted to $B_{iso}$ by the following equation.

**Isotropic $U_{equiv}$:** Isotropic $U_{equiv}$ values are converted to isotropic $B$:

$$B_{iso}[nm^2] = 0.01 \cdot 8.0 \cdot \pi^2 \cdot U_{equiv}$$
Figure 16: After conversion from CIF to STR format, BGMN will be called in the background to run the STR file. If successful, a hkl stick pattern will be shown, else an error message appears in the „Messages“ page.
<table>
<thead>
<tr>
<th>CIF File</th>
<th>STR File</th>
</tr>
</thead>
<tbody>
<tr>
<td>_chemical_name_mineral</td>
<td>PHASE=<code>name</code></td>
</tr>
<tr>
<td>_chemical_name_common</td>
<td>PHASE=<code>name</code></td>
</tr>
<tr>
<td>_chemical_name_systematic</td>
<td>Reference=<code>name</code></td>
</tr>
<tr>
<td>_database_code[a-z]</td>
<td>Formula=<code>name</code></td>
</tr>
<tr>
<td>_chemical_formula[a-z]</td>
<td>SpacegroupNo=<code>number</code></td>
</tr>
<tr>
<td>_symmetry_Int_Tables_number</td>
<td>SpacegroupNo=<code>number</code></td>
</tr>
<tr>
<td>_space_group_IT_number</td>
<td>HermannMauguin=<code>symbol</code></td>
</tr>
<tr>
<td>_symmetry_space_group_name_H-M</td>
<td>HermannMauguin=<code>symbol</code></td>
</tr>
<tr>
<td>_cell_length_a / _b / _c</td>
<td>A= / B= / C=<code>value</code></td>
</tr>
<tr>
<td>_cell_angle_alpha / _beta / _gamma</td>
<td>ALPHA= / BETA= / GAMMA=<code>value</code></td>
</tr>
<tr>
<td>_atom_site_label</td>
<td>E=<code>M±n(value)</code></td>
</tr>
<tr>
<td>_atom_site_type_symbol</td>
<td>E=<code>M±n(value)</code></td>
</tr>
<tr>
<td>_atom_site_Wyckoff_symbol</td>
<td>Wyckoff=<code>symbol</code></td>
</tr>
<tr>
<td>_atom_site_occupancy</td>
<td>E=<code>M±n(value)</code></td>
</tr>
<tr>
<td>_atom_site_frac_t.x / _y / _z</td>
<td>x= / y= / z=<code>value</code></td>
</tr>
<tr>
<td>_atom_site_B_iso_or_equiv</td>
<td>TDS=<code>value</code></td>
</tr>
<tr>
<td>_atom_site_U_iso_or_equiv</td>
<td>TDS=<code>value</code></td>
</tr>
<tr>
<td>_atom_site_aniso_U[1-3]</td>
<td>TDS=<code>value</code></td>
</tr>
<tr>
<td>_atom_site_aniso_B[1-3]</td>
<td>TDS=<code>value</code></td>
</tr>
</tbody>
</table>

Table 4: Assignment of CIF parameter tags to BGMN STR variables.
18. Creating Instrument Configuration Files

Raytraced geometric peak profiles must be calculated by BGMN prior to refinement. The instrument configuration is described in a control file, and the two programs **GEOMET** and **MAKEEQ**, which are part of the BGMN software distribution, are used to calculate and interpolate the peak profile in a specific 2θ range. For more information please refer to the BGMN documentation [1].

Profex allows editing instrument control files in a simple text editor, and runs **GEOMET** and **MAKEEQ** to generate the output files. A common workflow to modify an existing device configuration is shown below.

1. Run Profex and click ,,Instrument → Edit Configuration…”. Profex will open a file dialog in the Device database directory. Select the instrument control file (*.sav) you intend to modify.

2. The instrument dialog shown in Fig. [18] will be shown. Edit the file to precisely match your hardware configuration.

3. Save the file under a new name using the dialog’s ,,Save As” button. Be sure to save it in a directory with write access.

4. Check the options ,,Raytrace (GEOMET)” and ,,Interpolate (MakeEQ)”. The option ,,Calculate Profile (GERTEST)” is optional.
5. Check the option „Create Template for Refinement Control File” and select your tube’s target material and the type of monochromator you use.

6. Click the „Run” button and wait until the progress dialog has completed. Depending on the computer hardware, simulated angular range, and device configuration, this process may take several minutes to complete.

Figure 18: „Instrument → Edit Configuration…” opens a dialog to edit an existing instrument configuration.

Once the process has completed, BGMN has created two new files (*.ger and *.geq), which are required for refinements. If they were created outside of the Device database directory, they should be moved there in order to appear in the „Add Phase” dialog. It is also recommended to manually create a template file for the new configuration, as described in section 4.2.

Using „Instrument → New Configuration…” will allow to read some hardware information from Bruker RAW V4, Bruker BRML V5, and PANalytical XRDML files to create a BGMN instrument configuration file from scratch. Other raw data formats are not supported. Usually several variable required by BGMN will still not be available from the raw data files and will thus have to be entered manually.
19. Show Peak Profiles

The shape of measured diffraction peaks originates from a convolution of the wavelength emission spectrum, geometrical features of the instrument, and peak broadening by certain sample properties. Profex allows to display the individual contributions to the peak shape using the feature ,,Instrument → Show Peak Profile ...”. The dialog features four tabs. The first three tabs are used to display wavelength, instrumental, and sample profile shape contributions. The fourth tab shows the convoluted profile, and only is enabled once the first three tabs show data. Fig. 19 shows examples for all four pages.

All graphs can be zoomed horizontally using the mouse scroll wheel, unzoomed using the right mouse button, and dragged using the left mouse button. Also the graphs can be exported to CSV table files, PDF graphs, and pixel images. Clicking the second button from the left will reload the current file from disk. This allows to quickly update the graph when editing the source file in a text editor.

The filled curve always represents the total contribution function, which are usually composed of several sub-curves. The sub-curves can be toggled on and off using the third button from the left in the bottom-left corner of the dialog.

It is generally recommended to start with the left-most tab and load some data. Then proceed to the next tab. Once the third tab contains data, the fourth tab is enabled and the convoluted profile can be calculated.

19.1. Wavelength Distribution D

The first tab allows to display the characteristic spectrum of an X-ray tube, as it is described in a *.lam file bundled with BGMN and Profex. Use the first button on the left to load a file. The file dialog automatically opens in the BGMN directory and offers all *.lam files to be opened. Once opened, the dialog will show the wavelength spectrum on an Ångstrom scale.

The sub-curves on this graph represent the lorentzian curves described in the *.lam file in order to approximate the characteristic spectrum.

19.2. Instrumental Function G

The instrumental function originating from the goniometer layout is read from a *.geq file, which is obtained as a result of the raytracing and interpolation of the peak shape as described in section 18. When loading a file, the file dialog will automatically open in the device repository.

Instrument contributions are displayed on a Δ2θ axis. The position 0.0 represents the peak center, values to the left and right represent deviations from the center. The actual 2θ value is shown in the legend. Since the instrument contribution depends on the 2θ position, a slider at the bottom of the dialog can be used to scroll through the 2θ range the profile was calculated in (defined in the instrument *.sav file).
Sub-curves represent lorentzian curves computed by BGMN to approximate the raytraced profile.

19.3. Sample Function $P$

Peak broadening by small crystallite size and micro-strain can be computed on the third tab. There is no file to load. Instead, enter values for the BGMN variables $B_1$, $k_1$, and $k_2$ in the spin boxes, then press the „Reload” button (second button from the left) to compute the profile contribution. The peak broadening is shown on a $1/d$ axis. It also depends on the $2\theta$ position of the peak, which can be scrolled through using the slider.

Sub-curves represent individual contributions of crystallite size and micro-strain.

19.4. Convolution $D^*G^*P$

In order to convolute the peak profile contributions shown in the first three tabs, raise the fourth tab and click the „Reload” button (second button from the left). Computation will be complete after a few seconds. The graph will show the observed peak shape on a $\Delta2\theta$ scale with the value 0.0 representing the peak center. The peak’s position in the diffraction pattern is shown in the legend. Use the slider to scroll through the entire $2\theta$ range.

Sub-curves represent contributions from wavelength distribution, instrument geometry, and sample properties. Note that here all contributions are converted to a $2\theta$ scale.

20. Scan batch conversion

Several scan files can be converted to other data formats at a time using the „File → Scan batch conversion…” feature. However, due to limitations given by the formats, SVG and pixel images (PNG) are not available for batch conversion.

When opening the batch conversion dialog by clicking „File → Scan batch conversion…”, the file queue will contain all currently opened scan files by default. More files can be added by clicking the „Add File” button and selecting one or more files, and selected files can be removed from the queue by clicking the „Remove File” button.

Some output format support multiple scans stored in a single file. The option „Write scans to one file” will instruct Profex to store all scans found in a source file into one single file. In that case, all scans $I_{obs}$, $I_{calc}$, $I_{diff}$, $I_{background}$, and all sub phase patterns found in a DIA file will be stored in a single output file. Use „Write scans to individual files” to write these patterns into single output files instead. Note that storing multiple scans in one file must be supported by the output format as well as by Profex’ output filter, which is currently only the case for ASCII and Gnuplot files.
Figure 19: The dialog „Instrument → Show peak profile…“ allows to display the individual contributions leading to the convoluted observed peak shape.
Click „Convert” to start the conversion process, or „Close” to close the dialog without conversion. Output files will be stored at the location of their source files using the same base file name. Existing output files will be overwritten without warning.

21. Scan File Conversion

In contrast to the BGMN Rietveld backend, which only supports a limited number of scan file formats natively, Profex reads a wide and growing list of file formats. When running a refinement on a scan file format not supported by BGMN, Profex will by default automatically convert the file in the background and modify the control file accordingly. This section describes the conversion process and the settings allowing the user to control the conversion.

Automatic scan file conversion can be switched on and off in the preferences dialog by checking or unchecking the option „Edit → Preferences ... → BGMN → Convert raw scans to XY format”. Scan file handling by Profex will be different depending on this setting. Unless conversion is not desired for specific reasons, users are strongly advised to activate this option.

It is a surprisingly complex task to determine the correct file name of a project’s raw scan (VAL\[n\] keyword in the control file). The possible scenarios to be considered are manifold. Profex has sophisticated routines to determine the best guess for a VAL file name under all circumstances. These routines are illustrated in Figures 21–24.

In principle, when creating a new project, a raw scan file as obtained from the instrument is opened and a new control file is created either by using the „Add a new phase” dialog or the „Copy control file” function (see section 6). Either way the loaded raw scan file determines the location and the base name of the project, and all input and output file names in the control file will automatically be set to this scan’s file base name. More information on file name handling is given in section 4.2. The scan file name to be read by the BGMN Rietveld backend is specified with the VAL\[n\]=ScanFile.xxx line in the control file. The scan file name is given by the project name, as described above, but the file format and extension is determined by Profex automatically, depending on the raw scan format and the setting of „Edit → Preferences ... → BGMN → Convert raw scans to XY format”. If a format natively supported by BGMN is detected, the file will be used without conversion. If the format is not supported, the behavior will depend on the setting „Convert raw scans to XY format”: If active, the file will be converted to *.xy format and the VAL\[n\] file entry will be adapted accordingly. If inactive, no conversion will be done and it is in the user’s responsibility to guarantee correct file names and formats. See Fig. 20 for more explanations.

However, the processes described above represent relatively simple scenarios, when the raw scan file is opened and the format and file name are known. In many situations it determining the correct file name is not as straight-forward. The following situation represents a worst case: A DIA file is opened, conversion to *.xy is inactive, and the control file is created from another project using the „Copy control file” feature. Normally, when a DIA file exists, a control file should also exist with a valid VAL\[n\] entry. However, when sharing or moving DIA files, or when the base name of the DIA and control file do not match, it may still occur that a DIA file is present but the
corresponding control file cannot be located. Trying to find the correct raw scan file used to create
die DIA file is difficult in such a situation:

1. The control file copied over from another project contains input and output file names (VAL,
   DIAGRAMM, OUTPUT, etc.) of the source project. All file names must be changed to the
destination project. The VAL file name found in this control file must not be used.

2. The displayed scan is a DIA file, which cannot be used as input file.

3. Converting the DIA file to *.xy is not allowed.

4. There is no reference to the raw scan in any of the available files.

5. In that case, Profex will scan the directory of the DIA file for a raw scan file in a format
   natively supported by BGMN. But there is no guarantee that such a file is found.

This is one of many scenarios when finding the correct VAL file name is not trivial. However,
the complex processes illustrated in Figures 21–24 cover most situations, and if no solution can be
found, a warning will be issued.
If the raw scan format (here: xrdml) is not natively supported by BGMN, Profex will change the VAL\[n\] file name to *.xy and convert the file automatically.

<table>
<thead>
<tr>
<th>working directory</th>
<th>% Input files</th>
</tr>
</thead>
<tbody>
<tr>
<td>_scan_1.sav</td>
<td>VAL[1]=scan_1.xy</td>
</tr>
<tr>
<td>_scan_1.xrdml</td>
<td>VERZERR=instrument.geq</td>
</tr>
<tr>
<td>_structure_1.str</td>
<td>LAMBDA=CU</td>
</tr>
<tr>
<td>_instrument.sav</td>
<td>STRUC[1]=structure_1.str</td>
</tr>
<tr>
<td>_instrument.geq</td>
<td>% Output files</td>
</tr>
<tr>
<td>_instrument.ger</td>
<td>LIST=scan_1.lst</td>
</tr>
<tr>
<td></td>
<td>OUTPUT=scan_1.par</td>
</tr>
<tr>
<td></td>
<td>DIAGRAMM=scan_1.dia</td>
</tr>
</tbody>
</table>

If conversion to *.xy is deactivated, VAL\[n\] will be the raw scan file. If it is not supported natively by BGMN (e.g. xrdml), refinement will not start.

<table>
<thead>
<tr>
<th>working directory</th>
<th>% Input files</th>
</tr>
</thead>
<tbody>
<tr>
<td>_scan_1.sav</td>
<td>VAL[1]=scan_1.xrdml</td>
</tr>
<tr>
<td>_scan_1.xrdml</td>
<td>VERZERR=instrument.geq</td>
</tr>
<tr>
<td>_structure_1.str</td>
<td>LAMBDA=CU</td>
</tr>
<tr>
<td>_instrument.sav</td>
<td>STRUC[1]=structure_1.str</td>
</tr>
<tr>
<td>_instrument.geq</td>
<td>% Output files</td>
</tr>
<tr>
<td>_instrument.ger</td>
<td>LIST=scan_1.lst</td>
</tr>
<tr>
<td></td>
<td>OUTPUT=scan_1.par</td>
</tr>
<tr>
<td></td>
<td>DIAGRAMM=scan_1.dia</td>
</tr>
</tbody>
</table>

Natively supported file formats (here: Seifert val) do not require conversion to *.xy. Profex will use the raw scan file name for the VAL\[n\] entry, regardless of the state of the „Convert raw scans to XY“ setting.

<table>
<thead>
<tr>
<th>working directory</th>
<th>% Input files</th>
</tr>
</thead>
<tbody>
<tr>
<td>_scan_1.sav</td>
<td>VAL[1]=scan_1.val</td>
</tr>
<tr>
<td>_scan_1.val</td>
<td>VERZERR=instrument.geq</td>
</tr>
<tr>
<td>_structure_1.str</td>
<td>LAMBDA=CU</td>
</tr>
<tr>
<td>_instrument.sav</td>
<td>STRUC[1]=structure_1.str</td>
</tr>
<tr>
<td>_instrument.geq</td>
<td>% Output files</td>
</tr>
<tr>
<td>_instrument.ger</td>
<td>LIST=scan_1.lst</td>
</tr>
<tr>
<td></td>
<td>OUTPUT=scan_1.par</td>
</tr>
<tr>
<td></td>
<td>DIAGRAMM=scan_1.dia</td>
</tr>
</tbody>
</table>

Figure 20: Some examples for working and failing VAL[n] file scenarios.
Figure 21: VAL file handling when calling the „Add Phase“ dialog and activating the option „Generate default control file” to create a control file from a template file.
Start „Copy control file“

Temporarily store file name of previous VAL[n] = entry if available

Apply new control file content

Previous VAL[n] = empty?

no

VAL[n] = previous VAL file

yes

Convert to *.xy?

yes

VAL[n] = displayed scan file

no

Disp. scan file = native BGMN format?

yes

VAL[n] = displayed scan file

no

Search natively supported file with the same base name at the same location as the displayed scan file

Alternative scan file found?

yes

VAL[n] = alternative scan file

no

Leave VAL[n] = empty, display warning

Proceed to „VAL file verification“

Figure 22: VAL file name handling when using the „Copy control file“ function.
Figure 23: Automatic verification of a VAL[n] file entry in the SAV control file. This function is called at several occasions when modifying the control file content. E.g. after creating a default control file, or after applying a control file from another project.
Start „Create VAL file“

VAL[n] = file exists on hard disk?

yes

no

Convert displayed scan file to *.xy

Launch BGMN refinement process

Figure 24: Immediately before running the refinement process, Profex checks whether the VAL file referenced in the control file exists on the hard disk. If not, a *.xy file will be created from the currently displayed scan file.
22. Favorites

Reference structure files can be flagged as favorites in the preferences dialog (Fig. 25). Favorite phases can then be filtered in the „Add / Remove Phase“ dialog and in the reference phase dropdown menu by clicking the „Show favorites“ button (Fig. 26). Filtering favorites greatly simplifies handling reference structures in large repositories by limiting the number of displayed structure to a handful of relevant ones.

Important: When double-clicking a peak in the diffraction pattern to identify the nearest reference structure while filtering of favorites is active for the reference structure list (Fig. 26 top-left), only the favorites will be searched. In order to search all reference structures, temporarily deactivate favorites filtering (Fig. 26 top-right) prior to double-clicking.

![Figure 25: Favorite reference structure files are configured in the preferences dialog by checking the box in the 4th column „Favorites“.

Figure 25: Favorite reference structure files are configured in the preferences dialog by checking the box in the 4th column „Favorites“.
Figure 26: Filtering favorite reference structures (left) allows to quickly change between relevant (left) and all (right) structure files in the repository.
23. Baselines

Note: Subtracting baselines from raw data later used for Rietveld refinement is not recommended. All Rietveld refinement programs rely on unmodified intensities for error estimation.

Profex allows to compute a baseline (background curve) for scans in a project. Use „Project → Add Baseline...“ to open the dialog shown in Fig. 27. Two different algorithms \[17, 18\] are implemented with various parameters to adjust. The dialog provides the following options:

**Scan** Select the scan to add a baseline for.

**Algorithm** Select the algorithm for baseline calculation.

**Append** Appends the baseline to the project without closing the dialog. Another one can be created, either for a different scan, or for the same one but using different parameters.

**OK** Appends the baseline to the project and closes the dialog.

**Cancel** Discards the baseline and closes the dialog.

Depending on the selected algorithm, various different parameters can be adjusted in order to optimize the baseline. There is no recommended setup. One set of parameters might work well for a certain diffraction dataset whereas it might be a poor choice for another dataset. It is recommended to adjust the parameters until a satisfying baseline is created. The parameters are described in the sections below.

Baselines appended to the project are not yet saved to disk. If the project or the program is closed, they are discarded. To preserve the baselines, open the „Plot Options“ window, right-click on the baseline scan, and select „Export Scan...“. Select „Ascii Free format (*.xy *.XY)“ file type, or any other format of your preference.

Baselines can be subtracted from measured data using the „Scan Math“ feature (section \[24\]). However, as mentioned above, raw data used for Rietveld refinement must not be modified by baseline subtraction. However, in situations when the refined background curve is not able to accurately describe amorphous signals or low-angle steps in the background, it may still be desired to use a fitted baseline on top of the refined background. This is done as follows:

1. Create a baseline for the raw data scan, and export it to disk in „Ascii Free format (*.xy *.XY)“ as described above, for example as „myBaseline.xy“.
2. Create a refinement project and open the control file (*.sav).
3. Add the following line to the control file
   
   ```
   UNT=myBaseline.xy
   ```
4. Now run the refinement

The resulting background curve is a combination of the manually created baseline and a refined background polynom. This approach has no negative effect on error estimation.
23.1. SNIP algorithm

The SNIP algorithm \[17\] allows two adjust two parameters:

**Clipping Window** Select either an increasing or a decreasing clipping window. The decreasing window usually results in a smoother baseline and is generally the preferred choice.

**Iterations** The number of iterations determines the curvature of the baseline. Low values result in the line bending into the feet of wide peaks. High values result in a smoother, more continuous line. Adjust the value until the baseline follows the background, but does not bend into peaks.

23.2. Golotvin and Williams algorithm

The algorithm published by Golotvin and Williams \[18\] is based on interpolated anchor points. The first 6 parameters control the selection of anchor points, whereas the last option defines the interpolation function. Anchor points are shown in the table on the right, and can be fine adjusted manually.

**Data smoothing M:** Raw data can be smoothed prior to selecting anchor points. The smoothing algorithm is described in \[18\]. Select 0 for no smoothing. Greater values result in stronger smoothing. Usually a low number (0–5) works best.

**Window size N:** The number of data points used for the anchor point selection window. Data point \(i\) is compared with its neighbors in the window from data points \(i - N/2\) to \(i + N/2\) in order to determine whether or not it qualifies as an anchor point. Lower values result in
more flexible baselines, greater values in smoother ones. Values between 5–20 usually work well.

**Noise multiplier n**: Multiplier factor for the noise $\sigma_{\text{noise}}$. See equation 1 in the original paper [18] for more information. Greater values result in more data points being used as anchor points. Lower values are more restrictive, resulting in lower number of anchor points. A value of 1.0 is recommended.

**Sampling steps**: Only every $i^{\text{th}}$ data point will be used to determine anchor points. For a value of 1, every data point will be evaluated. For a value of 5, every $5^{\text{th}}$ data point will be evaluated. Values between 1 and 20 are recommended.

**Sensitivity**: For values greater than 1, a certain number of consecutive data points must qualify as anchor points in order for the middle point to be accepted as anchor points. For example, if sensitivity is set to 5, and the following data points all fulfill the requirements for anchor points:

\[
30.02, 30.04, 30.06, 30.08, 30.10
\]

then only the middle point at 30.06 will be used as an anchor point. Greater values for sensitivity result in smoother baselines. Values between 1 and 5 usually work best.

**Last point**: An anchor point will always be added at the position of the last data point in order to avoid extrapolation of the baseline. However, sometimes the scan stops in the middle of a peak rather than on the baseline. In that case, using the last data point as an anchor would bend the baseline upwards. To avoid this, a different intensity value can be used for the last anchor point. Options are either the second last anchor point, resulting in a horizontal end of the baseline, or the lowest anchor point determined anywhere in the diffraction pattern. There is no recommended setting. Avoid abrupt changes of the baseline at the end of the diffraction pattern.

**Interpolation**: Select one from several interpolation functions to connect the anchor points. In most cases, the Akima or monotone spline curves are the best choices.

### 24. Scan Math

The tool „Scan Math“ allows to perform calculations on the intensities of all scans loaded in a project. Expressions must be entered in Java Script syntax [19][20]. After clicking „Generate Scan“ the calculation will be performed and a new scan will be appended to the project. The new scan can be saved to disk by right-clicking on the scan in the „Plot options“ window and selecting „Export scan…“.

Scans are addressed by their position in the project preceded by „#“ . The first scan in a project is thus addressed as „#1“, the second one as „#2“. Clicking on a scan in the „Scan Math“ dialog will append its reference to the „Expression“ line.

If a reference exceeds the number of available scans, the calculation will not be performed.
24.1. Examples

Some example expressions are shown below. A comprehensive reference of functions and operators supported by Java Script is available at [19][20].

24.1.1. Rescaling and offset

Select „File → Open raw scan file…“ and open a scan file. Then select „Tools → Scan Math…“.

To rescale the intensity by factor 2.0, enter the expression:

\[ 2 \times \#1 \]

To add a vertical offset of 100 counts, enter the expression:

\[ \#1 + 100 \]

To get the square root of the intensity, enter the expression:

\[ Math.sqrt(\#1) \]

To raise the intensities to the power of 2, enter the expression:

\[ Math.pow(\#1, 2) \]

24.1.2. Sum and difference of two scans

Select „File → Open raw scan file…“ and open a scan file. Insert another scan to the same project by selecting „File → Insert Scan…“. Then select „Tools → Scan Math…“.

To calculate the sum of the two scans, enter the expression:

\[ \#1 + \#2 \]

To calculate the difference of the two scans, enter the expression:

\[ \#1 - \#2 \]

Alternatively the same examples can be performed on a refined project (*.dia) file, for example to subtract the background curve (#4) from „I observed“ (#1):

\[ \#1 - \#4 \]
25. Peak Integrals

The integrated intensity of individual peaks can be determined with the tool „Peak integration“ found in „Window → Peak integrals“. This opens a new window with an empty table. The table will list integrated intensities once at least one range is defined in the graph.

To define an integration range, place the mouse cursor on the graph at the beginning of the range, then press and hold the shift key and left mouse button, and drag the cursor to the end of the range. The range will be highlighted in gray, and once the mouse button is released, the integrals will be computed and shown in the peak integral table (Fig. [28]). The range’s start and end position can be adjusted in the respective boxes in the table.

The results of the peak integration can be exported to a CSV file by selecting „Results → Export peak integrals...“.

On the right-hand side of the table some buttons for more actions are located:

Remove selected range: By clicking this button the currently selected range is removed from the table.

Remove all ranges: This action clears the entire table.

Apply ranges to all open projects: This action will copy all ranges of the table to all other open projects. This allows to define ranges in one project, but to obtain the same integrals from a large number of projects. A dialog allowing to select projects to apply the ranges to will be shown prior to applying the ranges. Note that existing ranges will be cleared from the receiving projects.

Subtract linear background: This action toggles subtraction of a linear background on or off. See the next section for more information.

25.1. Calculations

Integrals $A$ in the angular range from data points $\text{start}$ to $\text{end}$ are determined as follows:

$$A = \sum_{n=\text{start}}^{\text{end}-1} S_n \cdot I_n \cdot F$$

with $S$ being the step size between data points $n$ and $n + 1$, $I_n$ being the intensity of data point $n$, and $F$ being the scale factor applied by the user (section 26.2.2). Vertical offsets are ignored. No interpolation or curve fit is performed.

If the option „subtract linear background“ is checked, a linear background will be interpolated between $\text{start}$ and $\text{end}$, and intensities will be determined relative to this background curve (Fig. [29]):
\[ A = \sum_{n=\text{start}}^{\text{end}-1} S_n \cdot (I_n - B_n) \cdot F \]

The background intensity \( B_n \) is calculated as:

\[ B_n = I_{\text{start}} + \frac{n - \text{start}}{\text{end} - \text{start}} \cdot (I_{\text{end}} - I_{\text{start}}) \]

Note that data points below the background will also be considered for integration, hence poor choice of the integration range can result in negative integrals.

When processing refined projects, it is recommended to de-activate the background subtraction, and instead subtract the integral of the refined background from the integral of the raw data.

Figure 28: Peak integrals of a raw data file (top) and a refined project (bottom).
Figure 29: When the option „subtract linear background“ is checked, a linear background will be interpolated between the first and the last point of the range (top). Integrals will be determined relative to this baseline (yellow area). If the option is unchecked, integrals will be determined from the zero line (bottom).
Part III.  
User Interface Reference

26. Main Window

The program’s main window features a menu bar and several tool bars to access all functions and settings (Fig. 30). The central area of the main window is occupied by the plot area, and optionally one or several text editors, which are accessible by tabs at the top of the plot area. The plot area cannot be closed, but text editors can be closed by clicking the close button on their tab.

The central area is surrounded by several dockable windows showing additional information and giving access to more features. These dockable windows can be closed and opened from the „Window“ menu. They can also be re-arranged (Fig. 31) by clicking on the title bar showing the window’s name, and dragging it to another location. Dockable windows can be stacked on top of each other to hide less frequently used windows, or detached from the main window, e.g. to be placed on another screen, or closed.

26.1. User Interface Elements

The following list explains the elements of the user interface shown in Fig. 30 in more detail.

1 Menu bar gives access to most features, as well as the program’s preferences. All menu items are discussed in section 27.

2 Main tool bar gives access to file operating features such as opening, saving, etc.

3 Project tool bar gives access to project related functions, such as opening/closing structure files, exporting results, adding/removing phases etc.

4 Refinement tool bar gives access to starting/stopping refinements or batch refinements.

5 Reference structure tool bar allows to select reference structures to display hkl indices, as well as to start scanning and indexing new structure files. See section 26.5 for more information.

6 Plot area displays raw or refined scans, and opens text editors for control files, results files, structure files, or generic text files.

7 Projects window lists all open projects and the refinement status. Selecting a project from this list will show it in the central plot area.

8 Plot options lists all scans loaded in the plot area. The „Show” checkbox can be used to show/hide certain scans to customize the appearance of the plot.

9 Refinement protocol shows output generated by the refinement backend.

10 Global Parameters and GOALs shows a summary table of refined global parameters. Listing EPS parameters can be configured in the program’s preferences dialog.
11 Local Parameters and GOALs shows a summary table of refined local parameters. The parameters shown here can be customized in the program’s preferences dialog.

12 Context help shows the context help text when pressing „F1” on a keyword in a control file.

13 Chemical composition shows the bulk chemical composition of all crystalline phases, calculated from refined crystal structures and phase quantities.

14 Status bar shows various information such as mouse cursor coordinates on the graph, and the wavelength used to transform $2\theta$ angles to $d$ values.

26.2. Dockable windows

All windows arranged around the central plot and editor area (no. 7–13 in Fig. 30) can be rearranged or closed to match the user’s preferences. They are called dockable windows, because they can be docked to different areas of the main window. Some examples are shown in Fig. 31 and explained below:

Moving: Grab the dockable window at it’s title bar (e.g. the bar (green rectangles on Fig. 31) and drag it to a different location. If the window can be docked, the area will be highlighted.

Stacking: Drag the dockable window onto another dockable window. The dragged window will be stacked on top. Tab buttons will automatically appear to give access to both windows. Unlimited numbers of windows can be stacked.

Detaching: Drag a window outside of the main window and release it when no dockable area is highlighted. The window is now detached from the main window and floating freely on the screen. Use this configuration to place windows on a second screen. Detached windows can also be stacked. Drag the detached window back into the main window to dock it.

Closing / Opening: Dockable windows can be closed by clicking on the close button (x) in the title bar. To open it again, use the menu „Window” in the main window’s menu bar.

26.2.1. Projects

This list shows all open projects and their current status. Click on a project to view it in the plot and editor area. Most actions from the menu and toolbar will apply to the currently shown project.

Right-click on a project to call the context menu.

Projects can be edited while another project is refining. Multiple projects can be refined at a time, but refinement may be slow depending on CPU power and number of CPU cores.

Running a batch refinement (see section 27.5) will allow to refine several projects in a sequence, rather than parallel.

Several projects can be selected with the mouse by holding the Control or Shift keys. Some actions such as closing, batch refining, results export, etc. will be applied to all selected projects.
Figure 30: The Profex main window. Elements 1–14 are described in section 26.1.
26.2.2. Plot options

This list shows all scans loaded in the currently shown project. To change the scans' drawing style (color, line style, line width), refer to the graph preferences discussed in section 28.3.

If a scan is clicked on with the mouse, it is set to active, as indicated by the symbol „A” shown next to the checkbox. Clicking it again will deactivate the scan. Active scans are shown in bolder line width than inactive scans. Only one scan can be set to active at a time. The active scan can be scaled by holding the middle mouse button and moving the mouse vertically. Clicking with the right mouse button will reset the scale. If a rescaled scan is deactivated, it will not be reset by a right mouse click anymore, until it is activated again. The only purpose of activating scans is to visually highlight them and to allow mouse scaling. Currently there is no other functionality related to scan activation.

Visibility of each scan can be changed by checking or unchecking the box in front of the scan name. For refined scans Profex distinguishes between main scans (usually $I_{\text{obs}}$, $I_{\text{calc}}$, $I_{\text{diff}}$, and the background curve), as well as phase patterns. All phase patterns can be toggled on or off at once by using the function „View → Show/Hide phase patterns”. This change is persistent and applies to all open projects. It is a convenience function for easy showing or hiding all phase patterns, but the same result can be obtained by manually checking or unchecking all phase patterns of all open projects.

$hkl$ tick marks are considered as part of phase patterns. Showing/hiding a phase pattern will also show or hide the phase’s $hkl$ lines. By using the functions in „View → Plot” (see section 27.3), drawing of $hkl$ lines and phase patterns can be controlled separately. This allows to draw either no phase information, $hkl$ lines only, phase patterns only, or both.

Double-clicking on a scan parameter (name, scale factor, vertical or horizontal offset) allows to edit the parameter directly. The changes will not be persistent, as they will get lost after closing the scan file or running a refinement. They will, however, be preserved when exporting the scans to ASCII, GNUplot, SVG, or PNG format.

Clicking on a scan with the right mouse button will allow to export an individual scan to a different file format. See section 10.2 for supported file formats.

Scans can be added or removed to the project by the functions „File → Insert Graph File…” and „File → Remove Scan…”. However, as soon as the main graph file is reloaded, for example automatically during a refinement, and added or removed scans will be reset and only the content of the reloaded file will be shown.

26.2.3. Refinement protocol

This window shows the output of the Rietveld refinement backend.
26.2.4. Global Parameters and GOALs

At the end of the refinement, this window shows a summary of the refinement results. The displayed parameters depend on the Rietveld refinement backend. For BGMN, the table shows all global goals and parameters, including estimated standard deviations (ESD) as calculated by BGMN. Some configuration options are available in the preferences as described in section 28.4.5. Values summarized here can also be exported to a CSV table using the function „File → Export Global Parameters and GOALs (Ctrl+E)” (see section 27.1).

26.2.5. Local Parameters

At the end of the refinement, this window shows a summary of refined local (phase related) parameters. This function depends on the Rietveld refinement backend and is not available for all backends. In case of BGMN, it is available and can be configured in the preferences as described in section 28.4.5. Values summarized here can also be exported to a CSV table using the function „File → Export Local Parameters” (see section 27.1).

26.2.6. Chemistry

The „Chemistry” dock window shows the refined chemical composition of the sample. This information is only available for BGMN, but not for other Rietveld refinement backends. See sections 13 for more information.

Clicking with the right mouse button allows to copy the table to the clipboard. It can be pasted to a spreadsheet program. The semicolon character „;” is used as a field separator.

26.2.7. Context Help

This window shows the context help, which can be accessed by placing the mouse cursor on a keyword in a control file, and pressing „F1”. Context help is available for BGMN, but may not be available for other Rietveld refinement backends (see section 27.10).

26.2.8. Convergence Progress

The „Convergence Progress” window shows a live graph of $R_{wp}$, $R_{exp}$, and an acceptance limit for $\chi^2$. $R_{wp}$ starts at 100% and converges towards $R_{exp}$ as the refinement progresses. The $\chi^2$ acceptance limits marks the level at which the goodness of fit can be considered acceptable. The value can be configured in the „Limits” page of the preferences dialog. For optimum goodness of fit $R_{wp}$ reaches $R_{exp}$.

Clicking with the right mouse button allows to toggle the legend visibility, and to export the graph data to text files or PDF files. Clicking with the left mouse button toggles the y-axis scaling.
Figure 31: Many elements of the user interface can be re-arranged by grabbing the title bar and dragging the window to a different place (1 stacked; 2 detached from the main window; 3 closed). Green rectangles show the title bars that can be grabbed with the mouse to rearrange the windows.
between full scale (0–100%) and zoomed in on the latest values (Fig. 32). In unzoomed state the scroll wheel can be used to zoom vertically into the graph.

26.3. The Plot Area

The plot area is the central area of the main window. It shows the loaded scans. Some appearance options can be configured in the preferences dialog as described in section 28.3. Visibilities of the legend, hkl indices, and phase patterns can globally be switched on or off in the menu ,,View → Plot”, as described in section 27.

Scans from different graph files can be added to the plot area by the function ,,File → Insert Graph File…” . Several files can be selected at a time. To remove a specific scan, select it in the dock window ,,Plot Options” and click ,,File → Remove scan…” . When starting a refinement, the project’s main graph file will automatically be reloaded and all added or removed scans will be reset to the main graph file’s content.

The plot area interacts with mouse and key events. A summary of mouse and keyboard commands can be displayed by pressing the ,,Shift” key or selecting ,,Help → Mouse and keyboard commands”. The plot area is divided into several segments (Fig. 33): The central data area shows the scans, hkl indices, and legend. The left margin area showing the y-axis labels. The bottom margin area shows the x-axis labels. The top margin area shows the file name. The right margin area is currently unused. The central area, left margin area, and bottom margin area interact in different ways with the mouse cursor.

26.3.1. Central Data Area

**Moving the mouse cursor:** The cursor position will be displayed in the status bar at the bottom of the main window. The horizontal and vertical position will be shown in degrees $2\theta$ and
counts or counts per second, depending on the unit of the \( y \)-axis (see section \ref{section:28}). Additionally, the horizontal position will also be shown as \( d \) value in Å. The wavelength is used to calculate \( d \) values. If no wavelength information is found in the scan file, Profex will use the default wavelength specified in the preferences (see section \ref{section:28}).

Hovering the mouse pointer on a \( hkl \) index line at the top of the plot will show a tool tip displaying the phase name, \( hkl \) Miller indices, and the texture factor.

**Left Mouse Button – Zooming:** Use the left mouse button and drag the mouse to zoom into the plot.

Alternatively use the mouse scroll wheel to zoom horizontally to the location of the mouse cursor, or hold the Ctrl key and use the scroll wheel to zoom vertically to the location of the mouse cursor.

Hold the Ctrl key and left mouse button to move the zoomed scan.

Hold the Shift key and left mouse button to create a peak integral range.

**Right Mouse Button – Unzooming:** Click the right mouse button in the data area to view the entire scan range.

**,,c” Key – Cross hair cursor:** Press the ,,c” key on the keyboard to activate a cross hair cursor (Fig. \ref{fig:34}). Press ,,c” again to disable it.
„n‖ Key – Counting noise cursor: Press the „n‖ key on the keyboard to show or hide a cursor indicating a range of

\[ \pm \sqrt{\text{Intensity} \text{[counts]}} \]

This range represents the Poisson-distributed statistical counting noise and allows to evaluate mismatches between \( I_{\text{obs}} \) and \( I_{\text{calc}} \), for example at the tips of peaks (Fig. [34]). When moving to the difference curve, the noise cursor will show the counting noise at the intensity of the first scan (e.g. \( I_{\text{obs}} \)) at the same 2\(\theta\) position.

„s‖ Key – Spectral line cursor: Press the „s‖ key to show or hide a cursor showing lines at the position of \( K\alpha_1 \), \( K\alpha_2 \), and \( K\beta \). The \( K\alpha_1 \) line will be drawn at the position of the mouse cursor (Fig. [34]). Positions for \( K\alpha_2 \) and \( K\beta \) lines will be calculated from the \( d \) value at the cursor position. If no wavelength is available, the default wavelength specified in the preferences dialog will be used (see section [28]). For monochromatic synchrotron radiation this feature is meaningless. Use the cross hair cursor instead.

Additionally, peaks from characteristic Tungsten radiation (\( WL\alpha_1 \) and \( WL\beta \)) can be shown by activating the option „Show characteristic Tungsten lines with spectral line cursor“ in the preferences dialog (section [28]). This allows to inspect the diffraction pattern for Tungsten contamination lines caused by aging X-ray tubes. The relative intensities of Tungsten lines are \( WL\alpha_1 \) (100 %), \( WL\beta_1 \) (49.4 %), \( WL\beta_2 \) (20.2 %). \( WL\beta_2 \) is not shown.

„h‖ Key – Help dialog Press the „h‖ key to show a tooltip with information on keyboard and mouse commands.

Double Click – Load reference structure: Double click with left mouse button will load the reference structure with it’s strongest peak closest to the double click position. This is a very simplistic way for phase identification, however, it can be very efficient and useful in some situations. Note that only indexed structure files are considered. Refer to section [26.5] for more information on indexing of references structure files. Also note that the strongest peak of the reference structure indices depends on the instrument configuration used for indexing (fix or variable divergence slit) and may therefore not be at the location of the currently processed scan.

Middle Mouse Button – Scale reference lines: Hold the middle mouse button and move the mouse vertically to scale the intensity of reference lines. Dragging the lines below the line of zero counts allows comparing peaks in the difference curve.

Double Click + Ctrl – List of coordinates: Hold the Ctrl key and double click with the left mouse button to copy the coordinates of the mouse cursor to the refinement output console. From there the coordinates can be copied and pasted to another program for further processing.

26.3.2. Left Margin Area

Right Mouse Click: Opens the context menu:
**Scale Linear:** Sets the scaling of the y-axis to linear. The change is only temporary, i.e. the setting in the preferences dialog is not affected. Other open projects and projects opened after changing the y-axis scaling will still use the scaling specified in the preferences dialog. To permanently change the scale, it must be changed in the preferences dialog.

**Scale Sqrt:** Sets the scaling of the y-axis to $\sqrt{\text{counts}}$. The change is volatile (see above).

**Scale Log10:** Sets the scaling of the y-axis to $\log_{10}(\text{counts})$. The change is volatile (see above).

**Zoom to Baseline:** Sets the zoom range from the baseline (0 counts for linear and square root scaling, 1 count for log10 scaling) to the maximum intensity. It essentially hides the difference curve. This feature is convenient for square root or log10 scales, for which the difference curve tends to dominate the display.

**Zoom to minimum intensity:** Sets the zoom range from the minimum intensity found in any of the scans (except for the difference curve) to the maximum intensity. This is particularly useful for log 10 scaling, which tends to over-represent the white space between 0 and the background.

**Reset Y-Axis Zoom:** Resets the zoom of the y-axis to show the full angular range. The zoom state of the horizontal axis is maintained.

### 26.3.3. Bottom Margin Area

**Right Mouse Click:** Opens the context menu:

- **Reset X-Axis Zoom:** Resets the zoom of the x-axis to show the full angular range. The zoom state of the vertical axis is maintained.

### 26.3.4. Stacking Scans

All scans in the plot area, originating from a single graph file or combined from several graph files using „File → Insert Graph File…”, can be stacked vertically and/or horizontally. Offsets can be adjusted by „View → Increase vertical displacement“, „View → Decrease vertical displacement“, „View → Displace left“, and „View → Displace right“. All displacements can be reset by „View → Reset Displacement“. An initial offset will be applied, which can be reduced incrementally by calling the function moving the scans in the opposite direction. The following commands were used to create the graphs shown in Figs. 35a and 35b:

1. „View → Increase vertical displacement“ to stack the scans vertically at regular intervals of the maximum intensity of the strongest scan (Fig. 35a).

2. „View → Decrease vertical displacement“ was called several times to reduce – not reset – the vertical offset, followed by „View → Displace right“ to stack the scans to the right (Fig. 35b).
Figure 34: Different cursors of the plot area: (a) counting noise cursor, (b) cross hair cursor, (c) spectral lines cursor.
A special vertical offset will be applied when calling „View → Decrease vertical displacement” first. In that case, positive vertical stacking will be applied, but instead of regular intervals, each scan will be displaced to the maximum intensity of the previous scan (Fig. 35). This will avoid large gaps above scans with low maximum intensity, however, it can also be confusing with scans of very low intensity (e.g. amorphous samples or the background curve). In the latter case, applying a regular stacking interval by calling „View → Increase vertical displacement” may be preferred.

26.4. Text Editors

Text editors can show any kind of text files, including control files, list files, structure files, or any generic text file. For control files and list files they will show syntax highlighting for better representation.

Besides the standard actions for text editors, such as copy, paste, undo, redo, and selection, the context menu shown by clicking with the right mouse button has some special features for control and structure files.

26.4.1. Control File specific features

**Open File:** When placing the cursor on a file name and clicking with the right mouse button, the context menu will show the action „Open File” at the bottom. Depending on the file type, the file will be opened as a scan file (VAL[n], DIAGRAMM), or as a text file (STRUC[n], STRUCOUT[n], SimpleSTRUCOUT[n], RESOUT[n], PDBOUT[n], FCFOUT[n]).

Note that if the file name contains spaces or underscores, the full file name must be selected with the text cursor before right-clicking. Else the file name will not be recognized correctly.

**Add <output> file:** When placing the cursor on a STRUC[n] file line and clicking the right mouse button, the context menu will offer to add various structure output files. The refined crystal structure will be written to these files at the end of the refinement. They may be useful for import into other programs, e.g. for structure visualization or publication in databases or papers. The output file names will be set to <phaseName>–<projectBasename>.ext so as to create unique file names and prevent accidental overwriting of output files from other projects in the same directory. The formats offered are STRUCOUT[n], SimpleSTRUCOUT[n], RESOUT[n], PDBOUT[n], and FCFOUT[n]. Please refer to the BGMN documentation for more information about the file formats.

26.4.2. Control and Structure File specific features

When placing the cursor on a parameter and clicking with the right mouse button, the context menu will offer the following actions:

**Fix Parameter:** This will set the parameter under the mouse cursor to be fixed (i.e. not refined).
Figure 35: Stacked scans.
Refine Isotropically: This will release the parameter under the mouse cursor for isotropic refinement. Reasonable lower and upper limits will be applied by default.

Refine Anisotropically: This will release the parameter under the mouse cursor for anisotropic refinement. A reasonable upper limit will be applied by default. Note that if the parameter cannot be refined anisotropically (e.g., unit cell parameters, fractional coordinates, etc.), choosing anisotropic refinement will set the parameter to isotropic refinement, but without any lower and upper limits.

Refinement states of parameters can also be toggled with the keys F5 and F6. If clicked on a parameter supporting anisotropic refinement, the refinement state will be changed in the following order:

F5: anisotropic → isotropic with limits → fix
F6: fix → isotropic with limits → anisotropic with upper limit

If the parameter does not support anisotropic refinement, the refinement state will be changed in this order:

F5: isotropic without limits → isotropic with limits → fix
F6: fix → isotropic with limits → isotropic without limits

Reasonable default limits will be used in all cases. If the toggled parameter is an EPSn parameter in the control file, the numbering of PARAM[n] will be updated automatically if necessary.

26.5. Toolbars

All functions shown in the main toolbar, project toolbar, and refinement toolbar are also accessible in the menu bar and are described in detail in section 27. Toolbars can be re-arranged by dragging the left end to another position, or shown / hidden by right-clicking on a toolbar and checking or unchecking the toolbar in the context menu.

Elements of the reference structure toolbar are only visible if at least one project is loaded. They are not accessible through a menu, only by the toolbar buttons:

Reference structures: A menu allowing to select a reference structure from all STR files found in the structure database directory. If selected, the STR file’s hkl lines will be shown in the graph. This is a generic way of phase identification. When using the „Add Phase” dialog while a reference structure is displayed, this structure file will be pre-selected in the „Add Phase” dialog.

If STR files have not been indexed before, hkl indices will be calculated on the fly when the structure is selected. On modern computers, this only takes a second or two. Afterwards the hkl positions will be buffered and will be available instantly next time the same structure is selected. The buffer can be cleared as described in section 28.4.6. Note that the double-click function described in section 26.3 is only available for indexed reference structures.
The reference structure menu is editable. When clicking on the menu and starting to type the name of a phase, auto-completion will propose the best matching phase. Press Enter to accept the proposed phase.

**Reset reference structure:** This button will reset the reference structure dropdown menu and hide reference \(hkl\) lines. After resetting, no structure will be pre-selected in the „Add Phase” dialog anymore.

**Search and index new reference structures:** Pressing this button will scan the structure database directory for new STR files and index all new files. The reference structures become immediately available in all projects.

**Favorites:** If clicked, only the phases flagged as favorite will be displayed in the dropdown menu. Important: Double-clicking on a peak in the graph to select the nearest reference structure will only search among the favorite structures if this button is clicked.

Height displacement of the sample surface and misaligned detectors cause a shift of the measured reflections in \(2\theta\). This may cause confusion, because the peak positions and \(d\) values differ from the true value and \(hkl\) reference lines. Phase identification would become more difficult as double-clicking on the strongest peak would load a wrong reference structure. Sample height errors can be corrected using the spin box and buttons in the reference structure toolbar as described below (Fig. 36).

**Spin box \(\text{EPS2}\):** Changing the value from 0.0 to a positive or negative value will shift \(hkl\) lines and the mouse cursor coordinates accordingly. The spin box shows the BGMN variable \(\text{EPS2}\) in radians. The effective sample height displacement \(\Delta\) can be calculated from \(\text{EPS2}\) and the instrument radius \(R\) as follows:

\[
\Delta = \frac{R \cdot \text{EPS2}}{2}
\]

\(\Delta\) and \(R\) have the same unit, e.g. millimeters. After a successful refinement, the correct refined value for \(\text{EPS2}\) will be applied automatically in order to center \(hkl\) tick marks and reference lines on the peaks. Internally Profex also reads the refined values for zero-offset (\(\text{EPS1}\)) and penetration depth (\(\text{EPS3}\)) and applies the corresponding angular corrections. But in contrast to \(\text{EPS2}\) these values cannot be controlled by the user.

**Button „Set angular corrections to refined values”:** Pressing this button will reset all angular corrections (\(\text{EPS1, EPS2, EPS3}\)) to the refined values read from the refinement results file (*.lst).

**Button „Set angular corrections to zero”:** Pressing this button will reset all angular corrections (\(\text{EPS1, EPS2, EPS3}\)) to 0.0.
Figure 36: Sample height displacement results in a shift of the peaks in $2\theta$. The reference peaks no longer match the shifted measured peaks (a). Manually correcting for the shift aligns the reference peaks (b). After refinement, the refined shift is automatically applied (c).

27. Menu Structure

27.1. File

Open Text File…(Ctrl+O) Opens a file in a text editor. If a project with the same name as the text file’s base name is already open, the file is opened in this project. Else a new project is created.

If the text file is a control or results file, Profex will automatically locate all other control and results files of the same project, as well as the scan file, and open them, too. Non-existing files are ignored.

BGMN structure files (*.str) are always opened in the currently shown project, regardless of the project name.

Open Raw Scan File…(Ctrl+G) Opens a scan file in a new project. If a control and/or results file with the same base name is found, Profex will open it, too. The file dialog will only show file format filters for raw data files.

Open Refinement Project…(Ctrl+R) Opens a previously created refinement project. The file dialog will only show file format filters for refinement output files.
**Open Project Archive**  A project backup created with „Project → Save Project backup“ can be extracted and opened. The archive will be extracted in a sub-folder named after the archive file.

**Insert Scans... (Ctrl+I)** Inserts scans from one or more graph files into an existing project. The additional scans will only be displayed in the project’s graph view. Other files, such as the control file, will not be modified. If no project is available, a new one will be created, based on the name of the first selected graph file. Inserted scans will be discarded when the project’s graph file is reloaded, e.g. during a refinement.

**Remove Scan...** Removes the scan selected in the „Plot Options“ window from the graph view. No other files will be modified. Removed scans will be restored when the project’s graph file is reloaded, e.g. during a refinement.

**Save (Ctrl+S)** Saves the current file under the same file name. This function only works for text files.

**Save file as... (Shift+Ctrl+S)** Saves the current file under a new file name. A file dialog is shown to ask for the file name, location, and file format.

**Save all text files in all projects (Ctrl+Alt+S)** Saves all modified text files (control and structure files) in all open projects. This function can be used after calling „Edit → Copy control file“, because the newly created control files will only be created in text editors, but not yet saved to disk. Calling this function will save them to disk all at once.

**Recent Graph Files** Shows a list of recently opened graph files.

**Recent Text Files** Shows a list of recently opened text files. For scan files, different output formats can be selected. Scans can be saved as raw data for further processing, or images.

**Print (Ctrl+P)** Prints the currently shown text or graph file. Printing options may differ depending on the platform and device driver.

**Print all Graphs (Shift+Ctrl+P)** Prints the graphs of several open projects at once. A project selection dialog will be shown first. By default all open projects are selected. If the graphs are printed to a PDF file, one file containing all graphs will be created.

**Export all Graphs to SVG** Creates SVG (vector graphics) files of several projects. A project selection dialog will be shown first. By default all open projects are selected. Each graph will be saved to an individual SVG file.

**Close Project (Ctrl+W)** Closes the current project. If a refinement is running, a message will ask for confirmation before aborting the refinement.

**Close All Projects** Closes all open projects. If one or more refinements are in progress, a warning will be displayed and no project will be closed.

**Import Structure File...**  Opens a dialog to convert CIF files (*.cif) or ICDD XML files (*.xml) to BGMN structure files (*.str). See section [17.1] for more information. CIF files can be obtained from various databases. ICDD XML files can be exported from the ICDD PDF-4+ graphical user interface using „Save PDF card as...“. See section [17.1] for more information.
Scan Batch Conversion... Opens a dialog for batch conversion of graph files. All currently opened project scans will be added to the batch list by default. More files can be added or deleted in the dialog. See section 20 for more information.

Quit (Ctrl+Q) Quits the application.

27.2. Edit

Undo (Ctrl+Z) Reverts the last change in the currently shown text file.

Redo (Shift+Ctrl+Z) Restores the last undone change in the currently shown text file.

Cut (Ctrl+X) Cuts the selected text and keeps it in the clipboard. This action only works on text editors, it has no effect on the graph display.

Copy (Ctrl+C) Copies the selected text to the clipboard. On graph displays a pixel image of the graph is copied to the clipboard. The resolution can be specified in the preferences (section 28.3.4).

Paste (Ctrl+V) Pastes the content of the clipboard. This action only works on text editors, it has no effect on the graph display.

Copy Control File Copies the current project’s control file to other projects and adapts all input and output file names to match the projects’ base names. A dialog will allow to select which projects’ control file shall be modified. Existing control files will be overwritten.

Note that this function does not check whether referenced structure files are actually present in all project directories. It only manages control files, but not structure files.

Insert Text Block Inserts the selected pre-defined text block to the current text editor at the cursor’s position. If a graph is shown, this action will do nothing. Text blocks can be configured in the preferences dialog.

Reset File Reverts the current project’s control file to the state before the last refinement. This function is only used for the Fullprof.2k backend, but not for BGMN, because BGMN usually does not modify STR and SAV files.

Find and Replace... (Ctrl+F) Searches a string in a control or structure file, and replaces it. If „use Regular Expression” is checked, the „Find” keyword will be interpreted as a regular expression pattern.

Preferences... Opens the program’s preferences dialog. All preference options are discussed in detail in section 28.
27.3. View

Switch to Graphs (Ctrl+1) Raises the Graph page of all projects.

Switch to Control Files (Ctrl+2) Raises page 2 (usually the control file) of all projects.

Switch to Output Files (Ctrl+3) Raises page 3 (usually the results file) of all projects.

Set Zoom Range… Opens a dialog to zoom the graph to precise upper and lower limits for angle and intensity.

Reset margin color Resets the color of the graph margin to idle color. This is useful for taking screenshots after completed refinements.

Show/Hide Phase Patterns (Ctrl+0) Activates or deactivates visibility of all phases. This option applies to all open projects. It only checks or unchecks the visibility boxes of all phase patterns in the Plot Options list for convenient displaying or hiding of all phases. Individual phases can be shown or hidden by selecting or un-selecting the „show” option in the Plot Options list. More information is given in section 26.2.2.

Plot Configure the visibility of the following elements on the plot:

Phase Patterns Shows or hides patterns of phases.

Legend Shows or hides the plot legend.

hkl Indices Shows or hides the hkl index tick marks at the top of the plots.

Increase Vertical Displacement (Ctrl+Up) Applies a regular vertical offset to all scans. The initial offset will correspond to the maximum intensity of the strongest scan. When called again, this function will increase the previous offset by a constant value.

Decrease Vertical Displacement (Ctrl+Down) Reduces the vertical offset of all scans by a constant value. If no vertical offset exists, an initial adaptive offset will be applied, with a vertical displacement of each scan corresponding to the maximum intensity of the scan below.

Displace left (Ctrl+Left) If no horizontal offset exists, it will apply a horizontal offset to the left to all scans. If an offset to the left exists, the offset will be increased by a constant value. If an offset to the right exists, the offset will be reduced by a constant value.

Displace right (Ctrl+Right) If no horizontal offset exists, it will apply a horizontal offset to the right to all scans. If an offset to the right exists, the offset will be increased by a constant value. If an offset to the left exists, the offset will be reduced by a constant value.

Reset Displacement (Ctrl+Space) Resets all horizontal and vertical offsets.
27.4. Project

Add / Remove Phase... (F8) Opens a dialog to create or manage a control file. New phases can be added or existing phases can be removed from the refinement. If no control file exists yet, a new one will be created. In that case, the correct instrument configuration file must be selected. The option to create a default control file is automatically activated or deactivated, depending on whether or not a control file already exists.

If a phase is activated in the Reference Phase box, it will be pre-selected in the Add Phase list.

If a default control file is created despite an existing control file, the existing one will be overwritten, any previously added modifications or phases will be lost.

Selected structure files and instrument configuration files will be copied from the structure and device database directory to the project directory. Files already existing in the destination directory will be skipped. If the option „overwrite existing files” is checked, existing structure files will be overwritten with the file copied from the structure file database. See section 8 for more information.

When removing a phase from the control file, the structure file can optionally be deleted. Deleting structure files may cause problems with other projects stored in the same directory and accessing the same structure files.

Add Baseline... Opens a dialog to calculate a baseline (background curve) for a certain scan in the project. See section 23 for more information.

Open all project STR files (Ctrl+F8) Opens all BGMN structure files (*.str) referenced in the current project’s control file (*.sav) in new pages.

Close all project STR files (Ctrl+F7) Closes all BGMN structure files (*.str) shown in the current project.

Set Internal Standard Allows to define one refined phase as internal standard phase with a given quantity. The calculation of phase quantities will be changed to apply the internal standard correction, and the standard phase will no longer be shown in the summary table.

Unset Internal Standard Reverts the internal standard calculation of refined phase quantities. All phases will be shown in the summary table in quantities normalized to the sum of all phases.

Refinement Presets Lists all refinement presets to create refinement control files. Select one of them to apply the preset to the current project. See section 16 for more information on refinement presets.

Save as Refinement Preset... Creates a new refinement preset from the currently loaded project. See section 16 for more information on refinement presets.
Save Project Backup (Ctrl+B) Creates a ZIP compressed archive of the current project. The file name is determined automatically as projectBasename-YYYYMMDD-hhmm.zip. It will be stored inside the current project’s working directory. The archive includes the raw data file, all instrument files, structure files, and output files of the project.

Save Project Backup As... (Ctrl+Shift+B) Creates a ZIP compressed archive of the current project. The file name and path can be selected by the user. The archive includes the raw data file, all instrument files, structure files, and output files of the project. The ZIP archives can be stored as a backup or shared with other users, as they contain all project relevant data.

Open File Manager (F4) Opens a file manager at the current project’s location.

27.5. Run

Run Refinement (F9) Starts the refinement of the currently shown project.

Run Batch Refinement (F10) Starts a batch refinement of several open projects. A project selection dialog will be shown first to select all or a selection of projects to be scheduled. If this function is called while a batch is already running, all selected projects will be scheduled and appended to the running batch.

Abort Current Refinement (Shift+F9) Aborts refinement of the currently shown project. In batch refinement mode all projects scheduled for batch refinement will be unscheduled. If the currently shown project is not running but scheduled, it will be unscheduled but the remaining batch refinement will not be interrupted. In either case refinements started outside of the batch will not be interrupted.

Abort All Refinement (Shift+F10) Aborts all running projects and batches. If more projects than the currently shown one are affected, the user will be asked for confirmation.

Follow Active Refinement When processing a batch refinement, activate this function to always raise the currently refining project. If a project refinement has completed, the next scheduled project will automatically be raised. This allows to monitor the batch refinement on screen. The function can be toggled on and off at any time, also during a running batch. It is automatically deactivated as soon as the user selects a text editor of any open project, so as to avoid automatically raising a different project while a text file is being edited or read.

27.6. Results

Export Global Parameters and GOALs (Ctrl+E) Exports the global parameters and goals (e.g. phase quantities) to a semicolon separated spread sheet (*.csv). See section 10.1.1 for more information.
Export Local Parameters and GOALs (Shift+Ctrl+E) Exports the local parameters and goals (e.g. structural parameters) to a semicolon separated spread sheet (*.csv). See section 10.1.1 for more information.

Export Chemistry… Writes the calculated chemical composition to a semicolon separated spread sheet (*.csv). See section 10.1.1 for more information.

Export Peak Integrals Exports all peak integral data to a semicolon separated spread sheet (*.csv). See section 25 for more information.

Export CIF file from LST file This function reads LST files of all open projects and writes crystal structure information to CIF files. One CIF file will be created for each crystal structure found. The file will be stored in the project directory. Information on saved files is shown in the refinement protocol console.

Export CELL file from RES file This function reads RES files of all open projects and writes crystal structure information to CELL files for the software Castep [9]. One CELL file will be created for each crystal structure found. The file will be stored in the project directory. Information on saved files is shown in the refinement protocol console. If no RES file is available for a specific phase, a tag RESOUT\[n\]=filename.res must be added to the control file (*.sav) and the refinement must be repeated.

27.7. Instrument

New Configuration… Read some hardware information from Bruker RAW V4, Bruker BRML V5, and PANalytical XRDML files to create a BGMN instrument configuration file from scratch. Other raw data formats are not supported. Usually several variable required by BGMN will still not be available from the raw data files and will thus have to be entered manually. See section 18 for more information.

Edit Configuration… Opens a dialog to process BGMN instrument configurations. See section 18 for more information.

Show Peak Shape… Opens a dialog that calculates the theoretical peak shapes for a selected instrument configuration file.

27.8. Tools

Browse BGMN Space Groups… Opens a dialog to browse space groups and atomic positions supported by BGMN. The dialog reads the file SPACEGRP.DAT, which is part of the BGMN software distribution.

Browse Atomic Scattering Factors… Opens a dialog to browse atomic scattering (form) factors supported by BGMN. The dialog reads the file AFAPARM.DAT, which is part of the BGMN software distribution.
**Calculate Absorption Coefficients** A dialog opens that allows to calculate linear and mass absorption coefficients for phases and samples. If a refinement project is loaded, the dialog will use the refined phases to compute absorption coefficients for each phase based on its chemical composition, and for the sample based on the phase quantities. However, phases can also be manually added and removed in order to compute absorption coefficients for arbitrary compositions.

**Process DIA files** (coming soon)

**Scan Math** The tool „Scan Math” allows to perform calculations on the intensities of all scans loaded in a project. Expressions must be entered in Java Script syntax [19] [20]. See section 24 for more information.

### 27.9. Window

**Projects** Shows or hides the Projects list window.

**Plot Options** Shows or hides the Plot Options window.

**Refinement Protocol** Shows or hides the Refinement Protocol window.

**Global Parameters and GOALS** Shows or hides the summary table window for global parameters and goals.

**Local Parameters** Shows or hides the summary table window for local parameters and goals.

**Chemistry** Shows or hides the table showing the refined chemical composition in oxide form.

**Context Help** Shows or hides the context help display.

**Convergence Progress** Shows or hides the window showing a graph with $R_{wp}$ and $R_{exp}$ values during a refinement.

**Peak Integrals** Shows or hides the peak integral window. See section 25 for more information.

### 27.10. Help

**Context Help.. (F1)** Shows the context help of the keyword under the text cursor. The „Context Help” window („View” menu) must be shown to display the context help.

**BGMN Variables..** Opens a web browser showing the BGMN variables documentation page.

**Mouse and Keyboard Commands** Shows a dialog with mouse and keyboard commands for plot windows.

**About Profex..** Shows information about Profex.
28. Preferences

28.1. General

**Toolbar Layout** Select how icons and text in Profex’ toolbars are shown. „Follow Style“ will match the system-wide style used by the operating system.

**Restore open projects** If checked, Profex will load all previously open graph files upon program start. If unchecked, Profex will not load any projects or files at program start.

**Default Project Type** For file formats not specific for either BGMN or Fullprof.2k, this option determines which type of project will be created when such a file is opened. The file type is identified by the file extension.

File extensions can also be associated with either of the two backends by adding the extension either to the list of „File Extensions associated with BGMN“ or „File Extensions associated with Fullprof“.

**Number of CPU cores used by BGMN** Specifies how many CPU cores will be used by the refinement backend (only available for BGMN). „Automatic“ will use all available cores.

**File Extensions associated with Fullprof** These file types will always be opened as Fullprof projects, regardless of the default project type. Enter the extension in small letters without asterisks and periods, separated by a space character. Example: pcr dat sum prf

**File Extensions associated with BGMN** These file types will always be opened as BGMN projects, regardless of the default project type. Enter the extension in small letters without asterisks and periods, separated by a space character. Example: sav lst dia str

**Default Wavelength** This wavelength, given in Å, is used for scan files not containing any information about the wavelength.

**Always use default Wavelength** If checked, Profex will ignore the wavelength read from the scan file and always use the default wavelength to calculate $d$ values from diffraction angles. Use this option with care. Any wavelength information read from raw data files will be ignored if this option is checked.

28.2. Text Editors

**Font** Sets the font of the text editor and refinement protocol window.
28.3. Graphs

28.3.1. Appearance

**Use AntiAliasing for Graphs (slow!)** Uses anti aliasing to draw the plots. If checked, lines look smoother but also wider. Drawing will be slower if checked.

**Show characteristic Tungsten lines with spectral line cursor** When using the spectral line cursor (26.3), additional lines will be shown for characteristic Tungsten radiation ($W\alpha_1$ and $W\beta_1$). This allows to inspect the diffraction pattern for Tungsten contamination lines caused by aging X-ray tubes.

**Show major grid lines** Show or hide vertical and horizontal grid lines at the positions of major tick marks. Major grid lines will be drawn as medium dashed lines.

**Show minor grid lines** Show or hide vertical and horizontal grid lines at the positions of minor tick marks. Minor grid lines will be drawn as light dotted lines.

**Show complete file name** If checked, the file name of the graph file will be shown with the absolute path in the top right corner of the graph display. If unchecked, only the file name without file path will be shown.

**Display Line Width** Width in pixels of all lines (plots, axes, tick marks) of the graph on computer screens. If plot lines are too fine (e.g. on high-resolution displays) increase this value.

**Symbol Size** Size of the measured data points when not using solid lines (e.g. dots or crosses) in pixels.

**Y-axis Scaling** Scaling of the y-axis. Options are linear, logarithmic with a base of 10 ($\text{log}_{10}$), or square root ($\text{sqrt}$).

**Y-axis unit** Shows the y-axis unit either in counts, or in counts per second (cps). Counts per second may not be available, depending on the file format of the loaded scan. If the time per step is not available, Profex will fall back to the unit „Counts“ and assume a counting time of 1 second per step.

Only the display of scans will be affected by the choice of the unit. Internally, all calculations and file format conversions will be performed in „Counts“. As a consequence, when converting a format supporting „Counts per second“ (such as XRDML) to a format not supporting it (such as ASCII XY), the displayed unit may change from [cps] to [counts].

**Multi-Scan Files** Select whether multi-range files will be shown as individual scans, as the sum of all ranges, or as the average of all ranges.

**Create Thumbnail** If checked, a thumbnail picture of the refined plot will be created at the end of the refinement. This file is stored in the project directory with the name *project-basename*.png. It allows easy browsing of refined projects. The width of the picture can be specified in pixels. The height is calculated from the displayed aspect ratio.
Use margin colors If activated, the margin of the graph will change color to indicate the refinement status. By default, the color for idle projects is white, for refining (active) projects red, and for completed projects green. The colors can be customized.

**Idle** Select the color of the graph’s margin in idle state. Usually white is the preferred option.

**Active** Select the color of the graph’s margin in active state (during refinements). The default is light red. If no color change is preferred, select the same color as for idle state.

**Complete** Select the color of the graph’s margin in complete state (after convergence of refinements). The default is light green. If no color change is preferred, select the same color as for idle state. The margin color can be set back to idle color by clicking „View → Reset margin color”.

28.3.2. Fonts

**Font Title** Select the font of the file name at the top-right of the graph.

**Font Axis Labels** Select the font of the graph axis labels.

**Font Tick Marks** Select the font of the graph tick marks.

**Font Legend** Select the font of the graph legend.

28.3.3. Scan Styles

**Color** Customize the list of colors to be used to draw scans by double-clicking on the color cell. If more scans are loaded than colors are available from the list, a random color will be created and added to the list. The first color defaults to black, all following colors are randomly generated. They can be changed manually later on. Line widths can be changed on the Graph’s Appearance page.

**Point Style** Select the style to draw scans. „Solid” draws the scan as a solid line. „Points” draws a dot at the measured position, „Cross” draws a cross at the measured position. Symbol sizes of crosses and points can be changed on the Graph’s General Appearance page.

+ Add another color to the color list.

– Remove the currently selected color from the list.

**Standard colors** Multiple scans can be loaded either from a raw data file containing more than one scan, or from a refined project containing one raw data scan (Iobs), as well as several calculated scans (Icalc, Idiff, background). Multi-scan files use the colors specified in the color list above. However, separate colors can be used for refined projects. These standard colors override the colors in the list above as soon as Profex detects a refined project. This is helpful to use pretty colors for multi-scan files, but the *de facto* standardized colors for Iobs (black), Icalc (red), Idifference (grey), and background (blue). An example for the two different modes is shown in Fig. 37.
Figure 37: Randomly generated scan colors (left) used for multi-scan files. Standardized colors for refined projects (right).

28.3.4. Print and Export

**Print: Line Width** Width in points of all lines (plots, axes, tick marks) of the graph on printouts. This value should usually be greater than the display line width. It has to be matched to the printer device driver by printing test plots.

**Print: Font Scale Factor** The font size on printouts can be scaled. Use values greater than 1.0 if the font is too small, and smaller than 1.0 if the font size is too large. The value has to be matched to the printer device driver by printing test plots.

**ASCII Data Export: Field Separator** Enter the field separator used when exporting data to ASCII text files. Only non-alphanumeric characters are allowed. Common choices are the semicolon (;), comma (,), space ( ), or tab.

**Raster Export: Width** Width of the exported image in pixels.

**Raster Export: Height** Height of the exported image in pixels.

**SVG Export: Font Scale Factor** Adjusts the font scale on SVG graphs. Increase the value if the font is too small, or decrease if the font is to large.

28.4. BGMN

28.4.1. Backend Configuration

**BGMN Executable** Selects the BGMN executable file. This file is part of the BGMN installation. It is called **BGMN.EXE** on Windows, and **bgmn** on Mac OS X and Linux.

**MakeGEQ Executable** Selects the MakeGEQ executable file. This file is part of the BGMN installation. It is called **MakeGEQ.EXE** on Windows, and **makegeq** on Mac OS X and Linux.

**Geomet Executable** Selects the Geomet executable file. This file is part of the BGMN installation. It is called **GEOMET.EXE** on Windows, and **geomet** on Mac OS X and Linux.
Output Executable  Selects the Output executable file. This file is part of the BGMN installation. It is called OUTPUT.EXE on Windows, and output on Mac OS X and Linux.

Verzerr Executable  Selects the Verzerr executable file. This file is part of the BGMN installation. It is called VERZERR.EXE on Windows, and verzerr on Mac OS X and Linux.

Gertest Executable  Selects the Gertest executable file. This file is part of the BGMN installation. It is called GERTEST.EXE on Windows, and gertest on Mac OS X and Linux.

Run in WINE  This box is only available on Linux and Mac OS X. It allows to use the Windows version of BGMN to be run in WINE. Check this option if the executable files specified above belong to the Windows version of BGMN.

Convert raw scans to XY format  If checked, raw scan files will be converted to ASCII XY free format (*.xy) prior to starting the refinement.

This option must only be disabled if the raw file format is directly supported by the BGMN backend (e.g. *.val, *.rd).

Spectral line cursor shows all wavelengths from BGMN *.lam file  By default Profex uses a hard-coded table of characteristic wavelengths to display the spectral lines of $K\alpha_1$, $K\alpha_2$, and $K\beta$ with the spectral line cursor. The primary wavelength is read from the scan file (raw data file or refined profile), and all related secondary wavelengths are found in the hard-coded table. If this option is checked, Profex will try to locate the *.lam file specified in the BGMN refinement control file using the keyword LAMBDA=, and read all wavelengths specified there.

The radiation spectrum in the *.lam file is often modeled by overlapping Lorentzian curves. It is therefore not unusual to use 4 or more emission lines with slightly different wavelength, widths, and intensities to model $K\alpha_1$ and $K\alpha_2$ with realistic emission line profiles. If additionally $K\alpha_3$ satellites and $K\beta$ are modeled, even more emission lines are required. The emission spectrum described in the *.lam file can therefore be relatively complex, and displaying all lines with the spectral line cursor can lead to a cluttered plot display. For most users using conventional X-ray tubes with characteristic radiation spectra, with or without $K\beta$ filters or monochromators, leaving this option unchecked is recommended.

If the *.lam file was not specified, cannot be found, or cannot be parsed, Profex falls back to the internal hard-coded table of characteristic wavelengths, just as if this option was unchecked.

Any comment trailing the emission line parameters will be used to label the line. For example, to add line labels to the file „cu.bergmann83.lam“, which is part of the Profex-BGMN-Bundle distribution:

% Cu-K-alpha doublet as measured in october 1983 by J. Bergmann
ILAM=4 TITEL=CU_vom_Oktober_1983
0.401939 6.49098 0.0010981
0.266445 6.49013 0.0019875
0.167844 6.47504 0.0012544
0.163773 6.47400 0.0017246
add comments to each data line:

```
% Cu-K-alpha doublet as measured in october 1983 by J. Bergmann
ILAM=4 TITEL=CU_vom_Oktober_1983
0.401939 6.49098 0.0010981 % CuKa1 (1)
0.266445 6.49013 0.0019875 % CuKa1 (2)
0.167844 6.47504 0.0012544 % CuKa2 (1)
0.163773 6.47400 0.0017246 % CuKa2 (2)
```

Now the emission lines will be labelled as ,,CuKa1 (1), „CuKa1 (2)” etc. when activating the spectral line cursor. *.lam files with parametrized intensities are also supported, as for example the default „cu.lam” file distributed with the Profex-BGMN-Bundle package:

```
% Berger CuK1,2,3 + Kb XPERT BERN
ILAM=6
0.01586*ifthenelse(ifdef(alpha3ratio),(alpha3ratio)/0.01586,1) 6.51571 0.00783 % CaKa3
0.56768*ifthenelse(ifdef(alpha2ratio),(1-alpha2ratio)/0.64369,1) 6.49099 0.00092 % CuKa1 (1)
0.07601*ifthenelse(ifdef(alpha2ratio),(1-alpha2ratio)/0.64369,1) 6.48905 0.00126 % CuKa1 (2)
0.25107*ifthenelse(ifdef(alpha2ratio),(alpha2ratio)/0.35631,1) 6.47496 0.00109 % CuKa2 (1)
0.08688*ifthenelse(ifdef(alpha2ratio),(alpha2ratio)/0.35631,1) 6.47366 0.00130 % CuKa2 (2)
0.00249*ifthenelse(ifdef(betaratio),(betaratio)/0.00249,1) 7.18206 0.00151 % CuKb
```

**Normalize quantity goals to 100%** Normally quantity goals are normalized to 1.0:

```
sum=betaTCP+betaCPP
GOAL[1]=betaTCP/sum
GOAL[2]=betaCPP/sum
```

If this option is checked, the goals will automatically be normalized to 100%:

```
sum=betaTCP+betaCPP
GOAL[1]=100*betaTCP/sum
GOAL[2]=100*betaCPP/sum
```

### 28.4.2. Repositories

**Structure Files Directory** Specifies the location where BGMN structure files (*.str) are stored. Several directories can be entered. Sub-directories will be scanned for *.str files, too. This allows to use a shared network structure repository and a local personal one simultaneously.

**Device Files Directory** Specifies the location where BGMN instrument files (*.sav, *.ger, *.geq, *.tpl) are stored.

**Presets Directory** Specifies the location where refinement preset files (*.pfp) are stored. See section 16 for more information on presets.
28.4.3. Limits

**Unit Cell Parameters**  Specifies the range for upper and lower limits of unit cell parameters to be added automatically to BGMN Structure files (*.str) created from CIF or ICDD XML structure files. The same limits will be applied if unit cell parameters are released for refinement in the control file.

**Fractional Coordinates**  Upper and lower limits are added to fractional coordinates released for refinement. The unit of this value is in fractional coordinates. Example: Releasing the coordinates of the following atom for refinement with a limit of 0.05:

\[
E=SI \text{ Wyckoff}=f \ x=0.25 \ y=0.5 \ z=0.1234 \ TDS=0.02
\]

will result in (without line break):

\[
E=SI \text{ Wyckoff}=f \ PARAM=x=0.25_0.20^0.30 \ PARAM=y=0.5_0.45^0.55 \ PARAM=z=0.1234_0.0734^0.1734 \ TDS=0.02
\]

\(\chi^2\) acceptance limit  Draws an additional line on the convergence display graph at the \(\chi^2\) value specified here. This is just a visual aid to quickly verify if the fit has reached an acceptable convergence. Values can be chosen freely. The default is 1.5, recommended values are in the range of 1.2–1.5.

28.4.4. GOAL Management

**Manage Phase Quantification GOALS**  If this option is checked, a GOAL to compute relative phase quantities will be added by Profex when a new phase is added with the ,,Add / Remove Phase“ dialog. When removing a phase using the ,,Add / Remove Phase“ dialog the corresponding quantification GOAL will be removed.

Custom GOALs not identified as quantification GOALs will be preserved and appended to the list of quantification GOALs.

Note that the syntax of GOALs written by Profex changed with version 3.12.0, as described below.

**GOAL syntax format**  The syntax used by Profex to define phase quantification GOALs changed with Profex version 3.12.0. The previous syntax („simple“) is still available for compatibility reasons, but the new syntax („extended“) provides some more flexibility. The syntax version only affects writing new GOALs. **Reading old projects using the simple syntax will work even if this option is set to „extended“ format.**

The simple syntax used in Profex 3.11 and older defines the sum of all phases and divides each GOAL by the sum in order to obtain relative phase quantities normalized to 1.0:

\[
\text{sum=}\text{Calcite+Aragonite} \\
\text{GOAL}[1]=\text{Calcite}/\text{sum} \\
\text{GOAL}[2]=\text{Aragonite}/\text{sum}
\]
When adding another phase „corundum” and declaring it as an internal standard with a phase content of 10 wt-\%, the GOALs section is re-written as follows:

$\text{ISTD}=\text{Corundum}$
$\text{ISTDQ}=0.1000$

$\text{sum}=\text{ISTD} \times (1-\text{ISTDQ})/\text{ISTDQ}$
$\text{Amorph}=1-\text{Calcite}+\text{Aragonite}/\text{sum}$
$\text{GOAL}[1]=\text{Calcite}/\text{sum}$
$\text{GOAL}[2]=\text{Aragonite}/\text{sum}$
$\text{GOAL}[3]=\text{Amorph}$

Using the new extended GOALs syntax, intermediate variables will be used, and the first example code looks as follows:

$\text{sum}=\text{Calcite}+\text{Aragonite}$
$\text{QCalcite}=\text{Calcite}/\text{sum}$
$\text{QAragonite}=\text{Aragonite}/\text{sum}$
$\text{GOAL}[1]=\text{QCalcite}$
$\text{GOAL}[2]=\text{QAragonite}$

Instead of $\text{Calcite}/\text{sum}$, the GOAL is now called $\text{QCalcite}$, using the prefix „Q”. The prefix is a character prepended to the phase name. The denominator for phase normalization is called „sum”.

Adding 10 wt-\% corundum and using it as an internal standard will change the GOALs section as follows:

$\text{ISTD}=\text{corundum}$
$\text{ISTDQ}=0.1000$

$\text{sumabs}=\text{ISTD} \times (1-\text{ISTDQ})/\text{ISTDQ}$
$\text{QabsCalcite}=\text{Calcite}/\text{sumabs}$
$\text{QabsAragonite}=\text{Aragonite}/\text{sumabs}$
$\text{QabsAmorph}=1-\text{Calcite}+\text{Aragonite}/\text{sumabs}$
$\text{GOAL}[1]=\text{QabsCalcite}$
$\text{GOAL}[2]=\text{QabsAragonite}$
$\text{GOAL}[3]=\text{QabsAmorph}$

This time the GOAL name prefix is „Qabs” and the denominator is „sumabs”. Prefixes and denominators can be customized as described below.

If the option „Also add GOALs for relative phase quantities” is activated, GOALs for relative and absolute phase quantities will be written when using an internal standard. In that case, the GOALs section the last example above will look as follows:
ISTD=Corundum
ISTDQ=0.1000

sum=Calcite+Aragonite+Corundum
QCalcite=Calcite/sum
QAragonite=Aragonite/sum
QCorundum=Corundum/sum

GOAL[1]=QCalcite
GOAL[2]=QAragonite
GOAL[3]=QCorundum

sumabs=ISTD*(1-ISTDQ)/ISTDQ
QabsCalcite=Aalcite/sumabs
QabsAragonite=Aragonite/sumabs
QabsAmorph=1-(Calcite+Aragonite)/sumabs

GOAL[4]=QabsCalcite
GOAL[5]=QabsAragonite
GOAL[6]=QabsAmorph

Now it becomes apparent that the new syntax allows easier identification of relative and absolute phase quantity GOALs. The prefix for relative quantities could also be set to „Qrel” in order to obtain GOAL names QrelCalcite and QabsCalcite for even easier reading.

Relative Phase Quantity GOALs: GOAL name prefix Set the prefix used to label quantification GOALs when not using an internal standard. Only alphanumeric characters are allowed (a–z, A–Z, 0–9). Default is „Q”.

Relative Phase Quantity GOALs: Denominator variable Set the name of the denominator variable used to calculate quantification GOALs when not using an internal standard. Default is „sum”.

Absolute Phase Quantity GOALs: GOAL name prefix Set the prefix used to label quantification GOALs when using an internal standard. Only alphanumeric characters are allowed (a–z, A–Z, 0–9). Default is „Qabs”.

Absolute Phase Quantity GOALs: Denominator variable Set the name of the denominator variable used to calculate quantification GOALs when using an internal standard. Default is „sumabs”.

Absolute Phase Quantity GOALs: Also add GOALs for relative phase quantities When checked, both relative and absolute phase quantities will be calculated when using an internal standard. If not checked, only absolute quantities will be calculated. This option only affects projects using an internal standard.
28.4.5. Summary Table

Global Parameters and GOALs

Show warnings for values below detection and quantification limit: If activated, Profex will show a warning for phase quantities getting small relative to their ESD. For example, if the limit of quantification (LOQ) is defined as 0.25, the variation coefficient (ESD / value) must be smaller than 25%, or, in other words, the refined value must be greater than $4 \cdot \text{ESD}$. Else a warning „< LOQ” will be shown in the summary table. See section 14 for more information.

Variation coefficient for LOQ: Defines the threshold for „< LOQ” (below limit of quantification) warnings. Typical values are 0.25 if the refined value must be at least four times its ESD in order to be quantifiable, or 0.10 if it must be at least 10 times greater than its ESD. This variable can also be set in the control file (*.sav), see section 29. Values read from the control file override values specified in the preferences dialog. See section 14 for more information.

Variation coefficient for LOD: Defines the threshold for „< LOD” (below limit of detection) warnings. Typical values are 0.50 if the refined value must be at least twice its ESD in order to be detectable, or 0.33 if it must be at least three times greater than its ESD. This variable can also be set in the control file (*.sav), see section 29. Values read from the control file override values specified in the preferences dialog. See section 14 for more information.

Minimum ESD (ignore ESDs below): For phase quantities approaching 0.0, the ESD also approaches 0.0. Such phases appear to be detectable and quantifiable even at infinitely small quantities, but in fact it is an artifact of the ESD computation. In order to avoid this, a minimum ESD can be specified here. Refined ESDs below this value will be ignored and hard set to the minimum ESD. Typical values are 0.05 wt-%. Set this value to 0.00 to use all refined ESD values, regardless of how small they are. See section 14 for more information.

Listed GOALs: A list of global GOAL names that will be read from the BGMN list file (*.lst) and shown in the summary table for global parameters and goals. If the text field is empty, all global GOALs will be shown. This text field supports regular expression patterns. For example, instead of listing all EPS<sup>n</sup> values separately:

EPS1
EPS2
EPS3
EPS4

one can use a regular expression to list all refined EPS values:

`^EPS\[1-4\]$`

or alternatively:

`^EPS\d$`
Regular expressions are useful to identify GOALs describing a phase quantity. Quantity GOALs managed by Profex always have a unique name ending on \textit{/sum}. A regular expression pattern describing GOAL names of type \textit{<any name>}/sum can thus be used to list only phase quantity GOALs. The following pattern only matches GOALs with names ending on /sum:

\^[\^[\[/\]+]\textit{/sum}$

For the new GOALs syntax used in Profex 3.12 and newer, quantification GOALs use prefixes \textit{„Q”} or \textit{„Qabs”} (both are customizable) instead of the denominator. These GOALs are captured with the following expressions:

\^Q\S+$
\^Qabs\S+$

Numerous tutorials on regular expressions can be found on the internet.

\textbf{Reset} Pressing this button erases the text field with global parameters and GOALs and inserts a default set of parameters.

\textbf{Local Parameters and GOALs}

\textbf{Listed GOALs} Enter the parameters to be read from the local parameters and goals section in the BGMN list file (*.lst) and shown in the summary table for local parameters and goals. The text field supports regular expression patterns. For example, instead of listing all unit cell parameters separately:

A
B
C
ALPHA
BETA
GAMMA

one could use a regular expression pattern

\^A|B|C|ALPHA|BETA|GAMMA$

or alternatively:

\^[A-C]$\n\^ALPHA|BETA|GAMMA$

However, with regular expression patterns the parameters may be listed in arbitrary order. Regular expressions are particularly useful for GrainSize results. Printing all refined Grain-Sizes is achieved by the following pattern:

\^GrainSize\(\textit{\d,\d,\d}\)$
**Reset**  Pressing this button erases the text field with local parameters and GOALs and inserts a default set of parameters.

### 28.4.6. Reference Structures

**Automatically select best matching reference phase** When opening a graph file, automatically search and select the reference phase with it’s strongest peak at the position of the scan’s highest intensity. This is the same as double clicking at the strongest peak just after loading the scan file. Note that only indexed reference structures will be considered.

**Automatically index new structure files** If checked, Profex will scan the structure file directory for new structure files each time Profex is started and the first project is loaded.

If not checked, new structures will be indexed the first time they are selected in the Reference Structures box.

Structures will not be available for double-click phase identification as long as they have not been indexed.

**Draw hkl reference lines from background curve if available** If this option is checked, Profex will use a scan with name „background“ to draw the base of the *hkl* reference lines on. If no such scan is found or this option is unchecked, the *hkl* lines will be drawn from the zero line.

**Color of Reference hkl Lines** Color of the *hkl* lines when selecting a reference structure from the Reference Structures box.

**Clear *hkl* index buffer** Clears the buffer file with structure file *hkl* indices. Profex must be restarted for this to take effect. All structure files will be re-indexed either automatically, or when selected from the Reference Structures box.

**hkl reference line range** Specifies the lower and upper 2θ angle for *hkl* indices to be calculated. Larger ranges will require more time to index. The range may be smaller or larger than scan file ranges.

### 28.4.7. Favorites

Select reference structure files to be shown in the „Add / Remove Phase“ and the reference structure dropdown menu when the „Favorites“ filter is applied. Check the box in the 4th column to flag files as favorites.
28.4.8. Structure File Handling

Custom Profile Function

Use custom profile function  Check this option if Profex should automatically change the profile parameters of BGMN Structure files (*.str). The files will be modified when they are copied from the structure database to the project directory by calling „Edit → Add Phase…”. If this option is disabled, the profile parameters will not be changed.

Profile Function (RP)  Specify the RP=n parameter.

Scaling (GEWICH)  Specify the GEWICH parameter. Choose SPHARn for refinement of preferred orientation, or ISOTROPIC for untextured samples.

Lorenzian Size Broadening (B1)  Specify B1, enter ANISO for anisotropic crystallite sizes. Check „refine” to refine this parameter.

Gaussian Size Broadening (k1)  Specify k1. Check „refine” to refine this parameter.

Micro Strain (k2)  Specify k2, enter ANISO4 for anisotropic micro-strain. Check „refine” to refine this parameter.

GOALs

Add Default Goals  Check this option if a set of default goals is to be added to each copied BGMN Structure file (*.str). Specify the goals in the text field below. Example:
GrainSize(1,1,1) //

Micro-Absorption Correction

Add Correction for Micro-Absorption  Check this option if a correction for micro-absorption (Brindley correction) shall be added to each copied structure file.

Default Function  If checked, the correction formula is hard coded to a default function.

Custom Function  Check this line and enter a custom correction function if a correction formula other than the default one shall be used.

28.5. Fullprof

Fullprof Executable  Specifies the path to the Fullprof executable fp2k.exe.

Structure files directory  Specifies the location of the directory with structure template files.

Device files directory  Specifies the location of the directory with device template files.

Stop on convergence  Normally Fullprof aborts the refinement when convergence criteria are reached. Checking this option forces Fullprof to always perform the number of refinement cycles specified with the parameter Ncy.
**Divergence slit angle** As Fullprof expects all scans to be measured with a fixed divergence slit setting, Profex will attempt to convert scans measured with automatic or variable divergence slit. The slit opening in degrees specified here is the opening the scans will be converted to. A value less than 1.0 degree is recommended.

### 28.6. Chemical Composition

The chemical composition page allows to edit the oxide forms and their molecular weights used to calculate the elemental composition of the sample. Elements with empty molecular weight, or with molecular weight of 0.0 g/mol, will be ignored. It is recommended to leave the oxide and molecular weight cells of oxygen (element No. 8) empty to suppress display of oxygen as a separate element in the chemistry results table.

A dialog to select the oxide form and automatically calculate the corresponding molecular weight can be opened by double-clicking on the element symbol (left column).

Double-clicking an oxide cell (middle column) or molecular weight cell (right column) allows to enter oxide names and molecular weights directly by bypassing the dialog mentioned above.

**Element, Oxide, and Molecular Weight table** This table holds the oxide formula and oxide molecular weight for each element. Edit the values by double clicking a cell. Double clicking an element cell will open a dialog to determine oxides and their molecular weight. Double clicking any other cell allows direct input of oxide formulas and values.

**Reset** Resets the table to the internal default values. All customizations will be lost.

### 28.7. Text Blocks

On this page text blocks can be managed (section 15). Click the button to create a new text block, then enter the text in the editor. All changes will be saved automatically when closing the preferences dialog. Click − to delete the current text block. The block will be deleted permanently when closing the preferences dialog with the „OK“ button. Close the dialog with „Abort“ if the text block was deleted accidentally.

### 29. Profex-specific Control File Variables

Profex reads some additional variables from BGMN control files (*.sav) that are not mandatory for the BGMN refinement backend. Some of them are only parsed by Profex and ignored by BGMN, and some of them are used for specific calculations of GOALs.
**sum**  This variable is used to compute relative phase quantities normalized to 100%. Normally it holds the sum of the GEWICHT variables of all phases. If one phase is set as an internal standard, the sum variable is used for the normalization to the internal standard quantity. sum is automatically managed by Profex if phases are added, removed, or set and unset as internal standard.

**ISTD**  Holds the phase name of the internal standard phase. It is only present if an internal standard has been defined. It is added and removed by Profex if an internal standard is set or unset.

**ISTDQ**  Holds the phase quantity of the internal standard phase normalized to 1.0 (not to 100%). It is only present if an internal standard has been defined. It is added and removed by Profex if an internal standard is set or unset.

**LOQ**  Relative standard deviation (ESD / value) considered as the limit of quantification (LOQ). This value will override the value set in the preferences dialog. It will only be parsed if the option „Show warnings for values below detection and quantification limit” is set active in the preferences dialog. If the ratio ESD / value of a refined phase quantity exceeds LOQ, it will be highlighted in the summary table and a warning „< LOQ” will be shown. See section 14 for more information.

**LOD**  Relative standard deviation (ESD / value) considered as the limit of detection (LOD). This value will override the value set in the preferences dialog. It will only be parsed if the option „Show warnings for values below detection and quantification limit” is set active in the preferences dialog. If the ratio ESD / value of a refined phase quantity exceeds LOD, it will be highlighted in the summary table and a warning „< LOD” will be shown. See section 14 for more information.

**MINESD**  Sets the minimum ESD that is considered realistic for refined phase quantities. This variable overrides the value set in the preferences dialog „Minimum ESD (ignore ESDs below) =”. See section 14 for more information.

**SampleID**:  A custom sample ID string can be entered to add random sample information to the refinement. Profex is able to extract sample ID information from some raw data formats, such as Bruker *.raw and *.brml. In that case it will add the SampleID tag automatically when the BGMN control file (*.sav) is created. SampleIDs are also exported to CSV tables when using the results export features.

Example:

% SampleID: Sample No 160810-01, room temperature

Note that all comment signs (also at the beginning of the line) will be ignored. Profex will extract the string following SampleID: regardless of comment signs. In the example above, the extracted sample ID string will be Sample No 160810-01, room temperature.

Warning: Avoid semicolons (;) in the sample ID string. This character is used as a field separator in the CSV results tables. Using it in the sample ID will confuse the layout of the CSV tables.
Part IV.
Appendix

A. Bundle File Structure

A.1. Windows

Profex-BGMN-Bundle-3.13.x.zip
  
  BGMNwin
  -- BGMN.EXE
  -- MakeGEQ.EXE
  ... 
  Profex-3.13.x
  
  Devices
  -- Instrument 1.sav
  -- Instrument 1.ger
  -- Instrument 1.geq
  -- Instrument 1.tpl
  -- Instrument 1.tpl
  ... 
  Structures
  -- Structure 1.str
  -- Structure 2.str
  ... 
  Presets
  -- Preset 1.pfp
  -- Preset 2.pfp
  ... 
  profex.exe
  ...
A.2. Mac OS X

Profex-BGMN-Bundle-3.13.x.dmg
- Profex-BGMN
  - profex.app
  - BGMNwin
    - bgmn
    - makegeq
    - ...
  - BGMN-Templates
    - Devices
      - Instrument 1.sav
      - Instrument 1.ger
      - Instrument 1.geq
      - Instrument 1.tpl
      - Instrument 1.sav
      - ...
    - Structures
      - Structure 1.str
      - Structure 2.str
      - ...
    - Presets
      - Preset 1.pfp
      - Preset 2.pfp
      - ...
A.3. Linux

An RPM file for OpenSuse Leap 42.1 x86_64 is provided with the following file structure.

```
/  
  |___opt
  |       |___Profex-BGMN
  |         |___Profex
  |             |___profex
  |                     |___profex.png
  |___BGMNwin
  |       |___bgmn
  |             |___makegeq
  |                     |...
  |___BGMN-Templates
  |       |___Devices
  |           |___Instrument 1.sav
  |           |___Instrument 1.ger
  |           |___Instrument 1.geq
  |           |___Instrument 1.tpl
  |           |___Instrument 2.sav
  |           |                     |...
  |___Structures
  |           |___Structure 1.str
  |           |___Structure 2.str
  |           |                     |...
  |___Presets
  |           |___Preset 1.pfp
  |           |___Preset 2.pfp
  |           |                     |...

  |___usr
  |       |___share
  |           |___applications
  |                     |___profex.desktop
```
References

[8] Andrew, V.J. „The Relative Intensities of the $\alpha_1$, $\beta_1$, $\beta_2$, and $\gamma_1$, Lines in Tantalum, Tungsten, Iridium, and Platinum”“. Phys. Rev. 42(5), 591 (1932).
[19] https://www.w3schools.com/js/js_arithmetic.asp/
[20] https://www.w3schools.com/js/js_math.asp/
Index

$B_{ij}$, 49
$B_{iso}$, 49
$U_{eq}$, 49
$U_{ij}$, 49

Abort, 93
About Profex, 95
Add Phase, 17, 20, 92
Add phases, 21
Anisotropic, 86
AntiAliasing, 97
ASCII free format, 27
ASCII HKL list, 27
Atomic Scattering Factor, 94
Axis
  Font Labels, 98
  y-axis Scaling, 97

B1, 108
Backend, 7, 76, 77
Background Color, 98
Backup, 93
Baseline, 66, 92
Batch Conversion, 90
Batch Processing
  Scan Batch Conversion, 55
Batch Refinement, 93
Batch refinement, 35
BGMN Variables, 95
BGMN.EXE, 10, 12, 99
BGMNwin, 10
Brindley, 108
Bundle, 111
  Linux, 113
  Mac OS X, 112
  Windows, 111

Castep, 34
Cell Files, 34
Chemical Composition, 74
Chemical composition, 77
Chemistry, 36, 77
CIF File

Export, 31
Export Powder CIF, 29
Import, 48, 89
Verification, 48

Color, 76
Context Help, 74, 77, 95
Context menu, 84
Control File, 17, 20, 36
  Profex specific variables, 109
  Text editor features, 84
Convergence, 77, 95, 102
Convolution, 55
Coordinates, 81
Copy, 90
Copy Control File, 36, 90
Counting Noise, 81
CPU Cores, 96
Cross Hair, 80
Cursor, 80, 81
Custom Profile Function, 108
Cut, 90

Database
  Device, 12
  Preset, 12
  Structure, 12
Default Control File, 18, 20
Default Project Type, 96
Device Configuration, 14
Device Database, 10, 12, 14, 101
Displacement
  Left, 91
  Reset, 91
  Right, 91
  Vertical, 91
Dockable Window, 73, 74, 78
  Closing, 74
  Detaching, 74
  Moving, 74
  Opening, 74
  Stacking, 74
Double Click, 81