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1. Introduction

Profex is a graphical user interface for Rietveld refinement of powder X-ray diffraction data with
the program BGMN [1]. It provides a large number of convenience features and facilitates the use
of the BGMN Rietveld backend in many ways. Some of the program’s key features include:

• Support for a variety of raw data formats, including all major instrument manufacturers
(Bruker / Siemens, PANalytical / Philips, Rigaku, Seifert / GE, and generic text formats)

• Export of diffraction patterns to various text formats (ASCII, Gnuplot scripts, Fityk scripts),
pixel graphics (PNG), and vector graphics (SVG)

• Batch conversion of raw data scans

• Automatic control file creation and output file name management

• Conversion of CIF and ICDD PDF-4+ XML structure files to BGMN structure files

• Internal database for crystal structure files, instrument configuration files, and predefined
refinement presets.

• Computation of chemical composition from refined crystal structures

• Batch refinement

• Export of refinement results to spread sheet files (CSV format)

• Context help for BGMN variables

• Syntax highlighting

• Enhanced text editors for structure and control file management and editing

• Generic support for FullProf.2k [2] as an alternative Rietveld backend to BGMN.

• And many more. . .

Profex runs on Windows, Linux, and Mac OS X operating systems and is available as free software
licensed under the GNU General Public License (GPL) version 2 or any later version. The latest
version of the program can be downloaded from [3]. This website provides the Profex source
code, bundles of Profex and BGMN for easy installation on Windows and Mac OS X (requiring
zero configuration), and a default set of crystal structure and instrument configuration files.
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2. Installation

2.1. Windows

2.1.1. Profex-BGMN bundle

Since Profex requires a Rietveld refinement backend, a bundle containing both Profex and BGMN
is offered for download on the Profex website. Using the bundle is the preferred way of installa-
tion if no previous installation is present on the computer. The directory and file structure of the
bundle is shown in appendix ??. The software does not need installation. The downloaded archive
can be extracted to any location on the computer. Automatic configuration of Profex will be able
to locate the BGMN installation if the relative paths of the BGMNwin and Profex-3.8.0 folders are
maintained. Therefore, it is recommended to copy the entire bundle to the same location on the
hard disk, as shown in Fig. 1. Follow these instructions to install BGMN and Profex:

1. Download Profex-BGMN-Bundle-3.8.0.zip from [3]

2. Extract the bundle to your harddisk (e. g. C:\Program Files)

3. Run Profex by executing the file profex.exe (e. g. C:\Program Files\Profex-BGMN-
Bundle\Profex\profex.exe)

The file and directory structure of the bundle is explained in appendix A. Profex is also available
for download without BGMN. This is the preferred way of installation if BGMN is already in-
stalled on the computer, or if previous versions of Profex are to be upgraded. The Profex binary
archive does not need installation. Extracting the archive to the local hard drive is sufficient.

If a previous version is installed on the same computer, using a new version will not interfere with
the existing installation. Old and new versions can be used at the same time, they will share the
configuration options.

2.2. Linux

A binary archive of BGMN for Linux (i686) is available for download on the Profex website [3].
Profex, however, must be compiled from source. It requires a C++ compiler environment and the
Qt toolkit version 5 to be installed [4], including header files. Qt version 5.4 or later is required.
The following Qt 5 modules and header files must be installed:

widgets , xml , printsupport , sql , svg

Support for Bruker BRML raw data files requires the 3rd party libraries zlib [5] and QuaZip [6].
Both libraries are included in the Profex source code archive and linked statically into the binary
in order to avoid version conflicts with system-wide installed libraries linked against Qt version
4.
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2.2.1. Getting the source

Download the source code archive profex-3.8.0.tar.gz from the Profex website [3], extract it to your
harddisk and navigate into the source code directory:

t a r xzvf profex − 3 . 6 . 0 . t a r . gz
cd profex −3.6 .0

2.2.2. Compiling from source code

Run the following commands from the source code directory:

qmake profex . pro
make − j 4
s r c /profex

Make sure qmake of Qt version 5 is used. If unsure, run qmake with the full path. If error mes-
sages occur and the program does not start after typing src/profex, read the error messages
carefully and try to solve all dependency and version problems with your distribution’s software
repository. Qmake locations for Qt5 vary among distributions. Some examples are listed below:

PCLinuxOS 64 bit /usr/lib64/qt5/bin/qmake
PCLinuxOS 32 bit /usr/lib/qt5/bin/qmake
OpenSuse 13.2 64 bit /usr/lib64/qt5/bin/qmake-qt5
OpenSuse 13.2 32 bit /usr/lib/qt5/bin/qmake-qt5
Debian 8.0 64 bit /usr/lib/x86 64-linux-gnu/qt5/bin/qmake
Debian 8.0 32 bit /usr/lib/i386-linux-gnu/qt5/bin/qmake

2.3. Mac OS X

A disk image containing Profex and BGMN for Mac OS X 10.7 or newer is provided for download
on the Profex website [3]. The binary requires a 64bit CPU. Visit [7] to find out whether a specific
Apple computer uses a 64bit or a 32bit CPU.

Mount the disk image and drag the folder Profex-BGMN to the Applications folder. The file and
directory structure of the bundle is explained in appendix A. Then run the application ,,Profex-
BGMN/profex”. The automatic setup routine (section 3) will find the BGMN installation and the
structure and device directories.
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Profex-BGMN-Bundle-3.8.0.zip
BGMNwin

BGMN.EXE
...

Profex-3.8.0
profex.exe
...
Structures

*.str
Devices

*.geq / *.ger

*.sav / *.tpl
Presets

*.pfp

(a) Structure of the bundle archive.

C:\Program Files\Profex-BGMN
BGMNwin

BGMN.EXE
...

Profex-3.8.0
profex.exe
...
Structures

*.str
Devices

*.geq / *.ger

*.sav / *.tpl
Presets

*.pfp

(b) Structure on the hard disk.

Figure 1: When extracting the Profex-BGMN-Bundle to the hard disk, automatic setup will only be
successful if the BGMNwin and Profex-3.8.0 directories are copied to the same location.

3. Setup

3.1. Automatic setup

When starting Profex for the first time, the program will try to locate the BGMN installation di-
rectory and structure and device database directories automatically. Automatic configuration will
also be executed later if the configured paths are invalid. It is therefore possible to force automatic
setup later by deleting the paths to BGMN and the database directories in the preferences dialog.
Automatic setup is platform specific. The locations scanned automatically are listed below.

3.1.1. Windows

Three directories named ,,Structures”, ,,Devices”, and ,,Presets” are expected to be located in the
directory of ,,profex.exe”. ,,BGMN.EXE” is expected to be found in a directory called BGMNwin
stored next to the parent directory of ,,profex.exe”. In other words, automatic setup on Windows
will work if BGMN and Profex directories are organized as shown in Figure 1.

3.1.2. Linux

On Linux, a list of directories is scanned for the executable file ,,bgmn”. Scanning will stop at the
first match. The directories are scanned in the following order:

1. /home/<user>/BGMN/

2. /home/<user>/BGMNwin/
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3. /opt/bgmnwin/

4. /opt/bgmn/

5. /opt/BGMNwin/

6. /usr/bin/

7. /usr/local/bin/

Directories named ,,Structures” ,,Devices”, and ,,Presets” will be searched in the following order
at:

1. /opt/BGMN-Templates/Structures
/opt/BGMN-Templates/Devices
/opt/BGMN-Templates/Presets

2. /home/<user>/Documents/BGMN-Templates/Structures
/home/<user>/Documents/BGMN-Templates/Devices
/home/<user>/Documents/BGMN-Templates/Presets

3. /home/<user>/BGMN-Templates/Structures
/home/<user>/BGMN-Templates/Devices
/home/<user>/BGMN-Templates/Presets

3.1.3. Mac OS X

On Mac OS X the BGMN installation and Structures and Devices directories will be scanned rela-
tive to the path of the Profex application bundle. Profex expects to find the following files, starting
at the position of the Profex application bundle:

• <location of profex.app>/../BGMNwin/bgmn

• <location of profex.app>/../BGMN-Templates/Structures

• <location of profex.app>/../BGMN-Templates/Devices

• <location of profex.app>/../BGMN-Templates/Presets

3.2. Manual setup

The following sections describe how to configure Profex to find the BGMN backend, as well as
the structure, device, and preset database directories manually. There are some scenarios when
automatic setup will fail and the backend and database directories are not found, or when the
automatic configuration is not desired:

• if only Profex was downloaded instead of a Profex-BGMN bundle
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(a) Set the default project type to BGMN. (b) Select the BGMN executable files (red), as well as
structure, device, and preset database directories
(green).

Figure 2: Manual configuration of the BGMN backend in Profex.

• if the Profex and BGMN folders from the bundle were not copied to the same location on the
harddisk

• if other structure and device repositories will be used than the ones provided with the bun-
dle. E. g. centrally stored on a network shared drive, or from a previous installation.

• on Linux no bundles are available

In these cases, manual configuration is necessary. Follow these instructions to set up Profex man-
ually:

1. Run Profex and go to ,,Edit→ Preferences . . . ”.

2. On the page ,,General” set the ,,Default Project Type” to ,,BGMN” (Fig. 2).

3. Go to page ,, BGMN” and check the configuration of ,,BGMN Backend”. If auto-detection
was successful, the lines for executable files and files directories are not empty (Fig. 2).

4. If the lines are empty, click the button on the right of each line and navigate to the corre-
sponding executable file. The file names depend on the operating system. On Windows, the
files are called BGMN.EXE, MAKEGEQ.EXE, GEOMET.EXE, and OUTPUT.EXE. On Linux and
Mac OS X these files are called bgmn, makegeq, geomet, and output.

5. Verify the location of the Structure, Device, and Preset directories. If they are empty or point
to the wrong location, click on the button on the right and select the correct directories.

10



3.3. Using WINE on Linux

Profex supports running the Windows version of BGMN on Linux using WINE. In that case, a
,,BGMNwin” directory from a Windows installation can be copied to any location on a Linux
system. The executable files of the BGMN backend will then be called BGMN.EXE, MAKEGEQ.EXE,
GEOMET.EXE, OUTPUT.EXE, and GERTEST.EXE. Checking the box ,,Run in WINE” and entering
the WINE executable in the configuration dialog (Fig. 2), which is usually /usr/bin/wine, will
let Profex call the BGMN backend in WINE. However, for performance reasons it is recommended
to use the native Linux version of BGMN if available.

3.4. Structure, Device, and Preset Database

Profex supports databases for crystal structures, device configurations, and refinement presets for
the BGMN backend. These databases are directories containing template files. Official Profex-
BGMN bundles usually contain default template files for structures and devices. The location of
these directories can be chosen freely. For example, installations on several computers can access
structures, device files, and presets stored on a network share and maintained centrally. In that
case, new structure files, device configurations, or presets will immediately become available to
all users using the same database directories. Write access is not required for normal use, only for
maintenance. Configuration (automatic or manual) is explained in section 2. Several structure file
directories can be specified, but only one directory for device and preset files, respectively.

3.4.1. Structure Template Files

Template files for crystal structures are normal BGMN structure files (*.str) stored at a central
place in the ,,Structures” database directory. When appending a structure file from the database to
a refinement using Profex’s ,,Add / Remove Phase” dialog, the file will be copied to the location
of the XRD scan. The original file will never be modified.

The following information is relevant when creating new structure files:

• Use the file extension *.str, other files will be ignored by Profex

• Profex will display the name given after the keyword ,,PHASE=” in the ,,Add / Remove
Phase” dialog.

• It is recommended to add further information, e. g. an original database code (PDF, AMCSD,
COD) after a comment sign (//) trailing the ,,PHASE=” keyword (see following example).
This text will be shown as a comment in the ,,Add / Remove Phase” dialog.

The following lines show an example of the file ,,lime.str”.
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Figure 3: Profex allows to modify structure files automatically to apply custom profile functions
and goals.

PHASE=CaO // 04-007-9734
SpacegroupNo=225 HermannMauguin=F4/m-32/m //
PARAM=A=0.4819_0.4771ˆ0.4867 //
RP=4 k1=0 k2=0 B1=ANISOˆ0.01 GEWICHT=SPHAR2 //
GOAL=GrainSize(1,1,1) //
GOAL:CaO=GEWICHT*ifthenelse(ifdef(d),exp(my*d*3/4),1)
E=CA+2 Wyckoff=a x=0.0000 y=0.0000 z=0.0000 TDS=0.00350000
E=O-2 Wyckoff=b x=0.5000 y=0.5000 z=0.5000 TDS=0.00440000

3.4.2. STR File Handling

Depending on where structure files are obtained from (created manually, exported from databases,
converted, downloaded, shared with others) they may contain different profile parameters RP, B1,
k1, k2, GEWICHT etc. Altering these files in the structure file database will also affect other users
accessing the same database, and may thus not be desired. Profex offers a feature to modify the
structure files while copying them from the database to the working directory. Choose ,,Edit →
Preferences→ BGMN→ Structure File Handling” to access the settings (Fig. 3). The individual
options on this page are explained in more detail in section 6.4.1.
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3.4.3. Device Configuration Files

For each device configuration Profex expects to find four different files in the device database
directory. These file names are supposed to have the same file name, but different file extensions
(Fig. 5):

*.sav Containing the description of the device configuration. To be processed with GEOMET.

*.ger Containing the raytraced profile shape. To be processed with MAKEGEQ.

*.geq Containing the interpolated profile.

*.tpl A sample *.sav control file for the refinement, not containing any file names or phases (op-
tional).

The *.tpl file is specific to Profex, all other files will be required by BGMN. The *.tpl file can be any
existing refinement control file, but all output file names (LIST=, OUTPUT=, DIAGRAMM=), all scan
file names VAL[n]=, and all structure file names STRUC[n]= should be empty. *.tpl files allow to
add goals, calculations, numbers of threads and similar customizations, which will be applied by
default when creating a new file set from the database. An example is shown below. All device
file names, structure files, scan files, and the various output files will be filled in automatically
by Profex. The automatic processes running in the background when using the ,,Add / Remove
Phase” dialog are illustrated in Fig. 5. More information on the ,,Add / Remove Phase” dialog
can be found in section 7.

% Theoretical instrumental function
VERZERR=
% Wavelength
LAMBDA=CU
% Phases
% Measured data
VAL[1]=
% Minimum Angle (2theta)
% WMIN=10
% Maximum Angle (2theta)
% WMAX=60
% Result list output
LIST=
% Peak list output
OUTPUT=
% Diagram output
DIAGRAMM=
% Global parameters for zero point and sample displacement
EPS1=0
PARAM[1]=EPS2=0_-0.001ˆ0.001
betaratio=0
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Figure 4: If no instrument template file is found, a dialog will ask for basic information on the
radiation and monochromatization.

NTHREADS=2
PROTOKOLL=Y

If the template file contains a reference to a scan file containing a measured background curve
(UNT=<my-background>.xy), the background file should be stored in the device database di-
rectory, too. Profex will copy it to the project directory when creating a new refinement control file.
The background scan file will not be converted. It must be stored in a format natively supported
by BGMN. The recommended format is ASCII XY.

The template file is optional. If no template file is found for an instrument, a dialog will be shown
asking for basic information about the X-ray tube target material and the type of monochromati-
zation (Kβ filter, monochromator, energy dispersive detector) used (Fig. 4).

3.4.4. Refinement Preset Files

A refinement preset file allows to quickly create a control file with a certain device configuration
file and a set of structures. It is useful for standard refinement always using the same device
configuration and structure files, as it allows to set up the control file with a single mouse click.
The format and application of preset files is described in detail in section 7.2.
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Structures database

Albite.str
Barite.str
Calcite.str
Dolomite.str
Ettringite.str
Fluorite.str
Gypsum.str
Hematite.str
Illite.str
Jade.str
Kaolinite.str
Lime.str
Magnesite.str
Nahpoite.str

Devices database

Instrument1.tpl
Instrument1.sav
Instrument1.ger
Instrument1.geq
Instrument2.tpl
Instrument2.sav
Instrument2.ger
Instrument2.geq
Instrument3.tpl

Project directory

myscan.xrdml

myscan.sav

Instrument1.sav
Instrument1.ger
Instrument1.geq

Calcite.str
Dolomite.str
Magnesite.str

Copies files from
database directories
to project directory

Modifies *.str files
if requested

Converts instrument
template (*.tpl) file to

control file (*.sav)

"Add Phase" Dialog

Figure 5: The ,,Add / Remove Phase” dialog will copy structure files and device files from the
database directories to the project directory. If selected in the preferences, the structure
files will be modified according to the preferences in ,,STR File Handling”. Files already
existing in the project directory will not be overwritten, unless the option is checked
manually in the ,,Add / Remove Phase” dialog.
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4. First steps

When Profex and BGMN have been installed and configured correctly as described in sections 2
and 3, and at least one device configuration and structure file has been stored in the databases
(section 3.4), the program is ready for a first refinement:

1. Click ,,File→ Open Graph. . . ”, or alternatively press Ctrl+G or the corresponding button in
the main tool bar.

2. In the opening file dialog set the file format at the bottom to the format of your raw scan
file, and open the file. See Tab. 1 for supported file formats. If a format is not supported, or
support is broken, other software such as PowDLL [11] is required to convert the scan to a
format supported by Profex.

3. The scan will be loaded as a new project.1

4. Double click on the strongest peak or select a reference structure from the reference structure
dropdown menu to identify your main phase.

5. Click ,,Edit → Add / Remove Phase. . . ”, or press F8 or the corresponding button in the
project tool bar create a control file. The dialog shown in Fig. 10 will be shown.

6. Select your instrument configuration from the dropdown menu, your phase from the struc-
tures list (it may be pre-selected), and verify that the option ,,Generate default control file”
is active. Then click ,,OK”.

7. Click ,,Run→ Run Refinement. . . ”, press F9, or click the corresponding button in the refine-
ment tool bar to start the refinement.

8. Wait for the refinement to complete.

9. If more phases are present, repeat steps 4–7, but make sure the option ,,Generate default
control file” is not active anymore.

10. If the refinement is complete, click ,,File→ Export Global Parameters and GOALs”, or press
Ctrl+E or the corresponding button in the project tool bar to export the results to a CSV file.

11. Optionally, also click ,,File→ Export Local Parameters and GOALs”, or press Shift+Ctrl+E
or the corresponding button in the project tool bar to export the local results to a CSV file.

The exported CSV files can be opened in a spreadsheet program such as Microsoft Excel, Libre-
Office Calc, or Softmaker PlanMaker. Specify the semicolon ,,;” as field separator and use the
spreadsheet program’s sort feature to sort the parameters as needed.

1At the first start of the program, all reference structures in the structure database directory will be indexed. Depend-
ing on the number of files and the speed of the computer, this may take up to several minutes. A progress dialog is
shown while indexing is in progress.
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Table 1: Data file formats supported for import by Profex. Level of support (LoS): A = full sup-
port based on the file format specification, including multi-range files; B = good support,
reverse-engineered; C = basic support, reverse engineered.

Manufacturer Extension File format Version LoS

Bruker *.raw Binary V1, V2, V3, V4 A
Bruker *.brml XML Compressed archive B
Bruker *.brml XML Single XML file with XML data

container
B

Bruker *.brml XML Single XML file with binary
data container

B

PANalytical *.xrdml XML 1.0 - 1.5 A
Philips *.rd Binary - C
Philips *.udf ASCII - C
Seifert/FPM *.val ASCII - B
Rigaku *.bin Binary - C
Rigaku *.dat, *.rig, *.dif ASCII - C
Rigaku *.raw Binary - C
MDI Jade *.xml XML - C
MDI Jade *.dif ASCII - C
STOE *.pro ASCII - C
STOE *.raw Binary - C
Generic *.xy ASCII Field separators: ; : , space tab

Comment signs: ! % & #
A

BGMN *.dia ASCII - A
Fullprof.2k *.prf ASCII Only PRF=3 A
Fullprof.2k *.dat ASCII Only INS=10 A
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5. Main Window

The program’s main window features a menu bar and several tool bars to access all functions and
settings (Fig. 6). The central area of the main window is occupied by the plot area, and optionally
one or several text editors, which are accessible by tabs at the top of the plot area. The plot area
cannot be closed, but text editors can be closed by clicking the close button on their tab.

The central area is surrounded by several dockable windows showing additional information and
giving access to more features. These dockable windows can be closed and opened from the
,,Window” menu. They can also be re-arranged (Fig. 7) by clicking on the title bar showing the
window’s name, and dragging it to another location. Dockable windows can be stacked on top of
each other to hide less frequently used windows, or detached from the main window, e. g. to be
placed on another screen, or closed.

5.1. User Interface Elements

The following list explains the elements of the user interface shown in Fig. 6 in more detail.

1 Menu bar gives access to most features, as well as the program’s preferences. All menu items
are discussed in section 5.6.

2 Main tool bar gives access to file operating features such as opening, saving, etc.

3 Project tool bar gives access to project related functions, such as opening/closing structure
files, exporting results, adding/removing phases etc.

4 Refinement tool bar gives access to starting/stopping refinements or batch refinements.

5 Reference structure tool bar allows to select reference structures to display hkl indices, as well
as to start scanning and indexing new structure files. See section 5.5 for more information.

6 Plot area displays raw or refined scans, and opens text editors for control files, results files,
structure files, or generic text files.

7 Projects window lists all open projects and the refinement status. Selecting a project from this
list will show it in the central plot area.

8 Plot options lists all scans loaded in the plot area. The ,,Show” checkbox can be used to
show/hide certain scans to customize the appearance of the plot.

9 Refinement protocol shows output generated by the refinement backend.

10 Global Parameters and GOALs shows a summary table of refined global parameters. Listing
EPS parameters can be configured in the program’s preferences dialog.

11 Local Parameters and GOALs shows a summary table of refined local parameters. The pa-
rameters shown here can be customized in the program’s preferences dialog.

12 Context help shows the context help text when pressing ,,F1” on a keyword in a control file.
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13 Chemical composition shows the bulk chemical composition of all crystalline phases, calcu-
lated from refined crystal structures and phase quantities.

14 Status bar shows various information such as mouse cursor coordinates on the graph, and the
wavelength used to transform 2θ angles to d values.

5.2. Dockable windows

All windows arranged around the central plot and editor area (no. 7–13 in Fig. 6) can be rear-
ranged or closed to match the user’s preferences. They are called dockable windows, because
they can be docked to different areas of the main window. Some examples are shown in Fig. 7 and
explained below:

Moving: Grab the dockable window at it’s title bar (e. g. the bar (green rectangles on Fig. 7) and
drag it to a different location. If the window can be docked, the area will be highlighted.

Stacking: Drag the dockable window onto another dockable window. The dragged window will
be stacked on top. Tab buttons will automatically appear to give access to both windows.
Unlimited numbers of windows can be stacked.

Detaching: Drag a window outside of the main window and release it when no dockable area is
highlighted. The window is now detached from the main window and floating freely on the
screen. Use this configuration to place windows on a second screen. Detached windows can
also be stacked. Drag the detached window back into the main window to dock it.

Closing / Opening: Dockable windows can be closed by clicking on the close button (x) in the title
bar. To open it again, use the menu ,,Window” in the main window’s menu bar.

5.2.1. Projects

This list shows all open projects and their current status. Click on a project to view it in the plot and
editor area. Most actions from the menu and toolbar will apply to the currently shown project.

Projects can be edited while another project is refining. Multiple projects can be refined at a time,
but refinement may be slow depending on CPU power and number of CPU cores.

Running a batch refinement (see section 5.6.5) will allow to refine all open projects in a sequence,
rather than parallel.

19



Fi
gu

re
6:

T
he

Pr
of

ex
m

ai
n

w
in

do
w

.E
le

m
en

ts
1–

14
ar

e
de

sc
ri

be
d

in
se

ct
io

n
5.

1.

20



5.2.2. Plot options

This list shows all scans loaded in the currently shown project. To change the scans’ drawing style
(color, line style, line width), refer to the graph preferences discussed in section 6.3.

If a scan is clicked on with the mouse, it is set to active, as indicated by the symbol ,,A” shown
next to the checkbox. Clicking it again will deactivate the scan. Active scans are shown in bolder
line width than inactive scans. Only one scan can be set to active at a time. The active scan can
be scaled by holding the middle mouse button and moving the mouse vertically. Clicking with
the right mouse button will reset the scale. If a rescaled scan is deactivated, it will not be reset by
a right mouse click anymore, until it is activated again. The only purpose of activating scans is
to visually highlight them and to allow mouse scaling. Currently there is no other functionality
related to scan activation.

Visibility of each scan can be changed by checking or unchecking the box in front of the scan
name. For refined scans Profex distinguishes between main scans (usually Iobs, Icalc, Idi f f , and the
background curve), as well as phase patterns. All phase patterns can be toggled on or off at once
by using the function ,,View→ Show/Hide phase patterns”. This change is persistent and applies
to all open projects. It is a convenience function for easy showing or hiding all phase patterns, but
the same result can be obtained by manually checking or unchecking all phase patterns of all open
projects.

hkl tick marks are considered as part of phase patterns. Showing/hiding a phase pattern will also
show or hide the phase’s hkl lines. By using the functions in ,,View → Plot” (see section 5.6.3),
drawing of hkl lines and phase patterns can be controlled separately. This allows to draw either
no phase information, hkl lines only, phase patterns only, or both.

Double-clicking on a scan parameter (name, scale factor, vertical or horizontal offset) allows to
edit the parameter directly. The changes will not be persistent, as they will get lost after closing
the scan file or running a refinement. They will, however, be preserved when exporting the scans
to ASCII, GNUplot, SVG, or PNG format.

Scans can be added or removed to the project by the functions ,,File→ Insert Graph File. . . ” and
,,File → Remove Scan. . . ”. However, as soon as the main graph file is reloaded, for example
automatically during a refinement, and added or removed scans will be reset and only the content
of the reloaded file will be shown.

5.2.3. Refinement protocol

This windows shows the output of the Rietveld refinement backend.

5.2.4. Global Parameters and GOALs

At the end of the refinement, this window shows a summary of the refinement results. The dis-
played parameters depend on the Rietveld refinement backend. For BGMN, the table shows
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all global goals and parameters, including estimated standard deviations (ESD) as calculated by
BGMN. Some configuration options are available in the preferences as described in section 6.4.3.
Values summarized here can also be exported to a CSV table using the function ,,File → Export
Global Parameters and GOALs (Ctrl+E)” (see section 5.6.1).

5.2.5. Local Parameters

At the end of the refinement, this window shows a summary of refined local (phase related) pa-
rameters. This function depends on the Rietveld refinement backend and is not available for all
backends. In case of BGMN, is is available and can be configured in the preferences as described
in section 6.4.3. Values summarized here can also be exported to a CSV table using the function
,,File→ Export Local Parameters” (see section 5.6.1).

5.2.6. Chemistry

The ,,Chemistry” dock window shows the refined chemical composition of the sample. This infor-
mation is only available for BGMN, but not for other Rietveld refinement backends. See sections
9 for more information.

5.2.7. Context Help

This window shows the context help, which can be accessed by placing the mouse cursor on a
keyword in a control file, and pressing ,,F1”. Context help is available for BGMN, but may not be
available for other Rietveld refinement backends (see section 5.6.9).

5.3. The Plot area

The plot area is the central area of the main window. It shows the loaded scans. Some appearance
options can be configured in the preferences dialog as described in section 6.3. Visibilities of the
legend, hkl indices, and phase patterns can globally be switched on or off in the menu ,,View→
Plot”, as described in section 5.6.

The plot area interacts with the following mouse and key operations. A summary of mouse and
keyboard commands can be displayed by pressing the ,,Shift” key or selecting ,,Help → Mouse
and keyboard commands”.

Moving the mouse cursor: The cursor position will be displayed in the status bar at the bottom
of the main window. The horizontal and vertical position will be shown in degrees 2θ and
counts or counts per second, depending on the unit of the y-axis (see section 6). Addition-
ally, the horizontal position will also be shown as d value in Å. The wavelength is used to
calculate d values. If no wavelength information is found in the scan file, Profex will use the
default wavelength specified in the preferences (see section 6).
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Figure 7: Many elements of the user interface can be re-arranged by grabbing the title bar and
dragging the window to a different place (1 stacked; 2 detached from the main window;
3 closed). Green rectangles show the title bars that can be grabbed with the mouse to
rearrange the windows.
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Hovering the mouse pointer on a hkl index line at the top of the plot will show a tool tip
displaying the phase name, hkl Miller indices, and the texture factor.

Zooming: Use the left mouse button and drag the mouse to zoom into the plot.

Alternatively use the mouse scroll wheel to zoom horizontally to the location of the mouse
cursor, or hold the Ctrl key and use the scroll wheel to zoom vertically to the location of the
mouse cursor.

Hold the Ctrl key and left mouse button to move the zoomed scan.

Unzooming: Click with the right mouse button to view the entire scan range.

Cross hair cursor: Press the ,,c” key on the keyboard to activate a cross hair cursor (Fig. 8). Press
,,c” again to disable it.

Counting noise cursor: Press the ,,n” key on the keyboard to show or hide a cursor indicating a
range of

±
√

Intensity[counts]

This range represents the Poisson-distributed statistical counting noise and allows to evalu-
ate mismatches between Iobs and Icalc, for example at the tips of peaks (Fig. 8).

When moving to the difference curve, the noise cursor will show the counting noise at the
intensity of the first scan (e. g. Iobs) at the same 2θ position.

Spectral line cursor: Press the ,,s” key to show or hide a cursor showing lines at the position of
Kα1, Kα2, and Kβ. The Kα1 line will be drawn at the position of the mouse cursor (Fig. 8).
Positions for Kα2 and Kβ lines will be calculated from the d value at the cursor position. If no
wavelength is available, the default wavelength specified in the preferences dialog will be
used (see section 6). For monochromatic synchrotron radiation this feature is meaningless.
Use the cross hair cursor instead.

Additionally, peaks from characteristic Tungsten radiation (WLα1 and WLβ) can be shown
by activating the option ,,Show characteristic Tungsten lines with spectral line cursor” in
the preferences dialog (section 6). This allows to inspect the diffraction pattern for Tungsten
contamination lines caused by aging X-ray tubes. The relative intensities of Tungsten lines
[8] are WLα1 (100 %), WLβ1 (49.4 %), WLβ2 (20.2 %). WLβ2 is not shown.

Load reference structure: Double click with left mouse button will load the reference structure
with it’s strongest peak closest to the double click position. This is a very simplistic way for
phase identification, however, it can be very efficient and useful in some situations. Note
that only indexed structure files are considered. Refer to section 5.5 for more information
on indexing of references structure files. Also note that the strongest peak of the reference
structure indices depends on the instrument configuration used for indexing (fix or variable
divergence slit) and may therefore not be at the location of the currently processed scan.

Scale reference lines: Hold the middle mouse button and move the mouse vertically to scale
the intensity of reference lines. Dragging the lines below the line of zero counts allows
comparing peaks in the difference curve.
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List of coordinates: Hold the Ctrl key and double click with the left mouse button to copy the co-
ordinates of the mouse cursor to the refinement output console. From there the coordinates
can be copied and pasted to another program for further processing.

Scans from different graph files can be added to the plot area by the function ,,File→ Insert Graph
File. . . ”. Several files can be selected at a time. To remove a specific scan, select it in the dock
window ,,Plot Options” and click ,,File → Remove scan. . . ”. When starting a refinement, the
project’s main graph file will automatically be reloaded and all added or removed scans will be
reset to the main graph file’s content.

5.3.1. Stacking Scans

All scans in the plot area, originating from a single graph file or combined from several graph files
using ,,File→ Insert Graph File. . . ”, can be stacked vertically and/or horizontally. Offsets can be
adjusted by ,,View→ Increase vertical displacement”, ,,View→ Decrease vertical displacement”,
,,View→ Displace left”, and ,,View→ Displace right”. All displacements can be reset by ,,View
→ Reset Displacement”. An initial offset will be applied, which can be reduced incrementally by
calling the function moving the scans in the opposite direction. The following commands were
used to create the graphs shown in Figs. 9a and 9b:

1. ,,View→ Increase vertical displacement” to stack the scans vertically at regular intervals of
the maximum intensity of the strongest scan (Fig. 9a).

2. ,,View→Decrease vertical displacement” was called several times to reduce – not reset – the
vertical offset, followed by ,,View→ Displace right” to stack the scans to the right (Fig. 9b).

A special vertical offset will be applied when calling ,,View → Decrease vertical displacement”
first. In that case, positive vertical stacking will be applied, but instead of regular intervals, each
scan will be displaced to the maximum intensity of the previous scan (Fig. 9). This will avoid
large gaps above scans with low maximum intensity, however, it can also be confusing with scans
of very low intensity (e. g. amorphous samples or the background curve). In the latter case,
applying a regular stacking interval by calling ,,View→ Increase vertical displacement” may be
preferred.

5.4. Text Editors

Text editors can show any kind of text files, including control files, list files, structure files, or any
generic text file. For control files and list files they will show syntax highlighting for better visual
orientation.

Besides the standard actions for text editors, such as copy, paste, undo, redo, and selection, the
context menu shown by clicking with the right mouse button has some special features for control
and structure files.
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(a)

(b)

(c)

Figure 8: Different cursors of the plot area: (a) counting noise cursor, (b) cross hair cursor, (c)
spectral lines cursor.
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5.4.1. Control File specific features

Open File: When placing the cursor on a file name and clicking with the right mouse button, the
context menu will show the action ,,Open File” at the bottom. Depending on the file type,
the file will be opened as a scan file (VAL[n], DIAGRAMM), or as a text file (STRUC[n],
STRUCOUT[n], SimpleSTRUCOUT[n], RESOUT[n], PDBOUT[n], FCFOUT[n]).

Note that if the file name contains spaces or underscores, the full file name must be selected
with the text cursor before right-clicking. Else the file name will not be recognized correctly.

Add <output> file: When placing the cursor on a STRUC[n] file line and clicking the right mouse
button, the context menu will offer to add various structure output files. The refined crystal
structure will be written to these files at the end of the refinement. They may be useful for
import into other programs, e. g. for structure visualization or publication in databases or
papers. The output file names will be set to <phaseName>-<projectBasename>.ext
so as to create unique file names and prevent accidential overwriting of output files
from other projects in the same directory. The formats offered are STRUCOUT[n],
SimpleSTRUCOUT[n], RESOUT[n], PDBOUT[n], and FCFOUT[n]. Please refer to the
BGMN documentation for more information about the file formats.

5.4.2. Control and Structure File specific features

When placing the cursor on a parameter and clicking with the right mouse button, the context
menu will offer the following actions:

Fix Parameter: This will set the parameter under the mouse cursor to be fixed (i. e. not refined).

Refine Isotropically: This will release the parameter under the mouse cursor for isotropic refine-
ment. Reasonable lower and upper limits will be applied by default.

Refine Anisotropically: This will release the parameter under the mouse cursor for anisotropic
refinement. A reasonable upper limit will be applied by default. Note that if the parameter
cannot be refined anisotropically (e. g. unit cell parameters, fractional coordinates, etc.),
choosing anisotropic refinement will set the parameter to isotropic refinement, but without
any lower and upper limits.

Refinement states of parameters can also be toggled with the keys F5 and F6. If clicked on a pa-
rameter supporting anisotropic refinement, the refinement state will be changed in the following
order:

F5: anisotropic → isotropic with limits → fix

F6: fix → isotropic with limits → anisotropic with upper limit

If the parameter does not support anisotropic refinement, the refinement state will be changed in
this order:

F5: isotropic without limits → isotropic with limits → fix
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F6: fix → isotropic with limits → isotropic without limits

Reasonable default limits will be used in all cases. If the toggled parameter is an EPSn parameter
in the control file, the numbering of PARAM[n] will be updated automatically if necessary.

5.5. Tool bars

All functions shown in the main toolbar, project toolbar, and refinement toolbar are also accessible
in the menu bar and are described in detail in section 5.6. Toolbars can be re-arranged by dragging
the left end to another position, or shown / hiden by right-clicking on a toolbar and checking or
unchecking the toolbar in the context menu.

Elements of the reference structure toolbar are only visible if at least one project is loaded. They
are not accessible through a menu, only by the toolbar buttons:

Reference structures: A menu allowing to select a reference structure from all STR files found
in the structure database directory. If selected, the STR file’s hkl lines will be shown in the
graph. This is a generic way of phase identification. When using the ,,Add Phase” dialog
while a reference structure is displayed, this structure file will be pre-selected in the ,,Add
Phase” dialog.

If STR files have not been indexed before, hkl indices will be calculated on the fly when the
structure is selected. On modern computers, this only takes a second or two. Afterwards
the hkl positions will be buffered and be available instantly. The buffer can be cleared as
described in section 6.6. Note that the double-click function described in section 5.3 is only
available for indexed reference structures.

Reset reference structure: This button will reset the reference structure dropdown menu and
hide reference hkl lines. After resetting, no structure will be pre-selected in the ,,Add Phase”
dialog anymore.

Search and index new reference structures: Pressing this button will scan the structure database
directory for new STR files and index all new files. The reference structures become imme-
diately available in all projects.

5.6. Menu Structure

5.6.1. File

Open Text File. . . (Ctrl+O) Opens a file in a text editor. If a project with the same name as the
text file’s base name is already open, the file is opened in this project. Else a new project is
created.

If the text file is a control or results file, Profex will automatically locate all other control and
results files of the same project, as well as the scan file, and open them, too. Non-existing
files are ignored.
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BGMN structure files (*.str) are always opened in the currently shown project, regardless of
the project name.

Open Graph File. . . (Ctrl+G) Opens a scan file in the graph page. If a control and/or results file
with the same base name is found, Profex will open it, too.

Insert Scans. . . (Ctrl+I) Inserts scans from one or more graph files into an existing project. The
additional scans will only be displayed in the project’s graph view. Other files, such as
the control file, will not be modified. If no project is available, a new one will be created,
based on the name of the first selected graph file. Inserted scans will be discarded when the
project’s graph file is reloaded, e. g. during a refinement.

Remove Scan. . . Removes the scan selected in the ,,Plot Options” window from the graph view.
No other files will be modified. Removed scans will be restored when the project’s graph
file is reloaded, e. g. during a refinement.

Save (Ctrl+S) Saves the current file under the same file name. This function only works for text
files.

Save file as. . . (Shift+Ctrl+S) Saves the current file under a new file name. A file dialog is shown
to ask for the file name, location, and file format.

Save all text files in all projects Saves all modified text files (control and structure files) in all
open projects. This function can be used after calling ,,Edit → Copy control file”, because
the newly created control files will only be created in text editors, but not yet saved to disk.
Calling this function will save them to disk all at once.

Recent Graph Files Shows a list of recently opened graph files.

Recent Text Files Shows a list of recently opened text files. For scan files, different output formats
can be selected. Scans can be saved as raw data for further processing, or images.

Print (Ctrl+P) Prints the currently shown text or graph file. Printing options may differ depending
on the platform and device driver.

Close Project (Ctrl+W) Closes the current project. If a refinement is running, a message will ask
for confirmation before aborting the refinement.

Close All Projects Closes all open projects. If one or more refinements are in progress, a warning
will be displayed and no project will be closed.

Import Structure File. . . Opens a dialog to convert CIF files (*.cif) or ICDD XML files (*.xml) to
BGMN structure files (*.str). See section 13 for more information. CIF files can be obtained
from various databases. ICDD XML files can be exported from the ICDD PDF-4+ graphical
user interface using ,,Save PDF card as. . . ”. See section 13 for more information.

Scan Batch Conversion. . . Opens a dialog for batch conversion of graph files. All currently
opened project scans will be added to the batch list by default. More files can be added
or deleted in the dialog. See section 12 for more information.

Quit (Ctrl+Q) Quits the application.
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5.6.2. Edit

Undo Reverts the last change in the currently shown text file.

Redo Restores the last undone change in the currently shown text file.

Copy Control File Copies the current project’s control file to other projects and adapts all input
and output file names to match the projects’ base names. A dialog will allow to select which
projects’ control file shall be modified. Existing control files will be overwritten.

Note that this function does not check whether referenced structure files are actually present
in all project directories. It only manages control files, but not structure files.

Reset File Reverts the current project’s control file to the state before the last refinement. This
function is only used for the Fullprof.2k backend, but not for BGMN, because BGMN usually
does not modify STR and SAV files.

Preferences. . . Opens the program’s preferences dialog. All preference options are discussed in
detail in section 6.

5.6.3. View

Switch to Graphs (Ctrl+1) Raises the Graph page of all projects.

Switch to Control Files (Ctrl+2) Raises page 2 (usually the control file) of all projects.

Switch to Output Files (Ctrl+3) Raises page 3 (usually the results file) of all projects.

Set Zoom Range. . . Opens a dialog to zoom the graph to precise upper and lower limits for angle
and intensity.

Show/Hide Phase Patterns (Ctrl+0) Activates or deactivates visibility of all phases. This option
applies to all open projects. It only checks or unchecks the visibility boxes of all phase pat-
terns in the Plot Options list for convenient displaying or hiding of all phases. Individual
phases can be shown or hidden by selecting or un-selecting the ,,show” option in the Plot
Options list. More information is given in section 5.2.2.

Plot Configure the visibility of the following elements on the plot:

Phase Patterns Shows or hides patterns of phases.

Legend Shows or hides the plot legend.

hkl Indices Shows or hides the hkl index tick marks at the top of the plots.

Increase Vertical Displacement (Ctrl+Up) Applies a regular vertical offset to all scans. The initial
offset will correspond to the maximum intensity of the strongest scan. When called again,
this function will increase the previous offset by a constant value.
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Decrease Vertical Displacement (Ctrl+Down) Reduces the vertical offset of all scans by a constant
value. If no vertical offset exists, an initial adaptive offset will be applied, with a vertical
displacement of each scan corresponding to the maximum intensity of the scan below.

Displace left (Ctrl+Left) If no horizontal offset exists, it will apply a horizontal offset to the left to
all scans. If an offset to the left exists, the offset will be increased by a constant value. If an
offset to the right exists, the offset will be reduced by a constant value.

Displace right (Ctrl+Right) If no horizontal offset exists, it will apply a horizontal offset to the
right to all scans. If an offset to the right exists, the offset will be increased by a constant
value. If an offset to the left exists, the offset will be reduced by a constant value.

Reset Displacement (Ctrl+Space) Resets all horizontal and vertical offsets.

5.6.4. Project

Add / Remove Phase. . . (F8) Opens a dialog to create or manage a control file. New phases can
be added or existing phases can be removed from the refinement. If no control file exists
yet, a new one will be created. In that case, the correct instrument configuration file must be
selected. The option to create a default control file is automatically activated or deactivated,
depending on whether or not a control file already exists.

If a phase is activated in the Reference Phase box, it will be pre-selected in the Add Phase
list.

If a default control file is created despite an existing control file, the existing one will be
overwritten, any previously added modifications or phases will be lost.

Selected structure files and instrument configuration files will be copied from the structure
and device database directory to the project directory. Files already existing in the destina-
tion directory will be skipped. If the option ,,overwrite existing files” is checked, existing
structure files will be overwritten with the file copied from the structure file database. See
section 7 for more information.

When removing a phase from the control file, the structure file can optionally be deleted.
Deleting structure files may cause problems with other projects stored in the same directory
and accessing the same structure files.

Open all project STR files (Ctrl + F8) Opens all BGMN structure files (*.str) referenced in the cur-
rent project’s control file (*.sav) in new pages.

Close all project STR files (Ctrl + F7) Closes all BGMN structure files (*.str) shown in the current
project.

Set Internal Standard Allows to define one refined phase as internal standard phase with a given
quantity. The calculation of phase quantities will be changed to apply the internal standard
correction, and the standard phase will no longer be shown in the summary table.
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Unset Internal Standard Reverts the internal standard calculation of refined phase quantities. All
phases will be shown in the summary table in quantities normalized to the sum of all phases.

Refinement Presets Lists all refinement presets to create refinement control files. Select one of
them to apply the preset to the current project. See section 7.2 for more information on
refinement presets.

Save as Refinement Preset. . . Creates a new refinement preset from the currently loaded project.
See section 7.2 for more information on refinement presets.

Create Project Backup Creates a ZIP compressed archive of the current project. The file name is
determined automatically as projectBasename-YYYYMMDD-hhmm.zip. It will be stored
inside the current project’s working directory. The archive includes the raw data file, all
instrument files, structure files, and output files of the project.

Create Project Backup As. . . Creates a ZIP compressed archive of the current project. The file
name and path can be selected by the user. The archive includes the raw data file, all instru-
ment files, structure files, and output files of the project. The ZIP archives can be stored as a
backup or shared with other users, as they contain all project relevant data.

5.6.5. Run

Run Refinement (F9) Starts the refinement of the currently shown project.

Run Batch Refinement (F10) Starts a batch refinement of all open projects.

Abort Current Refinement (Ctrl+C) Aborts refinement of the currently shown project. In batch
refinement mode all projects scheduled for batch refinement will be unscheduled. If the cur-
rently shown project is not running but scheduled, it will be unscheduled but the remaining
batch refinement will not be interrupted. In either case refinements started outside of the
batch will not be interrupted.

Abort All Refinemet (Shift+Ctrl+C) Aborts all running projects and batches. If more projects than
the currently shown one are affected, the user will be asked for confirmation.

Follow Active Refinement When processing a batch refinement, activate this function to always
raise the currently refining project. If a project refinement has completed, the next scheduled
project will automatically be raised. This allows to monitor the batch refinement on screen.
The function can be toggled on and off at any time, also during a running batch. It is au-
tomatically deactivated as soon as the user selects a text editor of any open project, so as to
avoid automatically raising a different project while a text file is being edited or read.
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5.6.6. Results

Export Global Parameters and GOALs (Ctrl+E) Exports the global parameters and goals (e. g.
phase quantities) to a semicolon separated spread sheet (*.csv). See section 8.3.1 for more
information.

Export Local Parameters and GOALs (Shift+Ctrl+E) Exports the local parameters and goals (e. g.
structural parameters) to a semicolon separated spread sheet (*.csv). See section 8.3.1 for
more information.

Export Chemistry. . . Writes the calculated chemical composition to a semicolon separated spread
sheet (*.csv). See section 8.3.1 for more information.

Export CIF file from LST file This function reads LST files of all open projects and writes crystal
structure information to CIF files. One CIF file will be created for each crystal structure
found. The file will be stored in the project directory. Information on saved files is shown in
the refinement protocol console.

Export CELL file from RES file This function reads RES files of all open projects and writes crystal
structure information to CELL files for the software Castep [9]. One CELL file will be created
for each crystal structure found. The file will be stored in the project directory. Information
on saved files is shown in the refinement protocol console. If no RES file is available for a
specific phase, a tag RESOUT[n]=filename.res must be added to the control file (*.sav)
and the refinement must be repeated.

5.6.7. Instrument

New Configuration. . . Read some hardware information from Bruker RAW V4, Bruker BRML V5,
and PANalytical XRDML files to create a BGMN instrument configuration file from scratch.
Other raw data formats are not supported. Usually several variable required by BGMN will
still not be available from the raw data files and will thus have to be entered manually. See
section 14 for more information.

Edit Configuration. . . Opens a dialog to process BGMN instrument configurations. See section
14 for more information.

Learn Profile. . . Opens a dialog to process BGMN instrument configurations using the ,,Learnt
Profile” approach.

Show Peak Shape. . . Opens a dialog that calculates the theoretical peak shapes for a selected
instrument configuration file.
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5.6.8. Window

Projects Shows or hides the Projects list window.

Plot Options Shows or hides the Plot Options window.

Refinement Protocol Shows or hides the Refinement Protocol window.

Global Parameters and GOALs Shows or hides the summary table window for global parameters
and goals.

Local Parameters Shows or hides the summary table window for local parameters and goals.

Chemistry Shows or hides the table showing the refined chemical composition in oxide form.

Context Help Shows or hides the context help display.

5.6.9. Help

Context Help. . . (F1) Shows the context help of the keyword under the text cursor. The ,,Context
Help” window (,,View” menu) must be shown to display the context help.

BGMN Variables. . . Opens a web browser showing the BGMN variables documentation page.

BGMN SPACEGRP.DAT. . . Opens a dialog to browse spacegroups and atomic positions sup-
ported by BGMN.

BGMN Atomic Scattering Factors. . . Opens a dialog to browse atomic scattering (form) factors
supported by BGMN. The dialog reads the file AFAPARM.DAT, which is part of the BGMN
software distribution.

Mouse and Keyboard Commands Shows a dialog with mouse and keyboard commands for plot
windows.

About Profex. . . Shows information about Profex.
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6. Preferences

6.1. General

Toolbar Layout Select how icons and text in Profex’ toolbars are shown.

Restore open projects If checked, Profex will load all previously open graph files upon program
start.

Default Project Type For files not specific for either BGMN or Fullprof.2k, this option determines
which type of project will be created when such a file is opened. The file type is identified
by the file extension.

File extensions can also be associated with either of the two backends by adding the exten-
sion either to the list of ,,File Extensions associated with BGMN” or ,,File Extensions asso-
ciated with Fullprof” on the corresponding backend configuration pages of the preferences
dialog.

Number of CPU cores used by BGMN Specifies how many CPU cores will be used by the refine-
ment backend (only available for BGMN). ,,Automatic” will use all available cores.

File Extensions associated with Fullprof These file types will always be opened as Fullprof
projects, regardless of the default project type. Enter the extension in small letters without
asterisks and periods, separated by a space character. Example: pcr dat sum prf

File Extensions associated with BGMN These file types will always be opened as BGMN
projects, regardless of the default project type. Enter the extension in small letters without
asterisks and periods, separated by a space character. Example: sav lst dia str

Default Wavelength This wavelength, given in Å, is used for scan files not containing any infor-
mation about the wavelength.

Always use default Wavelength If checked, Profex will ignore the wavelength read from the scan
file and always use the default wavelength to calculate d values from diffraction angles.

6.2. Editor

Font Sets the font of the text editor and refinement protocol window.

6.3. Graphs

Use AntiAliasing for Graphs (slow!) Uses anti aliasing to draw the plots. If checked, lines look
smoother but also wider. Drawing will be slower if checked.
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Show characteristic Tungsten lines with spectral line cursor When using the spectral line cursor
(5.3), additional lines will be shown for characteristig Tungsten radiation (WLα1 and WLβ1).
This allows to inspect the diffraction pattern for Tungsten contamination lines caused by
aging X-ray tubes.

Show major grid lines Show or hide vertical and horizontal grid lines at the positions of major
tick marks. Major grid lines will be drawn as medium dashed lines.

Show minor grid lines Show or hide vertical and horizontal grid lines at the positions of minor
tick marks. Minor grid lines will be drawn as light dotted lines.

Display Line Width Width in pixels of all lines (plots, axes, tick marks) of the graph on computer
screens.

Printing Line Width Width in points of all lines (plots, axes, tick marks) of the graph on printouts.
This value should usually be greater than the display line width.

Symbol Size Size of the measured data points when not using solid lines (e. g. dots or crosses) in
pixels.

Y-axis Scaling Scaling of the y-axis. Options are linear, logarithmic with a base of 10 (log10), or
square root (sqrt).

Y-axis unit Shows the y-axis unit either in counts, or in counts per second (cps). Counts per
second may not be available, depending on the file format of the loaded scan. If the time per
step is not available, Profex will fall back to the unit ,,Counts” and assume a counting time
of 1 second per step.

Only the display of scans will be affected by the choice of the unit. Internally, all calcula-
tions and file format conversions will be performed in ,,Counts”. As a consequence, when
converting a format supporting ,,Counts per second” (such as XRDML) to a format not sup-
porting it (such as ASCII XY), the displayed unit may change from [cps] to [counts].

Multi-Scan Files Select whether multi-range files will be shown as individual scans, as the sum
of all ranges, or as the average of all ranges.

Create Thumbnail If checked, a thumbnail picture of the refined plot will be created at
the end of the refinement. This file is stored in the project directory with the name
project-basename tn.png. It allows easy browsing of refined projects. The width
of the picture can be specified in pixels. The height is calculated from the displayed aspect
ratio.

6.3.1. Fonts

Font Title Select the font of the file name at the top-right of the graph.

Font Axis Labels Select the font of the graph axis labels.

Font Tick Marks Select the font of the graph tick marks.
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Font Legend Select the font of the graph legend.

6.3.2. Scan Styles

Color Customize the list of colors to be used to draw scans by double-clicking on the color cell. If
more scans are loaded than colors are available from the list, a random color will be created
and added to the list. It can be changed manually later. Line widths can be changed on the
Graph’s General Appearance page.

Point Style Select the style to draw scans. ,,Solid” draws the scan as a solid line. ,,Points” draws a
dot at the measured position, ,,Cross” draws a cross at the measured position. Symbol sizes
of crosses and points can be changed on the Graph’s General Appearance page.

+ Add another color to the color list.

− Remove the currently selected color from the list.

6.4. BGMN

BGMN Executable Selects the BGMN executable file. This file is part of the BGMN installation. It
is called BGMN.EXE on Windows, and bgmn on Mac OS X and Linux.

MakeGEQ Executable Selects the MakeGEQ executable file. This file is part of the BGMN instal-
lation. It is called MakeGEQ.EXE on Windows, and makegeq on Mac OS X and Linux.

Geomet Executable Selects the Geomet executable file. This file is part of the BGMN installation.
It is called GEOMET.EXE on Windows, and geomet on Mac OS X and Linux.

Output Executable Selects the Output executable file. This file is part of the BGMN installation.
It is called OUTPUT.EXE on Windows, and output on Mac OS X and Linux.

Verzerr Executable Selects the Verzerr executable file. This file is part of the BGMN installation.
It is called VERZERR.EXE on Windows, and verzerr on Mac OS X and Linux.

Gertest Executable Selects the Gertest executable file. This file is part of the BGMN installation.
It is called GERTEST.EXE on Windows, and gertest on Mac OS X and Linux.

Run in WINE This box is only available on Linux and Mac OS X. It allows to use the Windows
version of BGMN to be run in WINE. Check this option if the executable files specified
above belong to the Windows version of BGMN.

Structure Files Directory Specifies the location where BGMN structure files (*.str) are stored. Sev-
eral directories can be entered. Sub-directories will be scanned for *.str files, too. This allows
to use a shared network structure repository and a local personal one simultaneously.

Device Files Directory Specifies the location where BGMN instrument files (*.sav, *.ger, *.geq,
*.tpl) are stored.
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Presets Directory Specifies the location where refinement preset files (*.pfp) are stored. See sec-
tion 7.2 for more information on presets.

Convert raw scans to XY format If checked, raw scan files will be converted to ASCII XY free
format (*.xy) prior to starting the refinement.

This option must only be disabled if the raw file format is directly supported by the BGMN
backend (e. g. *.val, *.rd).

Manage phase quantification GOALs If this option is checked, a GOAL to compute relative phase
quantities will be added automatically if a new phase is added from the ,,Add / Remove
Phase” dialog. Example: Adding a new structure ,,vaterite.str” to a control file with the
following phase content:

STRUC[1]=calcite.str
STRUC[2]=aragonite.str
...
sum=calcite+aragonite
GOAL[1]=calcite/sum
GOAL[2]=aragonite/sum

If this option is checked, the control file will be modified as follows:

STRUC[1]=calcite.str
STRUC[2]=aragonite.str
STRUC[3]=vaterite.str
...
sum=calcite+aragonite+vaterite
GOAL[1]=calcite/sum
GOAL[2]=aragonite/sum
GOAL[3]=vaterite/sum

The GOAL section will be completely rewritten each time a phase is added or removed. Any
customizations (e. g. quantifications with internal standards) will be erased.

If this option is not checked, the file will be modified as follows:

STRUC[1]=calcite.str
STRUC[2]=aragonite.str
STRUC[3]=vaterite.str
...
sum=calcite+aragonite
GOAL[1]=calcite/sum
GOAL[2]=aragonite/sum

Note that in the second case, no GOALs will be modified. Any customizations will be pre-
served, but the GOAL computation for the newly added or removed phase must be updated
manually.
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6.4.1. STR File Handling

Custom Profile Function

Use custom profile function Check this option if Profex should automatically change the profile
parameters of BGMN Structure files (*.str). The files will be modified when they are copied
from the structure database to the project directory by calling ,,Edit→ Add Phase. . . ”. If this
option is disabled, the profile parameters will not be changed.

Profile Function (RP) Specify the RP=n parameter.

Scaling (GEWICHT) Specify the GEWICHT parameter. Choose SPHARn for refinement of preferred
orientation, or ISOTROPIC for untextured samples.

Lorenzian Size Broadening (B1) Specify B1, enter ANISO for anisotropic crystallite sizes. Check
,,refine” to refine this parameter.

Gaussian Size Broadening (k1) Specify k1. Check ,,refine” to refine this parameter.

Micro Strain (k2) Specify k2, enter ANISO4 for anisotropic micro-strain. Check ,,refine” to refine
this parameter.

GOALs

Add Default Goals Check this option if a set of default goals is to be added to each copied BGMN
Structure file (*.str). Specify the goals in the text field below. Example:
GrainSize(1,1,1) //

Micro-Absorption Correction

Add Correction for Micro-Absorption Check this option if a correction for micro-absorption
(Brindlay correction) shall be added to each copied structure file.

Default Function If checked, the correction formula is hard coded to a default function.

Custom Function Check this line and enter a custom correction function if a correction formula
other than the default one shall be used.

6.4.2. CIF and XML File Handling

CIF to STR Conversion

Upper and Lower Limits for Cell Parameters Specifies the range for upper and lower limits of
unit cell parameters to be added automatically to BGMN Structure files (*.str) created from
CIF or ICDD XML structure files.
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6.4.3. Summary Table

Global Parameters and GOALs

List EPS values in summary table If checked, refined EPSn will be shown in the summary table
for global parameters and GOALs. Else EPSn parameters will be skipped.

Show warnings for values below detection and quantification limit If activated, Profex will
show a warning for phase quantities getting small relative to their ESD. For example, if
the limit of quantification (LOQ) is defined as 0.25, the relative standard deviation ESD /
value must be smaller than 25 %, or, in other words, the refined value must be greater than
4 · its ESD. Else a warning ,,¡ LOQ” will be shown in the summary table. See section 10 for
more information.

Limit of quantification (LOQ): ESD / Value = Defines the threshold for ,,< LOQ” (below limit of
quantification) warnings. Typical values are 0.25 if the refined value must be at least four
times its ESD in order to be quantifiable, or 0.10 if it must be at least 10 times greater than its
ESD. This variable can also be set in the control file (*.sav), see section 11. Values read from
the control file override values specifiec in the preferences dialog. See section 10 for more
information.

Limit of detection (LOD): ESD / Value = Defines the threshold for ,,< LOD” (below limit of detec-
tion) warnings. Typical values are 0.50 if the refined value must be at least twice its ESD
in order to be detectable, or 0.33 if it must be at least three times greater than its ESD. This
variable can also be set in the control file (*.sav), see section 11. Values read from the control
file override values specifiec in the preferences dialog. See section 10 for more information.

Minimum ESD (ignore ESDs below) = For phase quantities approaching 0.0, the ESD also ap-
proaches 0.0. Such phases appear to be detectable and quantifiable even at infintesimally
small quantities, but in fact it is an artifact of the ESD computation. In order to avoid this,
a minimum ESD can be specified here. Refined ESDs below this value will be ignored and
hard set to the minimum ESD. Typical values are 0.05 wt-%. Set this value to 0.00 to use all
refined ESD values, regardless of how small they are. See section 10 for more information.

Local Parameters and GOALs

Listed GOALs Enter the parameters to be read from the local parameters and goals section in the
BGMN list file (*.lst) and shown in the summary table for local parameters and goals. Enter
one parameter per line. The parameters must be written exactly as in the list file, including
case sensitivity.

Reset Pressing this button erases the text field with parameters and inserts a default set of pa-
rameters.
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6.5. Fullprof

Fullprof Executable Specifies the path to the Fullprof executable fp2k.exe.

Structure files directory Specifies the location of the directory with structure template files.

Device files directory Specifies the location of the directory with device template files.

Stop on convergence Normally Fullprof aborts the refinement when convergence criteria are
reached. Checking this option forces Fullprof to always perform the number of refinement
cycles specified with the parameter Ncy.

Divergence slit angle As Fullprof expects all scans to be measured with a fixed divergence slit
setting, Profex will attempt to convert scans measured with automatic or variable divergence
slit. The slit opening in degreees specified here is the opening the scans will be converted to.
A value less than 1.0 degree is recommended.

6.6. Reference Structures

Automatically select best matching reference phase When opening a graph file, automatically
search and select the reference phase with it’s strongest peak at the position of the scan’s
highest intensity. This is the same as double clicking at the strongest peak just after loading
the scan file. Note that only indexed reference structures will be considered.

Automatically index new structure files If checked, Profex will scan the structure file directory
for new structure files each time Profex is started and the first project is loaded.

If not checked, new structures will be indexed the first time they are selected in the Reference
Structures box.

Structures will not be available for double-click phase identification as long as they have not
been indexed.

Color of Reference hkl Lines Color of the hkl lines when selecting a reference structure from the
Reference Structures box.

Clear hkl index buffer Clears the buffer file with structure file hkl indices. Profex must be
restarted for this to take effect. All structure files will be re-indexed either automatically,
or when selected from the Reference Structures box.

hkl reference line range Specifies the lower and upper 2θ angle for hkl indices to be calculated.
Larger ranges will require more time to index. The range may be smaller or larger than scan
file ranges.
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6.7. Chemistry

The chemical composition page allows to edit the oxide forms and their molecular weights used
to calculate the elemental composition of the sample. Elements with empty molecular weight,
or with molecular weight of 0.0 g/mol, will be ignored. It is recommended to leave the oxide
and molecular weight cells of oxygen (element No. 8) empty to suppress display of oxygen as a
separate element in the chemistry results table.

A dialog to easily select the oxide form and automatically calculate the corresponding molecular
weight can be opened by double-clicking on the element symbol (left column).

Double-clicking an oxide cell (middle column) or molecular weight cell (right column) allows to
enter oxide names and molecular weights directly by bypassing the dialog mentioned above.

Element, Oxide, and Molecular Weight table This table holds the oxide formula and oxide molec-
ular weight for each element. Edit the values by double clicking a cell. Double clicking an
element cell will open a dialog to determine oxides and their molecular weight. Double
clicking any other cell allows direct input of oxide formulas and values.

Reset Resets the table to the internal default values. All customizations will be lost.
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7. Adding and Removing Structure Files

One of Profex’ central components is the ,,Add / Remove Phase” dialog (Fig. 10). It is accessed
by clicking ,,Project→ Add / Remove Phase. . . ”, or pressing F8 or the corresponding button on
the project tool bar. This dialog is used to easily create or modify the refinement control file.
It will automatically add a STRUC[n] reference and related GOALs for phase quantification to
the control file, and copy the selected STR files from the structure file database to the working
directory (Fig. 5). The individual elements of this dialog are described in detail below.

Generate default control file: If this option is checked, Profex will generate a default control file
for the selected instrument configuration. If a template file is found (section 3.4), it will be
used to create the control file. Else Profex will present a dialog asking for basic information
about the instrument configuration. If the option is active, an existing control file will be
overwritten. The default state of this option depends on the presence of a previous control
file:

• If a control file was found, this function will be unchecked. Manually activating the
option will overwrite the existing control file with a newly created default file.

• If no control file was found, this function will be active.

Instrument configurations: This dropdown menu lists all instrument configurations found in the
device database directory (section 3.4).

Structures: This list shows all structure files found in the structure file database directories (sec-
tion 3.4). Files stored in a sub-directory will be shown in a tree structure that can be collapsed
or expanded. Clicking on the header of the table (,,File Name”, ,,Phase”, or ,,Comment”) will
sort the table in ascending or descending order of the clicked column. Structures selected
in the first column will be added to the control file. If a reference structure is shown on the
main graph, it will be pre-selected in this dialog.

Expand/Collapse: If structure files are organized in sub-directories in the structure database di-
rectory, they will be organized in a tree structure in this dialog. Clicking ,,Expand/Collapse”
will expand or collapse all items in the tree structure for easy navigation.

Overwrite existing files: If a selected structure file is already present in the project directory, it
will normally not be overwritten. This preserves customized files. Checking this option will
force overwriting of existing files. Use this option with care, as other projects accessing the
same structure files will be affected, too.

Remove Phases: The phases listed here are currently referenced in the control file. Check the
ones that shall be removed from the refinement.

Delete Files: If this option is checked, the removed file will also be deleted from the hard disk
in the project directory. This may cause problems with other projects residing in the same
directory and referencing the same structure file. It is recommended to use this option with
care.
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If the control file contains multiple references to the same structure file, only the first occur-
rence will be removed. In that case, the option ,,Delete STR Files” will be ignored until the
last reference to this file was removed from the control file.

Note that only copies of structure files in the local project directory will be deleted. The
structure file database directory will remain unchanged.

The ,,Add / Remove Phase” dialog will not allow to add the same phase more than once to a
control file. If a selected file is already referenced in the control file, it will just be skipped by the
dialog. If multiple entries of the same structure file are requested, the control file will have to be
modified by hand.

Figure 10: The ,,Add / Remove Phase” dialog showing all instrument configuration files (top),
structure files found in the database directories, and structure files currently referenced
in the control file.

7.1. Project organization

When working with several datasets (= projects) at a time, it is important to understand how Pro-
fex’ ,,Add / Remove Phase” function handles structure and instrument files in the background.

By default the ,,Add / Remove Phase” dialog will copy selected structure and instrument files to
the location of the currently loaded scan file as shown in Fig. 10. It will check whether a file with
the same name is already present. If yes, the present file will not be overwritten, unless the option
,,overwrite existing files” was activated for structure files, and ,,generate default control file” was
activated manually for instrument files.
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Since several raw scan files can be located in the same directory, a structure file will only be present
once, even if it was added multiple times for each project. Modifying, removing, or overwriting
this structure file will affect all projects within this directory (Fig. 11).

If common structure files are not desired, there are several options to avoid shared access by
multiple projects:

• Distribute the raw scans on several sub-directories, as shown in Fig. 11. The ,,Add / Remove
Phase” dialog will have to be called for each project separately, but each project will receive
it’s own copy of the instrument and structure files.

• Manually manage the structure files. E. g. create a copy of structure 1.str and name
it structure 1a.str. Then change the STRUC[1]=structure 1.str line in the corre-
sponding control file to STRUC[1]=structure 1a.str.

• Manually manage structure files by creating sub-directories for structure files only.
E. g. create a copy of structure 1.str in strFiles 1/structure 1.str. Then
change the STRUC[1]=structure 1.str line in the corresponding control file to
STRUC[1]=strFiles 1/structure 1.str. The project directory remains unchanged,
but it will access the structure files in a specific sub-directory, which can be managed
manually for each project.

7.2. ,,Refinement Preset”

For routine analyses or refinements of series of measurements it is often recommended to use
exactly the same structure files and refinement strategy. Instead of using the ,,Add Phase” dialog
each time to select the device configuration and structure files, this information can also be loaded
from a refinement preset file. A preset thus automates the choice of device configuration and
structure files, and reduces the user input to a single mouse click.

Preset files store their data in XML format. Their storage location can be configured in ,,Edit →
Preferences. . .→ BGMN→ Configuration→ Presets directory”, as described in section 3.4. When
opened in a text editor, the file must have the following structure:

<?xml version="1.0" encoding="UTF-8"?>
<preset name="anyName">

<device>../Devices/myInstrument.geq</device>
<template>../Devices/myTemplate.tpl</template>
<structures>

<structure>../Structures/myPhaseA.str</structure>
<structure>../Structures/myPhaseB.str</structure>
<structure>../Structures/myPhaseC.str</structure>

</structures>
<other>

<textfile>description.txt</textfile>

46



Projects sharing structure files

working directory
scan 1.sav
scan 2.sav
structure 1.str
structure 2.str

scan 1.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

scan 2.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

Projects in sub-directories

working directory
dataset 1

scan 1.sav
structure 1.str
structure 2.str

dataset 2
scan 2.sav
structure 1.str
structure 2.str

scan 1.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

scan 2.sav:
STRUC[1]=structure 1.str
STRUC[2]=structure 2.str

Manually renamed structure files

working directory
scan 1.sav
scan 2.sav
structure 1a.str
structure 2a.str
structure 1b.str
structure 2b.str

scan 1.sav:
STRUC[1]=structure 1a.str
STRUC[2]=structure 2a.str

scan 2.sav:
STRUC[1]=structure 1b.str
STRUC[2]=structure 2b.str

Structure files in sub-directories

working directory
scan 1.sav
scan 2.sav
strFiles 1

structure 1.str
structure 2.str

strFiles 2
structure 1.str
structure 2.str

(a) File structure

scan 1.sav:
STRUC[1]=strFiles 1/structure 1.str
STRUC[2]=strFiles 1/structure 2.str

scan 2.sav:
STRUC[1]=strFiles 2/structure 1.str
STRUC[2]=strFiles 2/structure 2.str

(b) Control file content

Figure 11: Projects and structure files can be organized in different ways, depending on whether
structure and instrument files shall be shared or not.
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<textfile>some-other-text-file.txt</textfile>
<binaryfile>some-other-binary-file.jpg</binaryfile>

</other>
</preset>

Exactly one <device> and <template> node must be present. If one of them is missing, apply-
ing the preset will be refused. If more than one of these nodes is present, all but the first will be
ignored. An arbitrary number of <structure> and <other><file> nodes may be present. All
paths can either be absolute or relative to the location of the preset file. Device and template files
do not need to have the same file name. It is possible to use different template files with the same
device file.

Files specified in

<other>
<textfile>\dots</textfile>

</other>

and

<other>
<binaryfile>\dots</binaryfile>

</other>

tags will be copied to the project directory. These tags can be used for arbitrary files, such as
descriptions, background scans, raw data, report files etc. It is important to specify whether the
file is stored in text or binary format. For text format files Profex will convert the line endings
to the target platform to maintain platform independence. Binary files will be copied without
modification.

Note that custom profile functions (,,Edit→ Preferences. . .→ BGMN→ STR File Handling”) will
not be applied when using presets, as it would undermine the purpose of reproducing precisely
defined refinement scenarios.

7.2.1. Creating and using presets

Presets can be created from an existing refinement or manually. To create a preset from an existing
refinement, set up an example refinement. Add all phases, GOALs, custom calculations etc. and
modify the structure files as desired. Then select ,,Project → Save as Refinement Preset. . . ” and
save the file in the Preset directory specified in the Preferences dialog (section 3). The preset is
now ready to use. Note that write access to the Presets directory is required.
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Manually creating a Refinement Preset The following example for manual preset creation as-
sumes that the ,,Devices”, ,,Structures”, and ,,Presets” directories are stored at the same place,
for example inside a Profex-BGMN application bundle as described in section A. The goal of this
hypothetical example is to create a preset file for a standard refinement according to ISOxyz, to
quantify impurities of phaseB and phaseC in a sample of phaseA. Since only traces of impurities
are expected, no texture or peak broadening shall be refined in phaseB and phaseC. Additionally,
the angular range of the file measured from 5–60◦ 2θ shall be restricted to 10–60◦ 2θ. Instrument
configuration xpert-ads-10mm.geq will be used to measure the data, and a control file tem-
plate xpert-ads-10mm.tpl has already been created along with the instrument configuration
files.

1. Create a new directory ,,ISOxyz” in the ,,Presets” directory.

2. Copy the structure files phaseA.str, phaseB.str, and phaseC.str from the ,,Struc-
tures” to the ,,Presets/ISOxyz” directory.

3. Modify the phase*.str files to your needs; i. e. refine texture and peak broadening in
phaseA.str, but fix them in phaseB.str and phaseC.str.

4. Copy the instrument and template files xpert-ads-10mm.geq and xpert-ads-10mm.tpl
from the ,,Devices” to the ,,Presets/ISOxyz” directory.

5. Edit the template file xpert-ads-10mm.tpl to your needs by adding WMIN=10.

6. Create a new preset file in the ,,Presets/ISOxyz” directory with the following content:

<?xml version="1.0" encoding="UTF-8"?>
<preset name="ISOxyz">

<device>xpert-ads-10mm.geq</device>
<template>xpert-ads-10mm.tpl</template>
<structures>

<structure>phaseA.str</structure>
<structure>phaseB.str</structure>
<structure>phaseC.str</structure>

</structures>
</preset>

The preset is now ready for use. The following files should be present:

Presets
ISOxyz

ISOxyz.pfp
xpert-ads-10mm.geq
xpert-ads-10mm.tpl
phaseA.str
phaseB.str
phaseC.str
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It can be applied as follows:

1. Load your raw data using ,,File→ Open Graph File. . . ”.

2. Select ,,Project→ Refinement Presets→ ISOxyz” or use the button in the project toolbar to
create the control file.

3. Click ,,Run→ Run Refinement”.
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8. Exporting data

8.1. Graphs

Scans shown in the plot area can be exported to various formats. Depending on the export format,
some information may get lost if it is not supported by the output format. Scans can be exported
as follows:

1. Make sure the graph to be exported is shown by selecting the project and showing the
,,Graph” tab.

2. Select ,,File→ Save File As. . . ”.

3. Select the format for the export in the file format dropdown menu.

4. Specify the file name and save the file.

Profex exports some generic file formats, and some formats specific for other applications. The
generic formats are useful for most users interested in further data processing or creation of fig-
ures. They will be discussed in further detail in the following paragraphs.

8.1.1. ASCII free format (XY)

A generic text format writing the data in columns, starting with the angle, followed by columns
with intensities for each scan. These files can be imported in spreadsheet or plotting software for
further processing. Spreadsheet software includes Microsoft Excel, LibreOffice Calc, SoftMaker
PlanMaker, and others. Plotting software includes OriginLab Origin, GNUplot, and others.

hkl lines will not be exported. Scan colors, line styles, and the legend will also get lost during the
export. Visibilities of scans will be ignored, all scans will be exported. A white space character is
used for field separation.

The following example shows an exported ASCII free format file with all scans written into one
file. The first column contains the x-values (2θ angle), the following columns contain y-values Iobs,
Icalc, Idi f f , Ibackground, and two phase patterns. Note that the phase patterns include the background
intensity:

4.007500 22.000000 21.070000 0.930000 21.050000 21.050000 21.070000
4.022500 19.000000 20.910000 -1.910000 20.890000 20.890000 20.910000
4.037500 20.000000 20.760000 -0.760000 20.740000 20.740000 20.760000
4.052500 22.000000 20.610000 1.390000 20.590000 20.590000 20.610000
4.067500 24.000000 20.470000 3.530000 20.450000 20.450000 20.470000
4.082500 13.000000 20.330000 -7.330000 20.310000 20.310000 20.330000
...
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8.1.2. ASCII HKL List (HKL)

If the graph contains hkl tick lines, the data will be written to a text file. The output file starts with
a header line, followed by hkl tick mark information of all phases. Note that the lines are sorted
by phase number, not by 2θ angle. An example of an ASCII HKL list file is shown below:

"Phase Name" "Angle" "Phase No." "HKL" "Texture"
"Adularia" 22.501230 0 "0 2 1" 1.263500
"Adularia" 24.476712 0 "2 0 -1" 0.915900
"Adularia" 26.213459 0 "1 1 1" 1.328900
...
"Calcite" 26.835628 1 "1 -1 2" 0.968500
"Calcite" 34.275930 1 "1 -1 -4" 1.053900
"Calcite" 36.669943 1 "0 0 6" 1.049000
...
"Plagioclase_Albite" 22.106786 2 "0 2 -1" 1.174800
"Plagioclase_Albite" 23.578835 2 "0 2 1" 1.363700
"Plagioclase_Albite" 25.646178 2 "2 0 -1" 0.723100
...
"Quartz" 24.264737 3 "1 -1 0" 1.029900
"Quartz" 31.030320 3 "1 -1 1" 1.037600
"Quartz" 31.030320 3 "1 -1 -1" 0.970300
...
"Zincite" 37.055257 4 "1 -1 0" 1.000000
"Zincite" 40.184602 4 "0 0 2" 1.000000
"Zincite" 40.184602 4 "0 0 -2" 1.000000
...

8.1.3. Pixel image (PNG)

Pixel image export will write the file to a Portable Network Graphics (PNG) image. A dialog will
open to ask for the output size in pixels. PNG uses lossless compression, therefore relatively small
files free of compression artifacts will be created.

If the line width or font size is too small, it will have to be changed prior to the export in the graph
preferences (see section 6.3). Use ,,display line width” to change the export line width.

All elements visible on screen will be exported, including hkl lines and the legend. Visibility of
the scans will be considered, invisible scans will also be invisible on the exported file. The export
will create a high-resolution image of the on-screen graph.

Pixel images can be edited in any photo editing software, such as Adobe Photoshop, GIMP,
Paintshop Pro, Corel PhotoPaint, and others.
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8.1.4. Gnuplot (GPL)

Gnuplot [12] is a powerful cross-platform graphing utility able to create quality graphs in various
formats. Scans exported as Gnuplot files are saved as Gnuplot scripts with inline data. The graphs
are a fairly accurate but not perfectly identical representation of the plot as displayed in Profex. It
includes hkl indices, a legend, all selected scans, and it preserves scan colors and symbol styles.
The output file may be edited to optimize the appearance of the Gnuplot graph or to change the
output terminal. Gnuplot code created by Profex version 3.8.0 was tested with Gnuplot versions
4.6 and 5.0.

On a system with a working Gnuplot installation, the following command entered in a terminal
emulator will output the graph ,,scan.gpl” to the default terminal:

gnuplot −p scan . gpl

8.1.5. Grace plots (AGR)

The displayed graph is exported to a file for the Grace plotting program [13]. All colors and hkl
tick marks are preserved. Grace is described on wikipedia as follows:

Grace is a free WYSIWYG 2D graph plotting tool, for Unix-like operating systems.
The package name stands for ,,GRaphing, Advanced Computation and Exploration
of data.” Grace uses the X Window System and Motif for its GUI. It has been ported
to VMS, OS/2, and Windows 9*/NT/2000/XP (on Cygwin). In 1996, Linux Journal
described Xmgr (an early name for Grace) as one of the two most prominent graphing
packages for Linux.

8.1.6. Scalable vector graphics (SVG)

Scalable vector graphics (SVG) is a resolution-independent vector graphics format ideal for post-
processing of graphs. All elements (scans, axes, hkl lines, text) are exported as editable paths or
text elements, allowing to change fonts, sizes, places, colors, line widths, or add annotations easily
in the exported file. It is the most powerful and flexible of all export formats to create high-quality
figures. However, it is necessary to use vector drawing software and convert the format before
importing into a word processor, as most programs, including Microsoft Word, LibreOffice Writer,
SoftMaker TextMaker, and LATEX, do not import SVG files directly.

All modern webbrowsers are capable of viewing SVG files natively. SVG files can therefore be
viewed and printed easily on all operating systems without requiring any additional software.
In order to edit the files, a vector drawing program such as Adobe Illustrator, Inkscape, Corel
DRAW, or others is necessary. Note that not all vector drawing programs interpret SVG files
correctly. Wrong SVG drawing may need manual optimization.

The recommended workflow to add a scan to a manuscript in high quality is the following:
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1. Exort the scan to SVG as described above.

2. Open or import the SVG file in a vector drawing program of your choice.

3. Make sure the SVG file looks as expected. Modify if necessary.

4. Select the entire plot and copy to the clipboard.

5. Special-paste it into the word processor or presentation program, for example as an extended
metafile.

8.1.7. Fityk Session (FIT)

Fityk scripts can be opened directly with the program Fityk [14], version 0.9.8 or later. This export
filter was specifically designed for phase quantification of calcium phosphate phases for medical
devices according to the standard procedure described in ASTM F2024-10. It may not be of much
use for anyone not performing this specific analysis.

The Fityk Session export offers several different export modes. ,,Entire File” will write the entire
measured range to a script. All other modes are described in more detail:

Corundum (104) peak: This export mode is to be used with the corundum reference data set. It
will export the range from 34.0 to 36.2◦ 2θ around the corundum (1 0 4) peak. Running the
script in Fityk will fit a linear function to the background signal. Afterwards, it will integrate
the intensities Iobs − Ibackground from 34.4 to 35.9◦ and print the result. This is the corundum
reference intensity to be used for ASTM F2024-10.

b-TCP range: This mode, which is to be used with the CaP data set, will export the range from
27.0 to 35.0◦ 2θ. Running the script in Fityk will fit a linear function to the background and
PearsonVII functions to all peaks except β-TCP (0 2 10), and then integrate the difference be-
tween all fitted curves and the observed curve from 30.5 to 31.5◦ 2θ. This integrated intensity
will be used to quantify β-TCP in the sample.

CaO range: This mode will export the range from 36.0 to 38.8◦ 2θ. Running the script in Fityk
will fit a linear function to the background, and integrate the difference Iobs− Ibackground from
37.0 to 38.5◦ 2θ. This integrated intensity will be used to quantify CaO.

HA range: This mode will export the range from 37.5 to 59.5◦ 2θ. Running the script in Fityk will
fit a linear function to the background and integrate the intensities Iobs − Ibackground in the
range from 38.5 to 59.0◦ 2θ to quantify hydroxyapatite.

All CaP ranges to separate files: This mode will export all three ranges (β-TCP, CaO, HA) ana-
lyzed with the CaP sample to separate files.
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8.2. Printing to PDF

On most operating systems a PDF printer is available. It allows direct export of the graph to a
PDF file. Prepare the graph as described at the beginning of this section, but use ,,File→ Print. . . ”
instead of the save as function. Use the printer dialog to write the output to a PDF file. The layout
and functions are platform specific.

If line widths are too fine or too wide, change the printing line width in the preferences, as de-
scribed in section 6.3. PDF files can be used directly in LATEX. Other word processors may need
the same conversion as described for SVG files.

8.3. Refinement results

8.3.1. CSV tables

At the end of a refinement, Profex shows a summary of global parameters and GOALs, as well
as refined local parameters, in the summary dockable windows. These values are read from the
LST output file. Local parameters can be customized in the preferences as described in section
6.4.3. Profex allows to easily export the global and local refined parameters of all open projects
into spreadsheet files:

,,Results→ Export Global Paramters and GOALs” will write the global parameters and goals of
all open projects to a CSV file.

,,Results→ Export Local Paramters” will write the local parameters of all open projects to a CSV
file.

,,Results→ Export Chemistry” will export the chemical composition (see section 9) to a CSV file.

The exported files are text files containing semicolon-separated fields. Open the file in a spread-
sheet program and specify the semicolon character as a field separator. Since the exported files
also contain the source file name, using the spreadsheet program’s sorting function allows easy
sorting and statistical evaluation of the results. The following example shows how the exported
CSV file with global parameters and goals looks like if opened in a text editor. Table 2 shows how
the same data looks after importing and sorting in a spreadsheet program.

File;Sample;Parameter / Goal;Value;ESD
<path>/scan1.lst;scan1;alphaTCP/sum;0.0311;0.0023
<path>/scan1.lst;scan1;hap/sum;0.9689;0.0023
<path>/scan2.lst;scan2;alphaTCP/sum;0.0161;0.0022
<path>/scan2.lst;scan2;hap/sum;0.9839;0.0022
<path>/scan3.lst;scan3;alphaTCP/sum;0.0147;0.0024
<path>/scan3.lst;scan3;hap/sum;0.9853;0.0024
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Table 2: Global parameters and GOALS exported from Profex and sorted by the ,,Paramter / Goal”
column. Sorted like this, mean values and standard deviations can easily be calculated.

File Sample Parameter / Goal Value ESD

<path>/scan1.lst scan1 alphaTCP/sum 0.0311 0.0023
<path>/scan2.lst scan2 alphaTCP/sum 0.0161 0.0022
<path>/scan3.lst scan3 alphaTCP/sum 0.0147 0.0024
<path>/scan1.lst scan1 hap/sum 0.9689 0.0023
<path>/scan2.lst scan2 hap/sum 0.9839 0.0022
<path>/scan3.lst scan3 hap/sum 0.9853 0.0024

(a)

(b)

Figure 12: Chemical composition of the sample. Quantity goals must be selected by the user. If no
quantity goals were selected (a), each phase will be normalized to 100 %. If the goals
describing the phases’ quantities were assigned (b), the total bulk composition of the
sample will be calculated, too.
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9. Chemical composition

After the refinement, Profex will calculate the bulk chemical composition of the sample from the
structural information and refined site occupancies reported in the list file (*.lst). The elemen-
tal composition, expressed in wt-% of the oxide, is shown in the ,,Chemistry” dockable widget
(Fig. 12). In a first step, Profex will calculate the chemical composition of each phase, and nor-
malize it to 100 % (Fig. 12a). In order to calculate the bulk composition of the entire sample, Profex
needs to know the relative quantity of each phase, which is normally calculated as a global goal.
Profex will attempt to identify the correct ,,Quantity Goal” by comparing global goal names with
the phase name. If a goal name of format phase name/some string is found, with phase name
matching the phases PHASE variable (case insensitive), the goal will be automatically selected.
Else no ,,Quantity Goal” will be selected and the user will have to select it manually.

As an example, the following ,,Quantity Goal” will be recognized and assigned automatically,
because the phase name and goal name match (matching is case insensitive):

STR file: PHASE=Corundum
GOAL:corundum=GEWICHT

SAV file: GOAL[1]=corundum/sum

But the following ,,Quantity Goal” will not be recognized automatically, because the phase name
and goal name do not match. The user will have to select it manually:

STR file: PHASE=Corundum
GOAL:Al2O3=GEWICHT

SAV file: GOAL[1]=Al2O3/sum

Once a valid ,,Quantity Goal” has been selected for a phase, the element composition will be
normalized to the phase’s quantity. The total chemical composition will be calculated only when
all phases were assigned a valid ,,Quantity Goal” (Fig. 12b).

The oxides and their molecular weights used to calculate the composition can be accessed and
customized in the preferences by calling ,,Edit → Preferences. . .→ Chemistry” (Fig. 13a). Ele-
ments without molecular weight value, or with a value of 0.0, will be ignored for the calculation.
It is recommended to leave the molecular weight of oxygen (element No. 8) empty or at 0.0 to
avoid listing oxygen as a separate element in the chemistry output table. See section 6.7 for more
information on customizing the oxide parameters.

Select ,,Project→ Export Chemistry. . . ” to export the data to a csv file.
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(a)

(b)

Figure 13: Oxides and molecular weights can be customized in the preferences dialog (a). Double
click on a ,,Element” cell in the oxide table to open a dialog for calculation of oxide
molecular weights (b).

10. Limits of Quantification and Detection

The counting noise inherently superimposing the diffraction peaks in a powder XRD pattern lim-
its the accuracy of phase quantifications. Even if a single specimen is measured multiple times
and variations introduced by sample preparation or sample inhomogeneities are guaranteed to
be absent, the random noise pattern will lead to a certain variation of the refined phase quanti-
ties. The results are Gauss-distributed around the true value. The standard deviation is largely
independent on the phase quantity, it rather depends on the counting noise amplitude, which it-
self strongly depends on the background intensity. As a result, phase quantities close to 0.0 still
show a standard deviation similar to greater quantities. An example is given in Table 3, which
shows mean quantities and ESDs of reference mixtures measured 10 times. Once the contamina-
tion phases fall below 5 wt-%, their ESDs are surprisingly constant, even if the phases are entirely
absent. As the phase quantities approach 0.0, but the ESDs remain constant, the relative standard
deviation (RSD) gets larger. The relative standard deviation is defined as

RSD =
ESD

Quantity
[%]

Assume we prepare reference mixtures with 5, 2, 1, 0.5, 0.2, and 0.0 wt-% of a contamination phase,
and the ESD of the refined quantities is constant at 0.2 wt-%. As a result, we observe the following
RSDs:
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Quantity [wt-%] ESD [wt-%] RSD [%]

5.0 0.2 4.0
2.0 0.2 10.0
1.0 0.2 20.0
0.5 0.2 40.0
0.2 0.2 100.0
0.0 0.2 ∞

For small quantities the scattering of the values becomes excessively large compared to the mean
value, which is expressed by huge RSDs. In other words, the refined quantity becomes unreliable.
Many textbooks, guidelines and standards define the limits of quantification and detection (LOQ
and LOD) as a relative standard deviation. For example, they specify that for quantification the
mean value must be at least 4 times greater than its standard deviation, or the standard deviation
must be less than one quarter of the value (RSD ≤ 25%). And for detection, the mean value must
be at least 2 times greater than its standard deviation, or the standard deviation must be less than
half the value (RSD ≤ 50%). The actual limits might depend on the source of the information.

The example in Table 3 also shows that, with the exception of phase C, none of the contamination
phases reach 0.0 wt-% in the sample absolutely free of contaminations (bottom line). Once the
peak intensities drown in the counting noise, the refinement algorithm will be able to fit positive
intensities into the noise pattern. This has some undesired side effects: These residual intensities,
even when reported as ,,not detected”, reduce the quantity of the main phase, as long as they are
taken into the normalization of phase quantities to 100 %. In Table 3 the quantity of phase A is
reduced to 99.10 wt-% due to accumulated residual intensities, even though no contaminations
were present. In order to avoid this problem, which can become even more pronounced if more
non-existent phases are added to the refinement, it is recommended to remove phases below the
detection limit from the project and repeat the refinement. This process should be repeated until
none of the refined phases is below the detection limit. Profex’ facilitates this strategy by high-
lighting phases below the detection and quantification limits and by showing a warning in the
summary table. The feature has to be enabled in the preferences dialog (Edit→ Preferences. . .→
BGMN → Summary Tables → ,,Show warnings for values below detection and quantification
limit”). In the same dialog the relative standard deviations (RSD) used as limits of quantification
and detection can be defined. In the example shown in Figure 14 the limit of quantification is
reached when the refined quantity falls below 8 times its ESD (RSD ≥ 12.5 %), and the limit of
detection is reached when it falls below 4 times its ESD (RSD ≥ 25 %).

Some phases actually converge towards 0.0 wt-% despite a considerable noise pattern. In that
case the ESD may reach 0.0 wt-%, too. However, this is an artifact of the refinement algorithm
and its error propagation, as there cannot be an absolute certainty of absence of a particular phase
as long as there is noise superimposing the diffraction signal. After all, there always might be a
signal hidden in the noise. If the ESD reaches 0.0, the refined quantity might never fall below the
quantification and detection limit, as the ESD shrinks along with the value rather than remaining
constant, and the RSD may or may not exceed the LOQ or LOD at a certain point. In order to avoid
this undesired result, Profex allows to define a minimum ESD. Any refined ESD below this value
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will be considered to be an artifact, i. e. an unrealistically low ESD, and instead the minimum ESD
specified in the preferences dialog will be used. That way, a hard-coded minimum LOQ and LOD
is introduced. For example, the limit of detection in Figure 14 is defined as

LOD =
ESD
value

= 0.250

If we refine a phase quantity to 0.06 wt-% with an ESD of 0.01, its RSD is:

RSD =
0.01
0.06

= 0.167

The RSD does not exceed the LOD, therefore the phase quantity of 0.06 wt-% should be considered
detectable, Profex will not show the warning ,,< LOD”. However, it is quite obvious that a quan-
tity of 0.06 wt-% cannot be detected in most real datasets collected on conventional instruments
with standard settings. Also an ESD of 0.01 wt-% is impossible to achieve if there is counting
noise in the pattern. The low ESD must therefore be an artifact. Applying Profex’ minimum ESD
at 0.05 wt-% (which is a realistic choice), the equation changes as follows

RSD =
minESD

0.06
=

0.05
0.06

= 0.833

The RSD exceeds the LOD of 0.250 by far, and the quantity of 0.06 wt-% is flagged as ,,< LOD”. In
fact, any quantity below

minESD
LOD

=
0.05
0.250

= 0.20

will be flagged as ,,< LOD”, regardless of its refined ESD.

If the minimum ESD is set to 0.0, the feature is deactivated and all refined ESDs will be used as
read from the results file. This is not recommended. The minimum ESD should be set to a positive
value. The non-existent phases B and D in Table 3 that converged to a positive residual intensity
(bottom line) had residual ESDs of 0.06 and 0.14 wt-%. It is a reasonable guess to use a value just
below the residual ESDs of non-existent phases as a minimum ESD. In this example, 0.05 wt-%
seems to be a good choice.
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Figure 14: Warnings for quantities below LOQ and LOD can be activated in the preferences dialog.
Relative standard deviations (ESD/value) used as LOQ and LOD are also specified on
the same page.
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Table 3: Reference mixtures of 3 contamination phases (B, C, D) in a matrix (A). All values are given in wt-%.

Composition (A + B + C + D) Quantity A ESD A Quantity B ESD B Quantity C ESD C Quantity D ESD D

0.0 + 33.3 + 33.3 + 33.3 0.02 0.01 33.79 0.29 32.54 0.19 33.65 0.37
1.0 + 33.0 + 33.0 + 33.0 0.66 0.11 33.57 0.29 32.33 0.20 33.44 0.38
10.0 + 30.0 + 30.0 + 30.0 9.58 0.24 30.63 0.29 29.44 0.20 30.36 0.40
25.0 + 25.0 + 25.0 + 25.0 24.98 0.29 25.48 0.28 24.20 0.19 25.34 0.40
40.0 + 20.0 + 20.0 + 20.0 40.37 0.30 20.35 0.26 19.02 0.18 20.27 0.41
55.0 + 15.0 + 15.0 + 15.0 55.94 0.25 14.95 0.19 14.00 0.15 15.11 0.26
70.0 + 10.0 + 10.0 + 10.0 70.71 0.25 9.82 0.17 9.14 0.13 10.32 0.25
77.5 + 7.5 + 7.5 + 7.5 78.07 0.22 7.44 0.14 6.72 0.12 7.77 0.17
85.0 + 5.0 + 5.0 + 5.0 85.55 0.21 4.91 0.13 4.27 0.12 5.27 0.17
94.0 + 2.0 + 2.0 + 2.0 93.79 0.19 2.02 0.10 1.65 0.08 2.53 0.15
97.0 + 1.0 + 1.0 + 1.0 96.64 0.17 1.05 0.09 0.74 0.05 1.57 0.14
98.5 + 0.5 + 0.5 + 0.5 98.09 0.16 0.54 0.08 0.30 0.04 1.08 0.13
99.4 + 0.2 + 0.2 + 0.2 98.79 0.14 0.28 0.07 0.09 0.03 0.84 0.12
100.0 + 0.0 + 0.0 + 0.0 99.10 0.15 0.14 0.06 0.00 0.00 0.75 0.14
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11. Profex-specific Control File Variables

Profex reads some additional variables from BGMN control files (*.sav) that are not mandatory for
the BGMN refinement backend. Some of them are only parsed by Profex and ignored by BGMN,
and some of them are used for specific calculations of GOALs.

sum This variable is used to compute relative phase quantities normalized to 100 %. Normally
it holds the sum of the GEWICHT variables of all phases. If one phase is set as an internal
standard, the sum variable is used for the normalization to the internal standard quantity.
sum is automatically managed by Profex if phases are added, removed, or set and unset as
internal standard.

ISTD Holds the phase name of the internal standard phase. It is only present if an internal stan-
dard has been defined. It is added and removed by Profex if an internal standard is set or
unset.

ISTDQ Holds the phase quantity of the internal standard phase normalized to 1.0 (not to 100 %).
It is only present if an internal standard has been defined. It is added and removed by Profex
if an internal standard is set or unset.

LOQ Relative standard deviation (ESD / value) considered as the limit of quantification (LOQ).
This value will override the value set in the preferences dialog. It will only be parsed if the
option ,,Show warnings for values below detection and quantification limit” is set active in
the preferences dialog. If the ratio ESD / value of a refined phase quantity exceeds LOQ,
it will be highlighted in the summary table and a warning ,,< LOQ” will be shown. See
section 10 for more information.

LOD Relative standard deviation (ESD / value) considered as the limit of detection (LOD). This
value will override the value set in the preferences dialog. It will only be parsed if the
option ,,Show warnings for values below detection and quantification limit” is set active in
the preferences dialog. If the ratio ESD / value of a refined phase quantity exceeds LOD,
it will be highlighted in the summary table and a warning ,,< LOD” will be shown. See
section 10 for more information.

MINESD Sets the minimum ESD that is considered realistic for refined phase quantities. This vari-
able overrides the value set in the preferences dialog ,,Minimum ESD (ignore ESDs below)
=”. See section 10 for more information.
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12. Scan batch conversion

Several scan files can be converted to other data formats at a time using the ,,File → Scan batch
conversion. . . ” feature. However, due to limitations given by the formats, SVG and pixel images
(PNG) are not available for batch conversion.

When opening the batch conversion dialog by clicking ,,File→ Scan batch conversion. . . ”, the file
queue will contain all currently opened scan files by default. More files can be added by clicking
the ,,Add File” button and selecting one or more files, and selected files can be removed from the
queue by clicking the ,,Remove File” button.

Some output format support multiple scans stored in a single file. The option ,,Write scans to one
file” will instruct Profex to store all scans found in a source file into one single file. In that case, all
scans Iobs, Icalc, Idi f f , Ibackground, and all sub phase patterns found in a DIA file will be stored in a
single output file. Use ,,Write scans to individual files” to write these patterns into single output
files instead. Note that storing multiple scans in one file must be supported by the output format
as well as by Profex’ output filter, which is currently only the case for ASCII and Gnuplot files.

Click ,,Convert” to start the conversion process, or ,,Close” to close the dialog without conver-
sion. Output files will be stored at the location of their source files using the same base file name.
Existing output files will be overwritten without warning.
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13. CIF and ICDD XML import

Crystal structure files retrieved from online or commercial databases are usually supplied in the
CIF format [10] or in an XML file format if exported from the ICDD PDF-4+ database. Before
they can be used with BGMN, the structure information needs to be converted the the BGMN STR
file format. Profex provides support to facilitate the conversion process for both CIF and XML
formats. PDF-4+ XML files are usually complete and require very little user input. CIF files, on
the other hand, often lack important information and require manual revision. The import and
conversion process in Profex is identical to both CIF and XML formats. The following instructions
show how to convert a CIF file to a BGMN STR file using Profex’ CIF import feature.

1. Retrieve a CIF file from an external resource (online or local database).

2. Start Profex and choose ,,File→ Import CIF. . . ” to open the CIF file.

3. If no space group number was found in the CIF file, Profex will display a dialog to select
the number (Fig. 16a). Select the space group number of your structure. It has to be known
or determined from an external source. The field ,,Supported Settings” shows all Hermann
Mauguin symbols of the selected space group number. The correct number must contain a
symbol remotely similar to the symbol read from the CIF file. Due to the lack of standard-
ization, CIF and BGMN Hermann Mauguin symbols often look similar, but not identical.

4. If more than one space group setting is available, select the correct one from the dialog
shown in Fig. 16b. Again, the available Hermann Mauguin symbol often looks similar but
not identical to the one read from the CIF file.

5. The STR file will be created and shown in an editor (Fig. 17). Most likely the STR file is in-
complete due to information missing in the CIF file. Some warnings are issued in the dialog.
Check manually for complete information. Typically Wyckoff sequences and element types
are often missing.

The dialog also shows the original CIF file on a second tab. It may be useful to verify the STR
file or to retrieve more information if it was not extracted automatically. The XML file shown
on the third tab is the intermediate format used by Profex. It is only shown for debugging
purposes.

6. Once the STR file is complete, choose ,,Save STR” to save the file in the structure file database
directory.

Sometimes it is helpful to browse the space group numbers and symbols in the form supported by
BGMN. Open ,,Help→ BGMN SPACEGRP.DAT” to open a dialog which shows all space group
numbers, settings, and Wyckoff sequences in the nomenclature used by BGMN (Fig. 18).

The assignment CIF file tags to STR parameters is described in Table 4.
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(a) Space group number (b) Space group setting

Figure 16: Importing a CIF file: If no space group number is found in the CIF file, it has to be
entered manually in dialog (a). If more than one setting for the space group is available,
it has to be choosen manually from dialog (b).

13.1. Automatic conversion of thermal displacement parameters

During the conversion from CIF to STR format Profex automatically transforms the thermal dis-
placement parameters to the format supported by BGMN. Depending on the source format, the
following conversions are calculated (anisotropic βij values are not supported by the CIF for-
mat.):

Isotropic B: Isotropic B is the format supported by BGMN. However, BGMN uses a different
unit than normally provided in the CIF file. Automatic conversion therefore performs the
following conversion:

Biso[nm2] = 0.01 · Biso[Å2]

Anisotropic Bij: Anisotropic Bij are converted to isotropic B values in the expected unit [15]:

Biso[nm2] = 0.01 · 1
3 ∑

i
∑

j
Bija∗i a∗j Ai Aj

with reciprocal lattice parameters a∗[Å−1] and real lattice parameters A[Å].

Anisotropic Uij: Anisotropic Uij are converted to Uequiv using the expression [15]:

Uequiv =
1
3 ∑

i
∑

j
Uija∗i a∗j Ai Aj

with reciprocal lattice parameters a∗[Å−1] and real lattice parameters A[Å]. Uequiv is con-
verted to Biso by the following equation.

Isotropic Uequiv: Isotropic Uequiv values are converted to isotropic B:

Biso[nm2] = 0.01 · 8.0 · π2 ·Uequiv
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Figure 17: After importing a CIF file and adding all space group information, the STR file is dis-
played. It may still be incomplete. Check the warnings at the bottom of the dialog and
fix the STR file text manually. The CIF file is also shown in the second tab for compar-
isong. The XML file in the third tab is only used internally by Profex.

Figure 18: ,,Help→ BGMN SPACEGRP.DAT” opens a dialog to browse all space group numbers,
settings, and atomic positions.
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CIF File STR File

chemical name mineral PHASE=name
chemical name common PHASE=name
chemical name systematic PHASE=name
database code [a-z] Reference=name
chemical formula [a-z] Formula=name
symmetry Int Tables number SpacegroupNo=number
space group IT number SpacegroupNo=number
symmetry space group name H-M HermannMauguin=symbol
space group name H-M alt HermannMauguin=symbol
cell length a / b / c A= / B= / C=value
cell angle alpha / beta / gamma ALPHA= / BETA= / GAMMA=value
atom site label E=M±n(value)
atom site type symbol E=M±n(value)
atom site Wyckoff symbol Wyckoff=symbol
atom site occupancy E=M±n(value)
atom site fract x / y / z x= / y= / z=value
atom site B iso or equiv TDS=value
atom site U iso or equiv TDS=value
atom site aniso U [1-3] TDS=value
atom site aniso B [1-3] TDS=value

Table 4: Assignment of CIF parameter tags to BGMN STR variables.
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14. Instrument configurations

Raytraced geometric peak profiles must be calculated by BGMN prior to refinement. The instru-
ment configuration is described in a control file, and the two programs GEOMET and MAKEGEQ,
which are part of the BGMN software distribution, are used to calculate and interpolate the peak
profile in a specific 2θ range. For more information please refer to the BGMN documentation [1].

Profex allows editing instrument control files in a simple text editor, and runs GEOMET and
MAKEGEQ to generate the output files. A common workflow to modify an existing device con-
figuration is shown below.

1. Run Profex and click ,,Instrument→ Edit Configuration. . . ”. Profex will open a file dialog in
the Device database directory. Select the instrument control file (*.sav) you intend to modify.

2. The instrument dialog shown in Fig. 19 will be shown. Edit the file as intended.

3. Save the file under a new name using the dialog’s ,,Save As” button. Be sure to save it in a
directory with write access.

4. Check the options ,,Raytrace (GEOMET)” and ,,Interpolate (MakeGEQ)”. The option ,,Cal-
culate Profile (GERTEST)” is optional.

5. Check the option ,,Create Template for Refinement Control File” and select your tube’s target
material and the type of monochromator you use.

6. Click the ,,Run” button and wait until the progress dialog has completed. Depending on
hardware, simulated angular range, and device configuration, this process may take several
minutes to complete.

Once the process has completed, BGMN has created two new files (*.ger and *.geq), which are re-
quired for refinements. If they were created outside of the Device database directory, they should
be moved there in order to appear in the ,,Add Phase” dialog. It is also recommended to manually
create a template file for the new configuration, as described in section 3.4.3.

Using ,,Instrument→New Configuration. . . ” will allow to read some hardware information from
Bruker RAW V4, Bruker BRML V5, and PANalytical XRDML files to create a BGMN instrument
configuration file from scratch. Other raw data formats are not supported. Usually several vari-
able required by BGMN will still not be available from the raw data files and will thus have to be
entered manually.

The resulting theoretical peak shape computed by GERTEST and MakeGEQ can be displayed by
clicking ,,Instrument → Show Peak Shape. . . ”. In the dialog click the button ,,Load Instrument
Control File” at the bottom left and load your instrument *.sav file. After computing the peak
shape, the horizontal slider can be used to skip through the 2θ range and show the peak shape
(Fig. 20). Displayed peaks can be exported to various formats using the export buttons at the
bottom left.
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Figure 19: ,,Instrument → Edit Configuration. . . ” opens a dialog to edit an existing instrument
configuration.
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Figure 20: ,,Instrument→ Show Peak Shape. . . ” opens a dialog display the theoretical peak shape
computed for a specific instrument configuration.

15. Scan File Handling

In contrast to the BGMN Rietveld backend, which only supports a limited number of scan file for-
mats natively, Profex reads a wide and growing range of file formats. When running a refinement
on a scan file format not supported by BGMN, Profex will by default automatically convert the file
in the background and modify the control file accordingly. This section describes the conversion
process and the settings allowing the user to control the conversion.

Automatic scan file conversion can be switched on and off in the preferences dialog by checking
or unchecking the option ,,Edit→ Preferences. . .→ BGMN→ Convert raw scans to XY format”.
Scan file handling by Profex will be different depending on this setting. Unless conversion is not
desired for specific reasons, users are strongly advised to activate this option.

It is a surprisingly complex task to determine the correct file name of a project’s raw scan (VAL[n]
keyword in the control file). The possible scenarios to be considered are manifold. Profex has
sophisticated routines to determine the best guess for a VAL file name under all circumstances.
These routines are illustrated in Figures 22–25.

In principle, when creating a new project, a raw scan file as obtained from the instrument is opened
and a new control file is created either by using the ,,Add a new phase” dialog or the ,,Copy con-
trol file” function (see section 4). Either way the loaded raw scan file determines the location and
the base name of the project, and all input and output file names in the control file will automat-
ically be set to this scan’s file base name. More information on file name handling is given in
section 3.4.3. The scan file name to be read by the BGMN Rietveld backend is specified with the
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VAL[n]=ScanFile.xxx line in the control file. The scan file name is given by the project name,
as described above, but the file format and extension is determined by Profex automatically, de-
pending on the raw scan format and the setting of ,,Edit → Preferences. . .→ BGMN → Convert
raw scans to XY format”. If a format natively supported by BGMN is detected, the file will be used
without conversion. If the format is not supported, the behavior will depend on the setting ,,Con-
vert raw scans to XY format”: If active, the file will be converted to *.xy format and the VAL[n] file
entry will be adapted accordingly. If inactive, no conversion will be done and it is in the user’s
responsibility to guarantee correct file names and formats. See Fig. 21 for more explanations.

However, the processes described above represent relatively simple scenarios, when the raw scan
file is opened and the format and file name are known. In many situations it gets a lot trickier
to determine the correct file name. The following situation represents a worst case: A DIA file is
opened, conversion to *.xy is inactive, and the control file is created from another project using the
,,Copy control file” feature. Normally, when a DIA file exists, a control file should also exist with
a valid VAL[n] entry. However, when sharing or moving DIA files, or when the base name of the
DIA and control file do not match, it may still occur that a DIA file is present but the corresponding
control file cannot be located. Trying to find the correct raw scan file used to create die DIA file is
difficult in such a situation:

1. The control file copied over from another project contains input and output file names (VAL,
DIAGRAMM, OUTPUT, etc.) of the source project. All file names must be changed to the
destination project. The VAL file name found in this control file must not be used.

2. The displayed scan is a DIA file, which cannot be used as input file.

3. Converting the DIA file to *.xy is not allowed.

4. There is no reference to the raw scan in any of the available files.

5. In that case, Profex will scan the directory of the DIA file for a raw scan file in a format
natively supported by BGMN. But there is no guarantee that such a file is found.

This is one of many scenarios when finding the correct VAL file name is not trivial. However,
the complex processes illustrated in Figures 22–25 cover most situations, and if no solution can be
found, a warning will be issued.
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If the raw scan format (here: xrdml) is not natively supported by BGMN, Profex will change the
VAL[n] file name to *.xy and convert the file automatically.

working directory
scan 1.sav
scan 1.xrdml
structure 1.str
instrument.sav
instrument.geq
instrument.ger

% Input files
VAL[1]=scan 1.xy
VERZERR=instrument.geq
LAMBDA=CU
STRUC[1]=structure 1.str
% Output files
LIST=scan 1.lst
OUTPUT=scan 1.par
DIAGRAMM=scan 1.dia
...

If conversion to *.xy is deactivated, VAL[n] will be the raw scan file. If it is not supported natively
by BGMN (e. g. xrdml), refinement will not start.

working directory
scan 1.sav
scan 1.xrdml
structure 1.str
instrument.sav
instrument.geq
instrument.ger

% Input files
VAL[1]=scan 1.xrdml
VERZERR=instrument.geq
LAMBDA=CU
STRUC[1]=structure 1.str
% Output files
LIST=scan 1.lst
OUTPUT=scan 1.par
DIAGRAMM=scan 1.dia
...

Natively supported file formats (here: Seifert val) do not require conversion to *.xy. Profex will
use the raw scan file name for the VAL[n] entry, regardless of the state of the ,,Convert raw scans
to XY” setting.

working directory
scan 1.sav
scan 1.val
structure 1.str
instrument.sav
instrument.geq
instrument.ger

% Input files
VAL[1]=scan 1.val
VERZERR=instrument.geq
LAMBDA=CU
STRUC[1]=structure 1.str
% Output files
LIST=scan 1.lst
OUTPUT=scan 1.par
DIAGRAMM=scan 1.dia
...

Figure 21: Some examples for working and failing VAL[n] file scenarios.

74



Start ,,Generate de-
fault control file” in
,,Add Phase” dialog

Temporarily store pre-
vious VAL[n] = file

name if available

Apply control file con-
tent from template

Previous VAL file
name available?

VAL[n] = previous VAL file

VAL[n] = remains empty

Proceed to ,,Verify VAL file”

yes

no

Figure 22: VAL file handling when calling the ,,Add Phase” dialog and activating the option ,,Gen-
erate default control file” to create a control file from a template file.
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Start ,,Copy control file”
Temporarily store

file name of previous
VAL[n] = entry if available

Apply new con-
trol file content

Previous VAL[n] =
empty?

VAL[n] = previous VAL file

Convert to *.xy?
VAL[n] = dis-
played scan file

Disp. scan file =
native BGMN

format?

VAL[n] = dis-
played scan file

Search natively supported
file with the same base

name at the same location
as the displayed scan file

Alternative scan file
found?

VAL[n] = alter-
native scan file

Leave VAL[n] =

empty, display warning
Proceed to ,,VAL
file verification”

no

yes

yes

no

yes

no

yes

no

Figure 23: VAL file name handling when using the ,,Copy control file” function.
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Start ,,VAL file verification”

VAL[n] = empty?
VAL[n] = dis-
played scan file

Convert to *.xy?

Change basename of
VAL[n] file to project base-
name, keep extension and
format of previous entry

VAL[n] = native
BGMN format?

VAL[n] = file
exists?

Displayed scan
format native?

VAL[n] = dis-
played scan file

VAL[n] = pro-
jectBasename.xy

Proceed to ,,Cre-
ate VAL file”

yes

no

yes

no

yes

no

yes

no

yes

no

Figure 24: Automatic verification of a VAL[n] file entry in the SAV control file. This function is
called at several occasions when modifying the control file content. E. g. after creating
a default control file, or after applying a control file from another project.
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Start ,,Create VAL file”

VAL[n] = file exists
on hard disk?

Convert displayed
scan file to *.xy

Launch BGMN re-
finement process

yes

no

Figure 25: Immediately before running the refinement process, Profex checks whether the VAL
file referenced in the control file exists on the hard disk. If not, a *.xy file will be created
from the currently displayed scan file.
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A. Bundle File Structure

A.1. Windows

Profex-BGMN-Bundle-3.8.0.zip
BGMNwin

BGMN.EXE
MakeGEQ.EXE
...

Profex-3.8.0
Devices

Instrument 1.sav
Instrument 1.ger
Instrument 1.geq
Instrument 1.tpl
Instrument 2.sav
...

Structures
Structure 1.str
Structure 2.str
...

Presets
Preset 1.pfp
Preset 2.pfp
...

profex.exe
...

A.2. Mac OS X

Profex-BGMN-Bundle-3.8.0.dmg
Profex-BGMN

profex.app
BGMNwin

bgmn
makegeq
...

BGMN-Templates
Devices

Instrument 1.sav
Instrument 1.ger
Instrument 1.geq
Instrument 1.tpl
Instrument 2.sav
...

Structures
Structure 1.str
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Structure 2.str
...

Presets
Preset 1.pfp
Preset 2.pfp
...

A.3. Linux

No bundle is available for Linux.
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